Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WAN OSPF Load Balancing

Hi

I have a remote site which connects back 2 X 2Mbps back to headquarters. This is 2 point to point connections. I would like to load balance the data that is passing thru this link. Currently below is my router config :-

interface Serial0/0

bandwidth 2048

ip address 5.5.5.2 255.255.255.252

!

interface Serial0/1

bandwidth 2048

ip address 10.10.10.10 255.255.255.252

router ospf 1

log-adjacency-changes

redistribute static subnets

network XXX.XXX.XXX.XXX X.X.X.X area 0

maximum-paths 1

Currently with this config what happens is, data flows in thru one link and out thru the other.

I would like the data to share both links, both direction eg: 2mbps data is down loaded, it should share 1mbps per link.

Thank You

Best Regards.

Rushan

5 REPLIES
New Member

Re: WAN OSPF Load Balancing

Change your OSPF config from:

maximum-paths 1

to

maximum-paths 2

maximum-paths X, where X represents the number of paths OSPF will load balance over. Without this command I think OSPF can use upto 16 equal cost paths.

New Member

Re: WAN OSPF Load Balancing

Hi n.bowbridge,

Thank You Very much for your reply. I've done that but it seems like the load balance works in the below mentioned way.

Site A - Site B

Router Users Serial0 first for out going & Serial1 for incoming. Once out going S0 is max it will overflow to s1.

Site B - Site A

Router Users Serial1 first for out going & Serial0 for incoming. Once out going S1 is max it will overflow to s0.

What I would want to achive is Site a - Site b or vice versa

Router shares the load over both the links for incoming & out going.

router ospf 1

log-adjacency-changes

redistribute static subnets

network x.x.x.x x.x.x.255 area 0

maximum-paths 2

Thank You

Rushan

Bronze

Re: WAN OSPF Load Balancing

please add maximum-paths 2 in your config, and remove maximum-paths 1 from your config.

this will solve your problem, Please rate, if your problem solve

-Minu

Gold

Re: WAN OSPF Load Balancing

As others have stated you need maximum path 2 in ospf.

Now this only sorta makes it load balance and this is a function of the router (CEF) now and not the routing protocol you are running. You will have the same issue even if you had 2 equal cost static routes.

With traffic that contains many source and destination addresses that fairly evently share traffic you will get what appears to be a balanced link.

The symptom you are describing is what happens if there is for example a single large user that transfers data between 2 machines.

The default method for the router to load balance is per session. It will use the source and destination ip addresses to pick a path. Since this will always be the same it will pick the same path and not use the other one.

To help resolve this you can use

ip load-sharing per-packet

under both serial interfaces.

This still does not fully load balance since packet size will vary. The only way to truely get even load balance is to use layer 2. PPP multilink is a common method and is pretty much the only method if you have a none cisco router involved.

Hall of Fame Super Silver

Re: WAN OSPF Load Balancing

The obvious comment, as others have pointed out, is that with maximum paths set to 1 then only one link will be used and there will be no load sharing. There is another thing that strikes me about the original posting: under router ospf there was a single network statement. I am not clear whether the config was edited down to reduce size and there is really multiple network statements, and we do not know what address or mask were used in the network statement. But I am wondering if both serial interfaces really became OSPF interfaces. If the original poster would post the output of show ip ospf interface and the output of show ip ospf neighbor it would clear up this point.

To load share in this kind of OSPF environment both serial interfaces must be included in OSPF via network statement, both interfaces must be assigned to the same area, both interfaces must have the same OSPF cost (it will be assuming that both interfaces have the same bandwidth and that no ospf cost was configured on either interface)

HTH

Rick

564
Views
16
Helpful
5
Replies