Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WAN problem

I have a problem with my Internet connection a the link is flapping up and down. Below is the configuration that i have on the router and the errors that i am getting:

Current configuration : 2589 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname RTR1

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

ip cef

!

!

!

!

ip domain name yourdomain.com

vpdn enable

!

!

!

!

!

!

interface FastEthernet0/0

description **FROM_ASA**

ip address 10.x.x.x 255.255.255.248

ip nat inside

duplex auto

speed auto

!

interface FastEthernet0/1

description WAN Interface

no ip address

no ip unreachables

ip nat outside

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Serial0/1/0

no ip address

shutdown

clock rate 2000000

!

interface Dialer1

mtu 1492

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname iatadmn

ppp chap password 7 xxxxxx

ppp pap sent-username iatadmn password 7 xxxxx

!

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 10.0.0.0 255.0.0.0 10.7.221.5

!

ip http server

ip http authentication local

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface Dialer1 overload

!

access-list 1 permit 10.0.0.0 0.255.255.255

access-list 101 permit ip 10.7.0.0 0.0.255.255 any

access-list 101 permit ip 10.8.0.0 0.0.255.255 any

!

control-plane

!

!

line con 0

logging synchronous

login local

line aux 0

line vty 0 4

privilege level 15

logging synchronous

login local

transport input telnet

line vty 5 15

privilege level 15

logging synchronous

login local

transport input telnet

line vty 16 807

logging synchronous

login local

!

scheduler allocate 20000 1000

end

The errors are the following:

611: %DIALER-6-BIND: Interface Vi1 bound to profile Di1

*Aug 23 10:49:24.615: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to upterface Virtual-Access1, changed state to up

*Aug 23 07:47:22.763: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

*Aug 23 07:47:45.851: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

*Aug 23 07:48:48.939: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

.675: %LINK-3-UPDOWN: Interface Dialer1, changed state to up

2 REPLIES

Re: WAN problem

Hi,

You dont need natting outside on Fastethernet0/1 interface, you already have it on the Dialer Interface.

Check the link between your ADSl modem and Fastethernet0/1 , flapping here should result in flapping on the dialler as well.

HTH

Mohamed

Silver

Re: WAN problem

There are two things I'd look at in your configuration.

I'd make sure the PPP negotiation and authentication is succeeding. I think this is the most likely cause of the flapping if it is not a physical interface problem.

Otherwise, it looks like you have a dialer-group statement under the Dialer1 interface that is not associated with a dialer-list. Perhaps you simply did not include the dialer-list statement in the posted config. The dialer-group causes the Dialer1 interface to come up only if there is interesting traffic, specified by an access list, which is associated with a dialer-list. The dialer-group/dialer-list combination is usually used in a Dial-on-demand situation. If that is not your intent, I'd remove the dialer-group statement.

113
Views
0
Helpful
2
Replies