Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

WAN QoS and DSCP from LAN not recognised

I'm implementing QoS and encountered a problem where the router is not recognizing the DSCP information from the LAN.

On the LAN Switch port connected to the router I have:

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

mls qos trust dscp

auto qos voip trust

!

On the Router I have:

!

class-map match-any VOICE_BEARER_TRAFFIC

match ip dscp ef

class-map match-any VOICE_CONTROL_TRAFFIC

match ip dscp cs3  af31  cs5

!

policy-map WAN_OUT_CHILD

class VOICE_BEARER_TRAFFIC

    priority percent 10

class VOICE_CONTROL_TRAFFIC

    bandwidth percent 2

class class-default

    fair-queue

     random-detect

policy-map WAN_OUT_PARENT

class class-default

    shape average 1000000

  service-policy WAN_OUT_CHILD

!

interface GigabitEthernet0/0

bandwidth 1000

service-policy output WAN_OUT_TSTT_SANDO

!

However, when I do a "show policy int gig0/0" I get:

RTR#sh policy-map interface GigabitEthernet0/0

GigabitEthernet0/0

  Service-policy output: WAN_OUT_PARENT

    Class-map: class-default (match-any)

      343734 packets, 65366192 bytes

      5 minute offered rate 0 bps, drop rate 0 bps

      Match: any

      Queueing

      queue limit 64 packets

      (queue depth/total drops/no-buffer drops) 0/0/0

      (pkts output/bytes output) 343721/65278879

      shape (average) cir 1000000, bc 4000, be 4000

      target shape rate 1000000

      Service-policy : WAN_OUT_CHILD

        queue stats for all priority classes:

          queue limit 64 packets

          (queue depth/total drops/no-buffer drops) 0/0/0

          (pkts output/bytes output) 0/0

        Class-map: VOICE_BEARER_TRAFFIC (match-any)

          0 packets, 0 bytes

          5 minute offered rate 0 bps, drop rate 0 bps

          Match: ip dscp ef (46)

            0 packets, 0 bytes

            5 minute rate 0 bps

          Priority: 15% (150 kbps), burst bytes 3750, b/w exceed drops: 0

        Class-map: VOICE_CONTROL_TRAFFIC (match-any)

          0 packets, 0 bytes

          5 minute offered rate 0 bps, drop rate 0 bps

          Match: ip dscp cs3 (24) af31 (26) cs5 (40)

            0 packets, 0 bytes

            5 minute rate 0 bps

          Queueing

          queue limit 64 packets

          (queue depth/total drops/no-buffer drops) 0/0/0

          (pkts output/bytes output) 0/0

          bandwidth 3% (30 kbps)

        Class-map: class-default (match-any)

          239067 packets, 49815430 bytes

          5 minute offered rate 0 bps, drop rate 0 bps

          Match: any

          Queueing

          queue limit 64 packets

          (queue depth/total drops/no-buffer drops/flowdrops) 0/0/0/0

          (pkts output/bytes output) 239080/49822124

          Fair-queue: per-flow queue limit 16

            Exp-weight-constant: 9 (1/512)

            Mean queue depth: 0 packets

            class     Transmitted       Random drop      Tail/Flow drop Minimum Maximum Mark

                      pkts/bytes    pkts/bytes       pkts/bytes    thresh  thresh  prob

            0          239080/49822124        0/0              0/0                 20            40  1/10

            1               0/0               0/0              0/0                 22            40  1/10

            2               0/0               0/0              0/0                 24            40  1/10

            3               0/0               0/0              0/0                 26            40  1/10

            4               0/0               0/0              0/0                 28            40  1/10

            5               0/0               0/0              0/0                 30            40  1/10

            6               0/0               0/0              0/0                 32            40  1/10

            7               0/0               0/0              0/0                 34            40  1/10

All the traffic is shown in the default class, and nothing is being matched in the traffic classes configured.

If I look at the switch QoS statistics on the port that connected to the router I see classed traffic leaving and entering the switch port.

SW#sh mls qos interface gig0/1 statistics

GigabitEthernet0/1

  dscp: incoming 

-------------------------------

  0 -  4 :   890120760            0          115            0          106 

  5 -  9 :           0          120            0         7364            0 

10 - 14 :        5185            0         4264            0           26 

15 - 19 :           0          250            0         1583            0 

20 - 24 :           0            0         3803            0           16 

25 - 29 :           0         2640            0         3540            0 

30 - 34 :           0            0        56928            0      3875576 

35 - 39 :           0            4            0         3429            0 

40 - 44 :    26086277           42            0            0            0 

45 - 49 :           0    195433083            0     13143148            0 

50 - 54 :           0            0            0            0         1353 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            3 

  dscp: outgoing

-------------------------------

  0 -  4 :   868314905            0            0            0          286 

  5 -  9 :           0            0            0            0            0 

10 - 14 :           0            0            0            0            0 

15 - 19 :           0            1            0            0            0 

20 - 24 :           0            0            0            0            0 

25 - 29 :           0            0            0            0            0 

30 - 34 :           0            0        56916            0      4326017 

35 - 39 :           0            0            0            0            0 

40 - 44 :    12339636            0            0            0            0 

45 - 49 :           0    192006693            0     87391218            0 

50 - 54 :           0            0            0            0          358 

55 - 59 :           0            0            0            0            0 

60 - 64 :           0            0            0            0 

  cos: incoming 

-------------------------------

  0 -  4 :  1143645037            0            0            0            0 

  5 -  7 :           0            0            0 

  cos: outgoing

-------------------------------

  0 -  4 :   934164530            0            1            0            0 

  5 -  7 :      213672    254270653         7478 

What is going on? Why is traffic not being classed or recognised by the router?

Sachin

Everyone's tags (2)
3 REPLIES
Community Member

WAN QoS and DSCP from LAN not recognised

Hi,

no L3 node before the router  on the path ? you need to trust also his port

All link inter switch need to be trusted also, you need to trust any port who will inject the dscp traffic on your lan

you can made a packet capture on the router to verify the incoming traffic

http://www.cisco.com/en/US/products/ps10591/products_configuration_example09186a0080bf0163.shtml

Community Member

WAN QoS and DSCP from LAN not recognised

Nothing between the switch and the router. I will do a packet capture to determine if any DSCP headers are being sent.

Thanks for the reply.

Community Member

WAN QoS and DSCP from LAN not recognised

Sorry that I didn't update this. The problem was the Nortel phone weren't using COS, so I had to set it to trust DSCP on the phone interfaces as well (not just on the interfaces to the router). It was a simple configuration error.

Sachin

367
Views
5
Helpful
3
Replies
CreatePlease to create content