Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WAN QoS Questions

We are planing to implement the WAN QoS polic to apply on the routers for sites. They all are connected to our service provider via MPLS. We will make policy for voice, video and data. We have Cisco VoIP phones and some other equipments for voice, and have Polycom for video conferencing. There are 5 classes, one class will be configured for voice traffic and one class will be configured for video conferencing. For video conferencing, we are using ACL. We don't want the voice traffic from video conferencing falling into the voice class. My question is how to distinguish between voice traffic for VoIP phone, Polycom' video and voice for video traffic. Another question is it will be covered all voice traffic when using "match protocol RTP" Please advise.

Here is part of the qos config.

class-map match-any voice-traffic

match protocolRTP

!

class-map match-any video-traffic

match access-group 100

!

policy-map QOS

class voice-traffic

bandwidth percent 10

set ip dscp ef

class video-traffic

bandwidth percent 30

set ip decp af41

!

access-list 100 permit ip host 10.10.254.1 any

access-list 100 permit ip any host 10.10.254.1

access-list 100 permit ip host 10.10.253.1 any

access-list 100 permit ip any host 10.10.253.1

3 REPLIES
New Member

WAN QoS Questions

First of all you usually have a policy map to mark on the inbound LAN interface and then a policy on the outbound to set your percentages.

so lets say

Class-map match-any MARK_EF

Match access-group name MARK_EF

!

Class-map match-any MARK_AF41

Match access-group name MARK_AF41

!

Class-map match-any MARK_AF31

Match access-group name MARK_AF31

!

policy-map MARK_IN

!

class MARK_EF

set ip dscp ef

!

class MARK_AF41

set ip dscp af41

!

class MARK_AF31

set ip dscp af31

!

class class-default

set ip dscp default

ip access-list extended MARK_AF41 (Sample acl, this matches any dscp41,42,43,cs3 and telnet and resets to af41)

permit ip any any dscp af41

permit ip any any dscp af42

permit ip any any dscp af43

permit ip any any dscp cs3  

remark TELNET

permit tcp any any eq telnet

permit tcp any eq telnet any

Then something like this outbound, wred is optional.

class-map match-any COS-EF

match dscp ef

class-map match-any COS-AF41

match dscp af41

class-map match-any COS-AF31

match dscp  af31

policy-map COS_OUT

class COS-EF

   priority 256

class COS-AF41

     bandwidth remaining percent 40

     random-detect dscp-based

class COS-AF31

   bandwidth remaining percent 39

     random-detect dscp-based

class class-default

   bandwidth remaining percent 21

I believe in the polycom set up you can set your dscp for the voice and video to whatever you want, so if you set it to 41, then you could match on that or you could match on source ip address etc, just put it in acl.  I'm also not sure if you need to match on protocol rtp as most phones set dscp to ef so just match on dscp EF.  Which actually brings me to a question I have, is there any benefit to setting 2 classes with almost the same bandwidth?  I'm about to post that.

WAN QoS Questions

Hey Joe,

Not to offend you but I wont keep posting the same stuff all night.

Seems like today is World QOS day, never before had so many questions about this topic in such a short timespan.

Please look here, I believe  it also answers your questions:

https://supportforums.cisco.com/thread/2125467?tstart=0

regards,

Leo

WAN QoS Questions

about the media streams from the video endpoints

there should be an option to mark video and audio generated from the endpoint and then in the network you can treat as you want to

Cisco best practice is to mark the video and audio streams generated from VC endpoints same marking ( video marking ) AF41 this way it will not overlap with telephony VOIP marking

not sure if polycom has the option to mark the audi and video but Cisoc products they do have it

also make sure that your marking is being aligned with the MPLS service provider COS marking if you have purchased some qos classes from them

hope this help

if helpful Rate

573
Views
0
Helpful
3
Replies
CreatePlease to create content