Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

WAN router with QOS for specific IP's

I have a 3745 router with one Fa port. I configured two ip ranges on that port and I want to create QOS on the WAN link to guar. 10 megs of traffic. How can i set that up for one ip range? does anyone have any sample configs i can see?

3 REPLIES

Re: WAN router with QOS for specific IP's

Here's a working example. You will want to double check my bandwidth numbers.

access-list 185 permit ip 10.28.9.0 0.0.0.255 any

class-map match-all HR

match access-group 185

!

!

policy-map RestrictHR

class HR

police 10000000 50000 50000 conform-action transmit exceed-action drop violate-action drop

interface fa1

service-policy output RestrictHR

Community Member

Re: WAN router with QOS for specific IP's

now does that restrict all other IP's? I want to Guarantee lets say 7 megs to 32 ips. Now it can use more if needed. I want to give 13 megs to the rest but restrict that so it cannot go over 13 megs.

Hall of Fame Super Bronze

Re: WAN router with QOS for specific IP's

The configuration provided by Collin will restrict the flow from those IPs to 10Mbps.

If you want to guarantee bandwidth on egress, you will need CBWFQ and the syntax would be as followed:

access-list 101 permit ip [32 IPs] any

class-map QoS_WAN

match access-group 101

policy-map QoS_WAN

class QoS_WAN

bandwidth 7000

class class-default

bandwidth 13000

random-detect

interface fx/x

description WAN Facing Interface

service-policy output QoS_WAN

Why would you want to limit the remaining traffic to 13Mbps? If you aren't using the 7Mbps, ideally - you want to have the remaining traffic to use that bandwidth.

Regards,

Edison

294
Views
10
Helpful
3
Replies
CreatePlease to create content