Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

WAN routing

hello

I have router 2801 with two WAN link.

One is with static IP address, and the other is with dynamic IP.

One subnet (management user) use one WAN link (static IP),

second subnet use second WAN link.

I want to do these.

If one WAN link go down (link with static IP),

the other will route traffic for that subnet.

All traffic should go across other, active, link.

and when it came back, it will again route traffic for it subnet.

I hope you understand me.

How can i do that?

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: WAN routing

I checked your config one more time. It's failing because you aren't NATng for those addresses.

You have a "source list G-nat" for dialer0 and G-nat ACL isn't listing those IPs for translation.

HTH,

__

Edison.

13 REPLIES
Hall of Fame Super Bronze

Re: WAN routing

I believe I understand you, but I will understand you better if you post the config from the router. I believe you have a PBR configured on this device since you are doing source based routing but I want to make sure before giving you a recommendation.

__

Edison.

Community Member

Re: WAN routing

ok.

here is config...

regards..

Hall of Fame Super Bronze

Re: WAN routing

As suspected, you are using PBR.

The solution is simple. Simply add another set statement within your current route-map pointing to F0/0 interface.

The route-map will try the destination in order. Currently you have:

set interface FastEthernet0/1

set ip next-hop 80.65.75.1

just modify it like:

set interface FastEthernet0/1

set ip next-hop 80.65.75.1

set interface FastEthernet0/0

HTH,

__

Edison.

Community Member

Re: WAN routing

ok

i will try this. hope it will resolve my problem.

thank you again...

i will post you the results.

regards

Community Member

Re: WAN routing

hello

i was did as you say

after re-configuring route map, it arrange line like this (little difference related to your post):

route-map zaCito permit 10

match ip address zaCito

set interface FastEthernet0/1 FastEthernet0/0

set ip next-hop 80.65.75.1

is this ok, or there are tricks how to do this...

regards

Hall of Fame Super Bronze

Re: WAN routing

Interesting, the parser arranges the commands. Well, anyway - you have F0/1 before F0/0 so it should work. Have you test it ?

__

Edison.

Community Member

Re: WAN routing

yes, without success.

i was shoot down fa 0/1 and test it.

cant go out across other link.

i think i need another ip next hop, but how, it is internet packet with dynamic IP address...

Hall of Fame Super Bronze

Re: WAN routing

I checked your config one more time. It's failing because you aren't NATng for those addresses.

You have a "source list G-nat" for dialer0 and G-nat ACL isn't listing those IPs for translation.

HTH,

__

Edison.

Community Member

Re: WAN routing

ok

i will make nat and try again

will post you results

Community Member

Re: WAN routing

is this that:?

ip access-list extended G-nat

permit ip 172.16.3.0 0.0.0.255 any

permit ip 172.16.1.0 0.0.0.255 any

permit ip 172.16.4.0 0.0.0.255 any

deny ip any any

Community Member

Re: WAN routing

i got a result.

i was did exactly as You say:

route-map zaCito_rmp permit 10

match ip address zaCito_acl

set interface FastEthernet0/1 FastEthernet0/0

set ip next-hop 80.65.75.1 89.146.128.1

and i was add second ip next gateway.

Configure nat as You say and its work.

when shut fa 0/1 traffic go out through dialer

0.

NAT did as you say.

I thin that is it.

Thank You lot.

this is very helpful for me.

one more question:

will this config be ok...

route-map zaCito_rmp permit 10

match ip address zaCito_acl

set interface FastEthernet0/1

set ip next-hop 80.65.75.1

route-map zaCito_rmp permit 20

match ip address zaCito_acl

set interface FastEthernet0/0

set ip next-hop 89.146.128.1

regards

Hall of Fame Super Bronze

Re: WAN routing

one more question:

will this config be ok...

route-map zaCito_rmp permit 10

match ip address zaCito_acl

set interface FastEthernet0/1

set ip next-hop 80.65.75.1

route-map zaCito_rmp permit 20

match ip address zaCito_acl

set interface FastEthernet0/0

set ip next-hop 89.146.128.1

Yes, nested route-map will work as well.

Community Member

Re: WAN routing

thanks again, a lot...

i did nested route-map.

its work fine, for now.

thank for your time.

best regards

167
Views
0
Helpful
13
Replies
CreatePlease to create content