Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Wan routing

I am newbee to cisco technology and hence require your help in order to configure the router  for  the following  network  scenario

so  here  it  is

 ISP  WAN  IP  : - 1 72  .2 4 . X  . X/  3 0   ie  private  class IP

 ISP  Public  Lan  pool  : -  1 1 7 . 2 5 4  . X. X / 29  

 Inside private   Network -   192 .168.X.X

Now i would like to NAT my internal private network to the Public LAN Pool so that i can access inter through one of these IP and use rest for my other Public Devices.

Thanks in Advance,

6 REPLIES
New Member

yes you can use but you

yes you can use but kindly check with your ISP provider whether your LAN IP pool address visible from outside.

New Member

Thank-you ! for the revert,

Thank-you ! for the revert,

As per my ISP the Lan pool is visible from outside only when it is routed through the ISP WAN Next Hop,

New Member

Router1#enableRouter1

Router1#enable
Router1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router1(config)#access-list 10 permit 192.168.X.X 0.0.0.255
Router1(config)#ip nat pool Publicpool 117.254.X.X 117.254.X.X netmask 255.255.255.X
Router1(config)#ip nat inside source list 10 pool Publicpool overload
Router1(config)#interface fa0/0 - Inside Interface
Router1(config-if)#ip nat inside
Router1(config-if)#exit
Router1(config)#int fa0/1 - Outside Interface
Router1(config-if)#ip nat outside
Router1(config-if)#exit
Router1(config)#exit
Router1#

Please have default route pointed to ISP WAN IP

ip route 0.0.0.0 0.0.0.0 172.24.X.X

if this still not working - Configure loop back with public pool ip address and try to ping any of the internet ip address with source of loopback address to see interfnet is working 

Configuration

Router1#interface loopback 1

Router1#ip address 117.254.X.X 255.255.255.X

Excute to below command : 

ping 4.4.4.4 source loopback 1

If it doesn't work - Please share me the router configuration.

New Member

Ravikant, can please rephrase

Ravikant, can please rephrase the last paragraph. I think you will need ip nat inside from what I understand but need to clarify what you want to do. Thanks!

New Member

Dear Saji,

Dear Saji,

All I want to do is to access internet without changing my existing internal network configuration,

ie I want to access internet through client systems having Ip address 192.168.X.X . I am not able to so by normal configuration since the WAN IP I have been given is a Private Class IP address.

Thanks.

New Member

Hi Ravikant,

Hi Ravikant,

Your internal IP range looks fine.
The external IP pool range and your pulic IP address is something I need clarification on.

Question 1) Is your public IP and the pool of IP's you have got from ISP in the same range or different?
Question 2) How many public IPs do you have. One or more?

Thanks!
Saji

61
Views
0
Helpful
6
Replies