Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Weird NBAR issue

Hi all....hope i didnt miss anything simple here...but have an nbar issue...sorry if this is long winded....just wanted to provide info.

i have ip nbar protocol-discovery on my interfaces along with cef.  when i do a sh ip nbar protocol-discovery stats bit-rate top 10....i get the following output....with no data on s0/0

nbar1.png

however...when i do the command with out stats bit-rate i get data on s0/0:   (Ignore the edonkey....i think it is ftp...is on a lab set up so I know there is no file sharing going on).

the lab is set up with 2 routers connected via t1.

nbar2.png

I think it is messing with my testing of traffic shaping ....i am using the following class maps and policy map on my serial 0/0 but am not getting the shaping i would expect.

Class Map match-any PRIORITY_BUSINESS (id 12)

   Match access-group name HTTP_ADP

   Match access-group name SOARR

   Match access-group name TELNET

   Match access-group name FTP

Class Map match-any WWW (id 16)

  Match access-group name HTTP_HTTPS

Class Map match-any VOICE_OUT (id 10)

   Match access-group name RTP

R2-3725#sh policy-map

  Policy Map EGRESS_TRAFFIC

    Class DAY

      Traffic Shaping

         Average Rate Traffic Shaping

         CIR 1500000 (bps) Max. Buffers Limit 1000 (Packets)

      service-policy HQ_REMOTES

    Class LIMA

      Traffic Shaping

         Average Rate Traffic Shaping

         CIR 1500000 (bps) Max. Buffers Limit 1000 (Packets)

      service-policy HQ_REMOTES

  Policy Map HQ_REMOTES

    Class VOICE_OUT

      Bandwidth 30 (%) Max Threshold 64 (packets)

    Class PRIORITY_BUSINESS

      Bandwidth 30 (%) Max Threshold 64 (packets)

    Class WEB

      Bandwidth 20 (%) Max Threshold 64 (packets)

    Class class-default

appreciate any advise you have.

Thanks

2 REPLIES
Community Member

Re: Weird NBAR issue

figured out the issue....appears to have been a bug in the ios code i was running...upgraded ios and issue has gone away.

Hall of Fame Super Silver

Re: Weird NBAR issue

Hello Mark,

you have been kind in providing a feedback on this issue

this makes this thread a complete story.

if you like you can add the Cisco bug-id that was causing this issue

Best Regards

Giuseppe

178
Views
5
Helpful
2
Replies
CreatePlease to create content