Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

What does the GRE "adjacency fixup" message mean and imply?

Hey,

I can't find documentation on this message:

*May  8 10:05:06: Tunnel114: adjacency fixup, 10.100.111.4->10.100.11.21, tos set to 0x60

Does anyone know why these messages show up and what they imply for routing through the GRE tunnel?

Thanks,

Joey

Everyone's tags (5)
3 REPLIES
Cisco Employee

What does the GRE "adjacency fixup" message mean and imply?

Hello Joey,

According to the document at

http://www.cisco.com/en/US/docs/ios_xr_sw/iosxr_r3.4/troubleshooting/guide/tr34fwd.html

"Fixup  is a direct pointer to a routine in the output path after a CEF  rewrite. this is an optimized path if a CEF rewrite exists and can be  used."

It seems that this adjacency fixup is related to an optimization of the CEF rewrite process (replacing a double rewrite with a single rewrite - just my guess here). In order to understand better the message you have received on your console, can you explain in more details what are the IP addresses 10.100.111.4 and 10.100.11.21? Are the in any way related to the tunnel source/destination? Do they appear as next-hop IP addresses for some route?

Best regards,

Peter

New Member

What does the GRE "adjacency fixup" message mean and imply?

This is sort of a "kiosk" deployment. We are using GRE tunnels to connect the Kiosks through to HQ. We have 9 tunnels per Kiosk.

The addresses are exactly the source and destination addresses of Tunnel114. This configuration is on the Kiosk router. I've shown two GRE tunnels going through the EZYVPN:

 

!On Kiosk Router:

!
interface Loopback114
ip address 10.100.11.21 255.255.255.252
!
interface Loopback115
ip address 10.100.11.25 255.255.255.252
!
...

!

interface Tunnel114

ip unnumbered Loopback114

tunnel source Loopback114

tunnel destination 10.100.111.4

!

interface Tunnel115

ip unnumbered Loopback115

tunnel source Loopback115

tunnel destination 10.100.111.5

!

...

!Routing into tunnel:

!

ip route 10.4.1.95 255.255.255.255 Tunnel114

ip route 10.4.1.96 255.255.255.224 Tunnel114

ip route 10.4.1.128 255.255.255.224 Tunnel114

ip route 10.4.1.160 255.255.255.224 Tunnel114

ip route 10.4.1.192 255.255.255.224 Tunnel114

ip route 10.4.1.224 255.255.255.224 Tunnel114

ip route 10.5.1.95 255.255.255.255 Tunnel115

ip route 10.5.1.96 255.255.255.224 Tunnel115

ip route 10.5.1.128 255.255.255.224 Tunnel115

ip route 10.5.1.160 255.255.255.224 Tunnel115

ip route 10.5.1.192 255.255.255.224 Tunnel115

ip route 10.5.1.224 255.255.255.224 Tunnel115

 

 

!On the HQ Router:

!

interface Loopback114

ip address 10.100.111.4 255.255.255.255

!

interface Loopback115

ip address 10.100.111.5 255.255.255.255

!

...

!

interface Tunnel114

ip unnumbered Loopback114

ip policy route-map Tunnel14_FromKiosk

tunnel source Loopback114

tunnel destination 10.100.11.21

!

interface Tunnel115

ip unnumbered Loopback115

ip policy route-map Tunnel15_FromKiosk

tunnel source Loopback115

tunnel destination 10.100.11.25

!

 

The policy maps traffic from a tunnel to a specific subinterface at HQ:

route-map Core11_FromKiosk permit 10

   match interface Tunnel114

   set interface FastEthernet0/0.1111

!

 

Thanks for your time.

 

 

Joey

New Member

What does the GRE "adjacency fixup" message mean and imply?


By the way, if I turn off CEF then the adjacency fixup messages go away. So your premise seems certianly correct.

1994
Views
0
Helpful
3
Replies
CreatePlease login to create content