Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

What is the best way to get range of ports NATted to inside server?

                   So my external is 72.186.194.70 /18 and I need ports tcp/udp 27000 through 27040 and 1200 forwarded to internal host 192.168.1.3.

I already have overload for internal hosts running on NAT. How do I change the destination IP on its way in and keep the port numbers the same ?

Building configuration...

Current configuration : 1462 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname HEADEND
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$jnHd$I0NUfO3VZdfYg2UV4LdTu1
!
no aaa new-model
memory-size iomem 15
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
ip name-server 65.32.5.111
ip name-server 192.168.1.75
ip name-server 65.35.5.112
ip name-server 192.168.1.76
!
!
!
username Derek privilege 15 secret 5 $1$nINc$vitl9FyVgzNxLDzRC6jJW.
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.254 255.255.255.0
ip nat inside
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 dhcp
!
ip http server
no ip http secure-server
ip nat pool OUTSIDE 72.186.194.70 72.186.194.70 netmask 255.255.192.0
ip nat pool SRCDS_Server 192.168.1.3 192.168.1.3 netmask 255.255.255.0
ip nat inside source list NATTY pool OUTSIDE overload
!
ip access-list extended NATTY
permit ip 192.168.1.0 0.0.0.255 any
ip access-list extended PUBLICIP
permit tcp any range 27000 27040 any range 27000 27040
permit tcp any eq 1200 any eq 1200
!
route-map PUBLICIP permit 10
!
route-map SRCDS_Server permit 10
match ip address PUBLICIP
set ip next-hop 192.168.1.3
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login local
transport input telnet
!
!
end

1 REPLY
Purple

What is the best way to get range of ports NATted to inside serv

Hi Derek,

Duplicate post. You have already asked that question and we began replying so it would be great if you kept the same thread and continue the discussion we started.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
98
Views
0
Helpful
1
Replies
CreatePlease to create content