Cisco Support Community
Community Member

Where are the Controller t1 commands?

I am trying to run a BERT across our T1 but the "controller t1 0/0/0" command is not available.   What am I missing?

Thank you.

The output of sh controllers t1 is empty.

My hardware is a 2811 with a 1DSU-T1V2 HWIC.

My IOS is c2800nm-adventerprisek9-mz.124-24.T2.  I tried IPBase and AdvIPServices as well.

Here is the procedure I'm trying to execute.



configure terminal

controller t1 slot/subslot/port <-----this command is not available.

bert pattern pattern interval time

Configure bert patterns on T1/E1 HWICs or network module as follows:

• When the linecode is AMI, use patterns 2^11, 2^15, or 2^20-QRSS.

• When the linecode is b8zs or hdb3, use patterns 2^11, 2^15, 2^20-QRSS, or 2^20-O.153.

(2^15 is typical for T1, some tests on the 7206 can go up to 2^23)

interval time is from 1 to 14,400 minutes.

Note that the interface will show down/down, but when you check results, you will see the BERT running and sync will be detected


show controllers t1 slot/subslot/port bert

T1 1 is down, speed: 1536 kbs, non-inverted data

  timeslots: 1-24

  FDL per ANSI T1.403 and AT&T 54016 spec.

  Configured for FDL Remotely Line Looped

  No alarms detected.

  Framing is ESF, LineCode is B8ZS, Clock Source is Internal.

  BERT test result (running)

      Test Pattern: All 0's, Status: Sync, Sync Detected: 1

      Interval: 4 minute(s), Time Remain: 4 minute(s)

      Bit Errors (Since BERT Started): 0 bits

      Bit Errors (Since last Sync): 0 bits, Bits Received: 7 Mbits

Hall of Fame Super Gold

Re: Where are the Controller t1 commands?


Would I assume that this is a new router that you are just configuring or is it an existing/working router?

I believe that for this router and this card that the controller t1 command only becomes available after you have configured the card type t1 command.



Community Member

Re: Where are the Controller t1 commands?


I tried it on 2 different 2811s.  Once fresh out of the box and one that's currently in production.  No joy.

The "card type t1" command is not available either.  I assumed that is because the HWIC is a T1 CSU...I assume that means it won't support E1.


Hall of Fame Super Gold

Re: Where are the Controller t1 commands?


I thought that I had a similar card in a 2811 that did need the card type command. But when I look at the router is is not the same card.

If the card type command is not available does the serial interface show up in  your running config? If so I wonder if the functionality that you want might be available through the service-module commands. Is the service-module available in your config in interface config mode?



Community Member

Re: Where are the Controller t1 commands?

I looked in the interface at the service-module commands but didn't see any bert commands.

Re: Where are the Controller t1 commands?


If I'm not wrong the card you have is a successor of the old T1 Card (only applicable to North American Circuits) where as the t1 controller command, I guess comes from the T1/E1 Cards which these days should be the MFT Cards.

Do you happen to have any MFT Card with you? You may be able to look at the MFT cards at

Also, please notice that, the card WIC-1DSU-T1-V2 seems to be listed under the WAN Serial Cards though the MFT Cards can do the T1 / E1 job, to me it seems that MFT cards have more features (ofcourse I'm not just including the Voice feature).


Please rate if it helps


Sam Wilson

CreatePlease to create content