Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Which vlan fa0/1/24 is associated with?

Just curious:

In a 3750 switch, I see in the 'show run' Vlan 1 is configured as 1.1.1.1 IP address.

Why the 'show vlan' below doesn't show fa0/1/24 associated with Vlan1 then? In which vlan is port fa0/1/24 associated with then??

Switch#show vlan

VLAN Name Status Ports

---- -------------------------------- --------- ------------------------------

1 default active Fa1/0/1, Fa1/0/2, Fa1/0/3

Fa1/0/4, Fa1/0/5, Fa1/0/6

Fa1/0/7, Fa1/0/8, Fa1/0/9

Fa1/0/10, Fa1/0/11, Fa1/0/12

Fa1/0/13, Fa1/0/14, Fa1/0/15

Fa1/0/16, Fa1/0/17, Fa1/0/18

Fa1/0/19, Fa1/0/20, Fa1/0/21

Fa1/0/22, Fa1/0/23, Gi1/0/1

Gi1/0/2

1002 fddi-default act/unsup

1003 token-ring-default act/unsup

1004 fddinet-default act/unsup

1005 trnet-default act/unsup

Switch#

Switch#show ip int brief

Interface IP-Address OK? Method Status Protoc

Vlan1 1.1.1.1 YES NVRAM up up

FastEthernet1/0/1 unassigned YES unset down down

FastEthernet1/0/2 unassigned YES unset down down

FastEthernet1/0/3 unassigned YES unset down down

FastEthernet1/0/4 unassigned YES unset down down

FastEthernet1/0/5 unassigned YES unset down down

FastEthernet1/0/6 unassigned YES unset down down

FastEthernet1/0/7 unassigned YES unset down down

FastEthernet1/0/8 unassigned YES unset down down

FastEthernet1/0/9 unassigned YES unset down down

FastEthernet1/0/10 unassigned YES unset down down

FastEthernet1/0/11 unassigned YES unset down down

FastEthernet1/0/12 unassigned YES unset down down

FastEthernet1/0/13 unassigned YES unset down down

FastEthernet1/0/14 unassigned YES unset down down

FastEthernet1/0/15 unassigned YES unset down down

FastEthernet1/0/16 unassigned YES unset down down

FastEthernet1/0/17 unassigned YES unset down down

FastEthernet1/0/18 unassigned YES unset down down

FastEthernet1/0/19 unassigned YES unset down down

FastEthernet1/0/20 unassigned YES unset down down

FastEthernet1/0/21 unassigned YES unset down down

FastEthernet1/0/22 unassigned YES unset down down

FastEthernet1/0/23 unassigned YES unset down down

FastEthernet1/0/24 unassigned YES unset up up

GigabitEthernet1/0/1 unassigned YES unset down down

GigabitEthernet1/0/2 unassigned YES unset down down

Switch#

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Which vlan fa0/1/24 is associated with?

Marlon

This additional output is quite helpful. It answers my question about trunking - and shows that I did not really ask quite the right question. In your switch there is no configuration of trunking. But trunking negotiation is enabled as shown by:

Negotiation of Trunking: On

The Administrative Mode is dynamic auto and the Operational Mode is trunk. So it looks as though the neighbor has requested trunking using ISL.

So it all looks ok to me. And explains nicely why fa1/0/24 does not show up in the ports in vlan 1 because trunk ports do not show up as members of the VLAN.

HTH

Rick

6 REPLIES
Hall of Fame Super Silver

Re: Which vlan fa0/1/24 is associated with?

Marlon

I do not believe that you have given us sufficient detail to be able to answer your question. The fact that show vlan does not indicate that fa1/0/24 is in any VLAN makes me assume that the interface is not configured as an access port (in some VLAN) but is configured as a routed port. But the output of show ip interface brief does not indicate that the port has been assigned an IP address. So I am guessing that it is a routed port without any IP address. Perhaps you can post the output of show run for the interface. This would help us to resolve your question.

HTH

Rick

New Member

Re: Which vlan fa0/1/24 is associated with?

As you can see, there is no configuration related to the port fa0/1/24 making it a no switchport (layer 3). Ah, I think if the 'no switchport' was issued on fa0/1/24, that should not show up in the 'show run', right?

Switch#show run

Building configuration...

Current configuration : 1375 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

(...)

interface FastEthernet1/0/9

!

interface FastEthernet1/0/10

!

interface FastEthernet1/0/11

!

interface FastEthernet1/0/12

!

interface FastEthernet1/0/13

!

interface FastEthernet1/0/14

!

interface FastEthernet1/0/15

!

interface FastEthernet1/0/16

!

interface FastEthernet1/0/17

!

interface FastEthernet1/0/18

!

interface FastEthernet1/0/19

!

interface FastEthernet1/0/20

!

interface FastEthernet1/0/21

!

interface FastEthernet1/0/22

!

interface FastEthernet1/0/23

!

interface FastEthernet1/0/24

!

interface GigabitEthernet1/0/1

!

interface GigabitEthernet1/0/2

!

interface Vlan1

ip address 1.1.1.1 255.255.255.0

!

ip classless

ip http server

!

!

(...)

New Member

Re: Which vlan fa0/1/24 is associated with?

Well, if I do 'no switchport' in reality I see that it should appear in thet 'show run'...

Hall of Fame Super Silver

Re: Which vlan fa0/1/24 is associated with?

Marlon

Yes, if you do no switchport that command should show up in the running config. The interface should always show up in the running config, whether it is a switch port or a routed port.

If the output of show run was the original configuration then I am quite puzzled about fa1/0/24. From that configuration I would assume that it was a member of the VLAN. I do not understand why it is not included in the output of show vlan. I notice that it is the only interface that shows as being up. Can you tell us what is connected to that interface? Also is there any configuration of trunks in that configuration?

HTH

Rick

New Member

Re: Which vlan fa0/1/24 is associated with?

If I do 'show cdp neig detail', I see that I have a 3550 switch connected to that port fa1/0/24.

The if I do 'show int fa1/0/24 switchport', I get the output below. The only thing unusual I see is that it is doing isl (instead of dot1q). Not sure if the below can clarify this(?)

Name: Fa1/0/24

Switchport: Enabled

Administrative Mode: dynamic auto

Operational Mode: trunk

Administrative Trunking Encapsulation: negotiate

Operational Trunking Encapsulation: isl

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Hall of Fame Super Silver

Re: Which vlan fa0/1/24 is associated with?

Marlon

This additional output is quite helpful. It answers my question about trunking - and shows that I did not really ask quite the right question. In your switch there is no configuration of trunking. But trunking negotiation is enabled as shown by:

Negotiation of Trunking: On

The Administrative Mode is dynamic auto and the Operational Mode is trunk. So it looks as though the neighbor has requested trunking using ISL.

So it all looks ok to me. And explains nicely why fa1/0/24 does not show up in the ports in vlan 1 because trunk ports do not show up as members of the VLAN.

HTH

Rick

173
Views
0
Helpful
6
Replies
CreatePlease to create content