Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Why am I no longer routing over static routes

Here is our set up-

We have 2 point to point t1's going from router A to Router B. We also have an aironet that we are testing pointing at each other which are connected to router A and B. Before we began turning up the aironet..a show ip route displayed both t1's as the preferred route. Now however, on router A , the f0/1 is the preferred route. (thats where the airnoet is connected on one). BUT the t1's are still shown on router B as the preferred route.

ospf neighbors are showing each other as full neighbors via the t1's and the fast ethernets wich connect the aironets

Router A has the 192.168.1.0 subnet

Router B has the 192.168.2.0 subnet

please review

(router A is showing the aironet via fe0/1)

ROUTER A#sh ip route 192.168.2.0

Routing entry for 192.168.2.0/24

Known via "ospf 711", distance 110, metric 8, type intra area

Last update from 192.168.255.130 on FastEthernet0/1, 1d02h ago

Routing Descriptor Blocks:

* 192.168.255.130, from 192.168.255.130, 1d02h ago, via FastEthernet0/1

Route metric is 8, traffic share count is 1

router a is showing the 2 t1's

Router B#sh ip route 192.168.1.0

Routing entry for 192.168.1.0/24

Known via "static", distance 1, metric 0

Routing Descriptor Blocks:

* 192.168.100.253

Route metric is 0, traffic share count is 1

192.168.100.249

Route metric is 0, traffic share count is 1

Here is some config for router

interface Serial0/0

description "t1 to router b"

ip address 192.168.100.253 255.255.255.252

no ip route-cache

ip ospf cost 45000

no fair-queue

!

interface Serial0/1

description "t1 to router B"

ip address 192.168.100.249 255.255.255.252

no ip route-cache

ip ospf cost 45000

no fair-queue

interface FastEthernet0/1

description "wirelless conn."

ip address 192.168.255.129 255.255.255.248

no ip route-cache

ip ospf cost 7

ip ospf hello-interval 5

ip ospf dead-interval 30

duplex auto

speed auto

router ospf 100

router-id 192.168.21.236

log-adjacency-changes

redistribute connected subnets

network 192.168.1.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 1

network 192.168.118.0 0.0.0.255 area 1

network 192.168.255.0 0.0.0.255 area 1

dialer-list 1 protocol ip permit

route-map wireless permit 10

match ip address 121

set interface FastEthernet0/0

!

route-map wireless permit 20

match ip address 122

set ip next-hop 192.168.255.130

!

route-map wireless permit 30

The .130 address is the FE address of router B

Now router B config

interface FastEthernet1/1

description "wireless conn"

ip address 192.168.255.130 255.255.255.248

no ip route-cache

ip ospf cost 7

ip ospf hello-interval 5

ip ospf dead-interval 30

duplex auto

speed auto

interface Serial1/0/0:0

description "t1 to router a"

ip address 192.168.100.254 255.255.255.252

no ip route-cache

ip ospf cost 45000

no fair-queue

!

interface Serial1/0/1:0

description "t1 to router A"

ip address 192.168.100.250 255.255.255.252

no ip route-cache

ip ospf cost 45000

no fair-queue

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

redistribute bgp 65213 subnets

network 192.168.2.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 1

network 192.168.118.0 0.0.0.255 area 1

network 192.168.255.0 0.0.0.255 area 1

!

ip route 192.168.1.0 255.255.255.0 192.168.100.249

ip route 192.168.1.0 255.255.255.0 192.168.100.253

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Silver

Re: Why am I no longer routing over static routes

Richard

Based on the config that you posted I would say that the route map is not doing anything.

HTH

Rick

9 REPLIES
New Member

Re: Why am I no longer routing over static routes

I see no static ip route command in router A.

But when i shut down the interface that the aironet is connected too. this comes is the iproute

sho ip route

Routing entry for 192.168.2.0/24

Known via "ospf 100", distance 110, metric 45001, type intra area

Last update from 192.168.100.254 on Serial0/0, 00:00:07 ago

Routing Descriptor Blocks:

* 192.168.100.250, from 192.168.255.130, 00:00:07 ago, via Serial0/1

Route metric is 45001, traffic share count is 1

192.168.100.254, from 192.168.255.130, 00:00:07 ago, via Serial0/0

Route metric is 45001, traffic share count is 1

(the ospf process was edited to 100 instead of the original..but i missed one edit :-) )

Hall of Fame Super Silver

Re: Why am I no longer routing over static routes

Richard

There are several aspects of this and I am not sure where to start and how far to go.

So I will observe first that router B has static routes which point at the T1 interfaces. It does not matter what OSPF does on that router, a normal static route is preferred to an OSPF route. So that is why router B is using the T1s.

I will then observer that from what you post (though it is incomplete and therefore hard to know what might be missing that is affecting the behavior) there is no static route on router A. So the routing decision on router A is made by OSPF. You set a very low metric on the interface to the wireless (7) which makes it very attractive and you set a pretty high metric on the serial interfaces. So OSPF prefers the wireless. And if you shut down the wireless then the T1s with a higher metric are selected. OSPF is behaving just as it should, given the metrics that you have set.

If there are other aspects that you want to discuss or if some of this is not clear then please ask a further question.

HTH

Rick

New Member

Re: Why am I no longer routing over static routes

Looks like the static route on router B is what is causing this. Static routes always have a higher priority than dynamic routes.

New Member

Re: Why am I no longer routing over static routes

correct-After reviewing the config, there only seems to be one static route configuration-which is on router B. Having said that- Is it possible

to configure 3 interfaces using ospf cost on one router?-or is there a limit of interfaces you can configure with ospf cost

The scenario we would like-Traffic going over the wireless. If the wireless should fail-traffic should be re-routed over the 2-t1's.

also-do the route-maps look like they are "doing anything" in this configuration of router A?

Hall of Fame Super Silver

Re: Why am I no longer routing over static routes

Richard

There is not any hard limit on the number of router interfaces that can be configured in OSPF. And certainly any interface configured in OSPF can be configured with its own cost if you wish - there is no limit on the number of OSPF costs that can be configured. So yes you certainly can configure 3 interfaces on one router to be in OSPF and each interface to have a cost configured.

The route map is one of the things I was referring to when I commented that there were many aspects that could be discussed and I did not know how far to go. The wireless route map would appear to be set up to do Policy Based Routing. But there is no assignment of PBR in what you posted. So based on what is posted the route map is not doing anything. Only you are a position to know if there is anything in the configs that was not posted and which would use the route map.

HTH

Rick

New Member

Re: Why am I no longer routing over static routes

hmm, Im not sure the maps are doing anything,

how bout you?..here is the conf

RouterA#sh run

!

boot-start-marker

boot-end-marker

!

no aaa new-model

ip subnet-zero

no ip cef

!

!

!

no ftp-server write-enable

!

!

!

policy-map wireless

!

!

!

interface FastEthernet0/0

ip address 192.168.1.236 255.255.255.0 secondary

ip address 192.168.21.236 255.255.255.0

no ip route-cache

speed 100

full-duplex

!

interface Serial0/0

description

ip address 192.168.100.253 255.255.255.252

no ip route-cache

ip ospf cost 45000

no fair-queue

!

interface FastEthernet0/1

ip address 192.168.255.129 255.255.255.248

no ip route-cache

ip ospf cost 7

ip ospf hello-interval 5

ip ospf dead-interval 30

duplex auto

speed auto

!

interface Serial0/1

description

ip address 192.168.100.249 255.255.255.252

no ip route-cache

ip ospf cost 45000

no fair-queue

!

router ospf 100

router-id 192.168.21.236

log-adjacency-changes

redistribute connected subnets

network 192.168.1.0 0.0.0.255 area 1

network 192.168.100.0 0.0.0.255 area 1

network 192.168.118.0 0.0.0.255 area 1

network 192.168.255.0 0.0.0.255 area 1

!

ip classless

!

access-list 21 permit 192.168.21.0 0.0.0.255

access-list 25 permit 192.168.0.0 0.0.255.255

access-list 121 permit ip 192.168.21.0 0.0.0.255 192.168.1.0 0.0.0.255

access-list 122 permit ip 192.168.21.0 0.0.0.255 any

dialer-list 1 protocol ip permit

route-map wireless permit 10

match ip address 121

set interface FastEthernet0/0

!

route-map wireless permit 20

match ip address 122

set ip next-hop 192.168.255.130

!

route-map wireless permit 30

!

line con 0

!

!

end

Hall of Fame Super Silver

Re: Why am I no longer routing over static routes

Richard

Based on the config that you posted I would say that the route map is not doing anything.

HTH

Rick

New Member

Re: Why am I no longer routing over static routes

thx.

I think the current network situation is confusing me more

Hall of Fame Super Silver

Re: Why am I no longer routing over static routes

Richard

I agree that there seem to be several aspects of the network that are confusing. I am glad that our answers have been helpful to you in understanding it. Thank you for using the rating system to indicate that your question was resolved (and thanks for the rating). It makes the forum more useful when people can read a question and can know that they will read answers that helped to resolve the question.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

170
Views
4
Helpful
9
Replies