Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Why can't I ping the loopback interfaces?

Hi, can you help me with this.

From WG4R3 I can't ping Lo0 and Lo1 on WG4R2 and vice and versa. I advertise the respective networks Lo0 and Lo1 via OSPF, so I am not sure if I can understand what's going on. My ultimate goal is to ping lo0:192.20.11.1 on router "Good".

1 ACCEPTED SOLUTION

Accepted Solutions
Hall of Fame Super Bronze

Re: Why can't I ping the loopback interfaces?

In R2, you have the following OSPF configuration:

router ospf 4

log-adjacency-changes

network 192.168.4.0 0.0.0.3 area 0

network 192.168.34.0 0.0.0.255 area 0

network 197.4.2.0 0.0.0.255 area 0

network 197.4.3.0 0.0.0.255 area 0

And you have the following L3 interfaces:

interface Loopback0

ip address 197.4.2.1 255.255.255.0

!

interface Loopback1

ip address 197.4.3.1 255.255.255.0

!

interface Ethernet0

ip address 192.168.4.5 255.255.255.252

interface Serial0.1 multipoint

ip address 192.168.4.2 255.255.255.252

interface Serial0.2 point-to-point

ip address 192.168.34.1 255.255.255.0

Noticed, how E0 is missing within the OSPF process? That's the reason there is no neighbor between R2 and R3. You need:

network 192.168.4.4 0.0.0.3 area 0

On R2.

As for changing the frame-relay interface type, you have 2 options:

1) Delete the interface with:

no interface Serial0.1 multipoint

then reboot and recreate the interface.

2) Create another interface with a different number:

no interface Serial0.1 multipoint

interface Serial0.10 point-to-point

ip address 192.168.4.2 255.255.255.252

frame-relay interface-dlci 221

HTH,

__

Edison.

4 REPLIES
Hall of Fame Super Bronze

Re: Why can't I ping the loopback interfaces?

Based on the output provided,

WG4R3#show ip ospf neig

Neighbor ID Pri State Dead Time Address Inter

197.4.7.1 0 FULL/ - 00:00:30 192.168.4.10 Seria

I don't see WG4R2 listed as OSPF neighbor, just WG4R4 is listed.

Verify connectivity between these routers and please post the WG4R2 config for further help.

__

Edison.

New Member

Re: Why can't I ping the loopback interfaces?

Please find attached run config for all routers (WG4R1 thru WG4R4).

One thing that I noticed is that on WG4R2, there is a s0.1 interface configured as multipoint. I tried to do it as 's0.1 point-to-point' but that was not accepted by the IOS. I got message saying that 'type cannot be changed'.

Hall of Fame Super Bronze

Re: Why can't I ping the loopback interfaces?

In R2, you have the following OSPF configuration:

router ospf 4

log-adjacency-changes

network 192.168.4.0 0.0.0.3 area 0

network 192.168.34.0 0.0.0.255 area 0

network 197.4.2.0 0.0.0.255 area 0

network 197.4.3.0 0.0.0.255 area 0

And you have the following L3 interfaces:

interface Loopback0

ip address 197.4.2.1 255.255.255.0

!

interface Loopback1

ip address 197.4.3.1 255.255.255.0

!

interface Ethernet0

ip address 192.168.4.5 255.255.255.252

interface Serial0.1 multipoint

ip address 192.168.4.2 255.255.255.252

interface Serial0.2 point-to-point

ip address 192.168.34.1 255.255.255.0

Noticed, how E0 is missing within the OSPF process? That's the reason there is no neighbor between R2 and R3. You need:

network 192.168.4.4 0.0.0.3 area 0

On R2.

As for changing the frame-relay interface type, you have 2 options:

1) Delete the interface with:

no interface Serial0.1 multipoint

then reboot and recreate the interface.

2) Create another interface with a different number:

no interface Serial0.1 multipoint

interface Serial0.10 point-to-point

ip address 192.168.4.2 255.255.255.252

frame-relay interface-dlci 221

HTH,

__

Edison.

New Member

Re: Why can't I ping the loopback interfaces?

You rule! That was it. Thanks!!!

4540
Views
5
Helpful
4
Replies