Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

wic-1adsl card connect to ISP

Cisco 2651XM router

fitted with WIC-1ADSL interface card

as a newbie I've been unsuccessful in connecting to my ISP with the wic-1adsl card. Before coming here I've been trawling through cisco documents but I can't work out what the correct commands are for a successful connection. I confess I also don't know how to verify if I have a successful connection or not.

My wic card is present in the cli as interface ATM0/0.

Here are the details for connecting to my isp, who happens to be a very bog standard UK isp on a BT phone line. Thanks for any pointers.

Connection type: PPPoA

VPI value: 0

VCI Value: 38

Encapsulation type: VC-MUX (or VC based)

Modulation: G.DMT (or DMT)

Authentication type: CHAP (may be listed as "PAP or CHAP")

ADSL Username: username

ADSL Password: password

1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: wic-1adsl card connect to ISP

Glad to hear. The issue with your FastEthernet 0/1 port interfering with your ADSL card sounds strange. There is no reason I can think of that would cause that. As with any ADSL setup, make sure you have filters on all other lines with the same number.

Please indicate that this question was solved and rate any post you felt was helpful.

Thanks,

Jim

26 REPLIES
New Member

Re: wic-1adsl card connect to ISP

Hello,

Apply the following making changes for slot numbers and such.

interface ATM0/0

no ip address

dsl operating-mode auto

interface ATM0/0.1

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

interface Dialer0

ip address negotiated (I am assuming)

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin (substitute chap if necessary)

ppp pap sent-username YOURUSERNAME password YOURPASSWORD (adjust for chap if necessary)

This is a standard ADSL config. You will obviously need some NAT and routing to make this function for simple Internet access.

Hope this helps,

Jim

New Member

Re: wic-1adsl card connect to ISP

thanks for your response Jim. The commands you gave do make the lights behave properly on the wic card so I think I might be connected but I'm still not 100% sure. Do you know if there's a way to test if the adsl card is actually connected to my ISP? I think my config for routing and such is a mess and will need sorting out but first I need to be certain about the adsl connection. Thanks for any further help you can give.

New Member

Re: wic-1adsl card connect to ISP

Using show commands you should be able to see the status on all of your interfaces as well as your routing. Check out the following:

show interface ATM0/0, status of DSL connection.

show interface Dialer0, status up PPP authentication and also where your 'outside' IP address is applied.

show ip route, current routing table. You should see a default route listed if you are setup correctly.

To have the dialer interface used as the default route apply the following:

ip route 0.0.0.0 0.0.0.0 Dialer0

After this is all setup you should be able to ping a public IP address. Try your ISP's DNS server.

You will also need NAT/PAT setup if you have nodes behind the router that need access to the Internet. With some simple searching on either Google or Cisco's website you can find many examples of configurations.

New Member

Re: wic-1adsl card connect to ISP

Can you post your running config along with the show commands I recommended? Feel free to sanitize where necessary.

New Member

Re: wic-1adsl card connect to ISP

Jim attached to this post is a copy of my (sanitised) running config. At the end of the running config part I then ran some commands which give a lot more info and may help us get this adsl card connected. At the end of the running config I can't ping my own ip address, can't ping the isp's dns address, can't ping anything outside the router. Also with the command 'no ip address' the CD light is dead. But when I put in an ip address the cd comes one, starts flashing and then eventually goes solid so it seems the atm0/0 has to have an ip address.

At this point all I want to do is reach the stage where I know the adsl card is connected to my isp. I know I won't be able to surf the net even if it's connected because my nat and routing is all wrong, but I don't care about that right now. I just want to reach the point where I can be certain the adsl card is connected to my isp. Earlier today I rang my isp and their logs show there's been no attempts to log on, so it would appear this adsl card isn't even trying to connect, which is puzzling. Sorry the attachment is so long but I thought it best to provide as much data as possible. Thanks and await any further advices you may have.

New Member

Re: wic-1adsl card connect to ISP

Try pinging ur isp gateway first to be sure if you are connecting or not,then make sure you are using the right connectors if since you are pretty sure about the configuration details given to by your ISP.And come to think of it WIC-1-ADSL is only supported on cisco 1720 and 1750 platforms. your ISP DSLAM must also be compatible with this WIC so check again with your isp to very compatible DSLAM for this WIC include Alcatel Digital Subscriber Loop Access Multiplexer (DSLAM), the Cisco 6260 DSLAM with Flexi-line cards and the Cisco 6130 DSLAM with Flexi-line cards.

New Member

Re: wic-1adsl card connect to ISP

WIC-1-ADSL is only supported on cisco 1720 and 1750 platforms? are you sure of that?

New Member

Re: wic-1adsl card connect to ISP

soory bout that it was initially but its supported on your router,so dont worry bout that,but make sure of other compatibility isssues b4 thinking bout configuration.

New Member

Re: wic-1adsl card connect to ISP

have u seen this try use your own setting it might work.

router> configure terminal

router(config)# interface atm slot/port

router(config-if)# ip address IP-address

router(config-if)# pvc [name] vpi/vci

[optional] router(config-if-vc)# protocol ip IP-address

[optional] router(config-if-vc)# vbr-rt peak-[optional]rate average-rate burst

router(config-if-vc)# encapsulation {aal2 | aal5ciscoppp | aal5mux | aal5nlpid | aal5snap}

router(config-if-vc)# exit

router(config-if)# dsl

operating-mode {ansi-dmt | auto

itu-dmt | splitterless}

router(config-if)# no shutdown

router(config-if)# exit

router(config)# exit

router# show interface atm 1/0

New Member

Re: wic-1adsl card connect to ISP

thanks for those commands cistajorin but I'm still having no joy. I entered them into the cli but but I got numerous errors along the way. What puzzles me is that I've entered about 3 different sets of commands and none of them show any evidence of the adsl card trying to connect. There must be a way to check if the adsl card is actually trying to connect. There must be a command of some kind but I can't find what it is. This is now starting to drive me insane.

New Member

Re: wic-1adsl card connect to ISP

You have two lights on the back of the WIC. When one light is on the card is initialized by the router. When the CD light is blinking slowly it is looking for DSL service. When the CD light is blinking quickly it is training to the DSL services. When the CD light is solid it has fully trained but is not necessarily 'working' as the PPP authentication still has to process successfully.

Can you attach your running config along with the following show command outputs?

show int ATM0/0

show in Dialer0

show ip route

Regards,

Jim

New Member

Re: wic-1adsl card connect to ISP

yes, done above in reply to your earlier post.

New Member

Re: wic-1adsl card connect to ISP

It looks like we are part way there. The physical DSL link is in showtime status which means it is fully trained.

However, you still have several other things that need changed. First remove the manual IP address off both the ATM0/0 and Dialer0 interfaces. Then tell the Dialer0 interface to be negotiated (from my original reply). Next try putting configuring the PPP authentication on Dialer0 back to PAP rather than CHAP (for now). We can then see if Dialer0 will come up with an outside IP address. Finally we will fix your routing and NAT. So, issue the following commands:

config t

int atm0/0

no ip address

shut

exit

default int fa0/1

int dialer0

no ip address

ip address negotiated

ip nat outside

ppp authentication pap callin

ppp pap sent-username YOURUSERNAME password YOURPASSWORD

exit

no router rip

no ip nat inside source list 3 interface Fa0/1 overload

ip nat inside source list 1 int dialer0 overload

no access-list 2

no access-list 3

int atm0/0

no shut

Give it a minute for the DSL to train up. After you have a solid CD light do:

show int dialer0

See if you have been assigned an outside IP address. If so, ping your ISP's DNS server address.

New Member

Re: wic-1adsl card connect to ISP

Jim I did the commands as you said and at the end I saw the dsl train up and then the CD light went solid. Then I did 'show int dialer 0', but I see no ip address or anything that indicated the adsl has a connection to my isp. Attached is a txt file showing results of commands and the new running config.

New Member

Re: wic-1adsl card connect to ISP

I think we are getting close. I would next check with your ISP and verify the both the username/password along with the PAP authentication method we chose. Also, see if they can see any attempted authentications from their end.

New Member

Re: wic-1adsl card connect to ISP

the username and password I'm using is definitely correct, no doubt about that. I rang my isp earlier today and their log shows no attempted connections from my line, so my adsl card isn't even trying to initiate a connection which is baffling. The OK and CD lights on the adsl card are on and solid.

The connection details my isp gives out to all customers is:

Connection type: PPPoA

VPI value: 0

VCI Value: 38

Encapsulation type: VC-MUX (or VC based)

Modulation: G.DMT (or DMT)

Authentication type: CHAP (may be listed as "PAP or CHAP")

New Member

Re: wic-1adsl card connect to ISP

Try reconfiguring the Dialer0 interface to CHAP. Remove the PAP related lines we entered and replace them with the CHAP versions. I don't know what these are off the top of my head.

New Member

Re: wic-1adsl card connect to ISP

yes ok I'll give that a try. One thing I thought of, it may help if I can see the log of what the adsl card is doing. I have logging console switched off by default. Is there a way to switch the logging on so that it only shows what's happening with the adsl card? maybe if I posted bits of the the adsl log that might shed some light...

New Member

Re: wic-1adsl card connect to ISP

You are looking for a debug command. Again, off the top of my head I am not sure which one you want. However, I from what you are telling and showing me the DSL is up. By that I mean your WIC has negotiated a connection to the DSLAM on your ISP's end. What you are fighting with now is the PPP portion of the PPPoA VC-Mux connection type. Your router has to authenticate with your ISP's RADIUS servers and they have to assign you an IP address before IP traffic can be sent across the connection.

New Member

Re: wic-1adsl card connect to ISP

success jim!

I changed the dialer0 pap to chap as you said and also tried a couple of other things and then saw the dialer0 had my internet ip address and I could ping my isp's dns addresses. So I messed about with the routing and then I saw my internet was on. Unbelievable. I couldn't see web pages though so I messed with my nic card settings and then the pages came on. I would still like to clean up my config as I'm sure it's a mess but now I am posting this message through the adsl card I've been trying to connect. Thankyou very much for your help along the way Jim. Once connected I did 'copy running-config startup-config' and also tftp'd a copy of my startup config to backup. Don't wanna lose it now ha ha. It's now 2.30am in the morning so I think I can go to bed at last.

One thing is weird though, maybe you can shed some light. The adsl CD light blinks constantly and will not sync with the line if the f0/1 port is not connected to some RJ45 port. And the f0/1 port also has to have an ip address, or the CD light will start blinking. But I'm not using the f0/1 port for anything. I connected it to another dinky plastic router just so it could be connected to something and then the dsl sync came back on. My LAN connects to f0/0 and data now goes in and out of atm0/0. What would cause that?

New Member

Re: wic-1adsl card connect to ISP

Glad to hear. The issue with your FastEthernet 0/1 port interfering with your ADSL card sounds strange. There is no reason I can think of that would cause that. As with any ADSL setup, make sure you have filters on all other lines with the same number.

Please indicate that this question was solved and rate any post you felt was helpful.

Thanks,

Jim

New Member

Re: wic-1adsl card connect to ISP

run straight into a brick wall the next morning though ha ha. Today I cannot get the dsl to train no matter what I do. I don't know whether this is solely a hardware issue or whether a config error would cause this. I wrote to the guy who sold me the card but no reply yet. The CD light will not stop blinking, the line won't sync. Oh well...

New Member

Re: wic-1adsl card connect to ISP

Post a current running config and I will see if something changed that shouldn't have.

New Member

Re: wic-1adsl card connect to ISP

I don't believe this router....

I re-tftp'd the same startup-config that worked last night (again) reloaded and saw an ever blinking light, so I began to knock up a running config. While I was preparing the text file the light went solid and I'm on the internet now. I don't understand this. Last night and today the sync would not train at all.

Anyway, running config is attached. I hope you do notice things that shouldn't be there, I'm sure it's a mess even though I have a connection right now. While typing this the f0/1 port is down so I pulled the network cable out of the socket and the CD light began to flash and I lost the connection. Plugged the cable back in, flashing light for at least 3 minutes, and then I'm back on again. Weird. Thanks and await yours.

New Member

Re: wic-1adsl card connect to ISP

I see nothing terribly wrong with this config. You might remove the following just to clean it up a bit.

config t

no ip ddns update method sdm_ddns1

int dialer0

no pap sent-username xxxxxxxxxxxx password 0 zzzzzzzzz

You mentioned that the secondary FastEthernet port needed to be usable? What for? I see you have it set to get an address from DHCP with a custom client-id? Is there a reason you set this up?

New Member

Re: wic-1adsl card connect to ISP

I've been on for a couple of hours straight now so I may put off those commands until tomorrow, this connection is so precious right now ha ha.

Actually I don't need the f0/1 port at all, I'm not using it and currently if I do 'show ip interface brief' I get:

FastEthernet0/1 unassigned YES NVRAM administratively down.

But if I pull the cable out of f0/1 the adsl sync goes and I lose the connection.

317
Views
0
Helpful
26
Replies
CreatePlease to create content