Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Windows 7 cannot obtain an IP address from 4503 Core Switch

Dear all ,,

there is a  Strange issue that  i want to  discuss ,, we have Core-Siwtch 4503 in the main building which is connected to another Core 4503-E in another building ,, now our PCs connected to the 4503-E ,,, any XP M/C can  pick an Dhcp-ip but and M/C run Win.7 Cannot !!!!!!! 

action taken :

1st we try to connect our win 7 pc in the node which was connected to xp M/C ,, and it didnot take ip from the DHCP . ,, 2

2nd we ensure from the core-switch configuration and its normal with no mistake

3rd trying to use tool from Microsoft Fix-it Center whih name is ( Microsoftfixit 50475 ) which is just .msi file but the problem face us is that this tool donnot accept to run on win 7 cause its made for vista .

4th after some researchs we notic that there is some modifications have to be performed on registery by disabling the dhcp broadcast flag we did it but nothing change yet

5th now we are waiting to perform another action which is Disable the IP Helper service in win 7

Best regards

Ossamy

6 REPLIES
Silver

Windows 7 cannot obtain an IP address from 4503 Core Switch

Mohammed Ossamy Mohammed wrote:

Dear all ,,

there is a  Strange issue that  i want to  discuss ,, we have Core-Siwtch 4503 in the main building which is connected to another Core 4503-E in another building ,, now our PCs connected to the 4503-E ,,, any XP M/C can  pick an Dhcp-ip but and M/C run Win.7 Cannot !!!!!!! 

action taken :

1st we try to connect our win 7 pc in the node which was connected to xp M/C ,, and it didnot take ip from the DHCP . ,, 2

2nd we ensure from the core-switch configuration and its normal with no mistake

3rd trying to use tool from Microsoft Fix-it Center whih name is ( Microsoftfixit 50475 ) which is just .msi file but the problem face us is that this tool donnot accept to run on win 7 cause its made for vista .

4th after some researchs we notic that there is some modifications have to be performed on registery by disabling the dhcp broadcast flag we did it but nothing change yet

5th now we are waiting to perform another action which is Disable the IP Helper service in win 7

Best regards

Ossamy

Are you using the 4503 as the DHCP server?

Can you post the DHCP server configuration you're using if you are?

Cheers.

New Member

Windows 7 cannot obtain an IP address from 4503 Core Switch

yes am using 4503 as the DHCP and i ll post  the configuration to you tomorrow

New Member

Windows 7 cannot obtain an IP address from 4503 Core Switch

hi darren ,,

i attached to  you the configuration of the dhcp server

thanks for your interest

Best Regards

Ossamy

Silver

Windows 7 cannot obtain an IP address from 4503 Core Switch

Mohammed Ossamy Mohammed wrote:

hi darren ,,

i attached to  you the configuration of the dhcp server

thanks for your interest

Best Regards

Ossamy

Well, your configuration shows you avoiding the most usual problem with configuring a DHCP server on a Cisco device and Windows 7/Vista - if you add a subnet mask in your "default router" statement it almost alwaysd breaks - but you don't have that in your configuration, so we can rule that out.

Are you 100% certain that your attempt to disable the broadcast flag on the Windows 7 boxes worked? This blog post has a great deal of detail which may help.

http://blogs.technet.com/b/teamdhcp/archive/2009/02/12/dhcp-broadcast-flag-handling-in-windows-7.aspx

If that doesn't help then I'm scratching my head. I just had a look at the DHCP configured on my router, which works fine for both XP and Windows 7 (32 & 64 bit) and I can't see much different from yours (apart from the obvious address ranges etc).

Sorry I can't offer more.

Cheers.

New Member

Windows 7 cannot obtain an IP address from 4503 Core Switch

Core 4503 #sh run

Building configuration...

Current configuration : 11191 bytes

!

version 12.2

no service pad

service timestamps debug datetime

service timestamps log datetime

service password-encryption

service compress-config

service sequence-numbers

!

hostname Pachin-Core

!

boot-start-marker

boot-end-marker

!

logging buffered 40960 debugging

!

username cisco privilege 15 secret 5 $1$snRG$Ko4rfi.T5lJ.QUXS7gRHm/

no aaa new-model

ip subnet-zero

no ip domain-lookup

ip dhcp excluded-address 10.1.1.1 10.1.1.10

ip dhcp excluded-address 10.1.2.1 10.1.2.10

ip dhcp excluded-address 10.3.1.1 10.3.1.10

ip dhcp excluded-address 10.3.2.1 10.3.2.10

ip dhcp excluded-address 10.4.1.1 10.4.1.10

ip dhcp excluded-address 10.5.1.1 10.5.1.10

ip dhcp excluded-address 10.5.2.1 10.5.2.10

ip dhcp excluded-address 10.5.3.1 10.5.3.10

ip dhcp excluded-address 10.5.4.1 10.5.4.10

ip dhcp excluded-address 10.6.1.1 10.6.1.10

ip dhcp excluded-address 10.1.110.1 10.1.110.10

ip dhcp excluded-address 10.1.3.1 10.1.3.10

ip dhcp excluded-address 10.2.1.1 10.2.1.10

ip dhcp excluded-address 192.168.222.60 192.168.222.80

!

ip dhcp pool Purchasing

network 10.1.1.0 255.255.255.0

default-router 10.1.1.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool Finance

network 10.1.2.0 255.255.255.0

default-router 10.1.2.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool Sales

network 10.2.1.0 255.255.255.0

default-router 10.2.1.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool Planning

network 10.3.1.0 255.255.255.0

default-router 10.3.1.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool IT

network 10.3.2.0 255.255.255.0

default-router 10.3.2.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool Labs

network 10.4.1.0 255.255.255.0

default-router 10.4.1.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool Marketing

network 10.5.2.0 255.255.255.0

default-router 10.5.2.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool HR

network 10.5.3.0 255.255.255.0

default-router 10.5.3.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool INK

network 10.6.1.0 255.255.255.0

default-router 10.6.1.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool Visitor

network 10.1.110.0 255.255.255.0

default-router 10.1.110.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool Management-Affairs

network 10.1.3.0 255.255.255.0

default-router 10.3.1.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool Tech-Affairs

network 10.5.1.0 255.255.255.0

default-router 10.5.1.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool CEO-Office

network 10.5.4.0 255.255.255.0

default-router 10.5.4.1

dns-server 192.168.0.29

lease 365

!

ip dhcp pool camera

network 192.168.222.0 255.255.255.0

dns-server 192.168.0.29

default-router 192.168.222.254

lease 365

!

ip dhcp pool test

!

!

no file verify auto

!

spanning-tree mode pvst

spanning-tree extend system-id

spanning-tree vlan 2-20 priority 0

port-channel load-balance dst-mac

power redundancy-mode redundant

!

!

!

vlan internal allocation policy ascending

!

interface Port-channel1

description ** Ether-Channel Downlink To Sales **

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel2

description ** Ether-Channel Downlink To Managment **

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel3

description ***Tech-Affiars UP***

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel4

description ***TO TechAffairs Down***

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel5

description ***TO Labs***

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel6

description ***TO INK***

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel7

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface Port-channel8

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/1

switchport access vlan 150

switchport trunk encapsulation dot1q

switchport mode access

!

interface GigabitEthernet1/2

switchport access vlan 33

switchport trunk encapsulation dot1q

switchport mode access

duplex full

!

interface GigabitEthernet1/3

switchport access vlan 33

switchport trunk encapsulation dot1q

switchport mode access

!

interface GigabitEthernet1/4

switchport access vlan 33

switchport trunk encapsulation dot1q

switchport mode access

!

interface GigabitEthernet1/5

switchport access vlan 33

switchport trunk encapsulation dot1q

switchport mode access

!

interface GigabitEthernet1/6

switchport access vlan 33

switchport trunk encapsulation dot1q

switchport mode access

!

interface GigabitEthernet1/7

switchport access vlan 33

switchport trunk encapsulation dot1q

switchport mode access

!

interface GigabitEthernet1/8

switchport access vlan 150

switchport trunk encapsulation dot1q

switchport mode access

!

interface GigabitEthernet1/9

switchport access vlan 33

switchport trunk encapsulation dot1q

switchport mode access

!

interface GigabitEthernet1/10

switchport access vlan 200

switchport trunk encapsulation dot1q

switchport mode access

!

interface GigabitEthernet1/11

switchport access vlan 150

switchport trunk encapsulation dot1q

switchport mode access

!

interface GigabitEthernet1/12

switchport access vlan 33

switchport trunk encapsulation dot1q

switchport mode access

!

interface GigabitEthernet1/13

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 3 mode desirable

!

interface GigabitEthernet1/14

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 5 mode desirable

!

interface GigabitEthernet1/15

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/16

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 4 mode desirable

!

interface GigabitEthernet1/17

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 5 mode desirable

!

interface GigabitEthernet1/18

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface GigabitEthernet1/19

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 3 mode desirable

!

interface GigabitEthernet1/20

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 4 mode desirable

!

interface GigabitEthernet2/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode desirable

!

interface GigabitEthernet2/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 2 mode desirable

!

interface GigabitEthernet2/3

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 7 mode desirable

!

interface GigabitEthernet2/4

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

!

interface GigabitEthernet2/5

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 7 mode desirable

!

interface GigabitEthernet2/6

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 8 mode desirable

!

interface GigabitEthernet3/1

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 6 mode desirable

!

interface GigabitEthernet3/2

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 6 mode desirable

!

interface GigabitEthernet3/3

!

interface GigabitEthernet3/4

!

interface GigabitEthernet3/5

!

interface GigabitEthernet3/6

switchport trunk encapsulation dot1q

switchport mode trunk

channel-group 1 mode desirable

!

interface Vlan1

no ip address

!

interface Vlan11

description ** Purchasing **

ip address 10.1.1.1 255.255.255.0

shutdown

!

interface Vlan12

description ** Finance **

ip address 10.1.2.1 255.255.255.0

loopback

!

interface Vlan13

description ** Management Affairs **

ip address 10.1.3.1 255.255.255.0

shutdown

!

interface Vlan21

description ** Sales **

ip address 10.2.1.1 255.255.255.0

!

interface Vlan31

description ** Planning **

ip address 10.3.1.1 255.255.255.0

shutdown

!

interface Vlan32

description ** IT **

ip address 10.3.2.1 255.255.255.0

!

interface Vlan33

description ** Servers **

ip address 192.168.0.10 255.255.255.0

!

interface Vlan41

description ** Labs **

ip address 10.4.1.1 255.255.255.0

!

interface Vlan51

description ** Tech Affairs **

ip address 10.5.1.1 255.255.255.0

!

interface Vlan52

description ** Marketing **

ip address 10.5.2.1 255.255.255.0

!

interface Vlan53

description ** HR **

ip address 10.5.3.1 255.255.255.0

shutdown

!

interface Vlan54

description ** CEO Office **

ip address 10.5.4.1 255.255.255.0

!

interface Vlan61

description ** INK **

ip address 10.6.1.1 255.255.255.0

!

interface Vlan70

ip address 192.168.222.254 255.255.255.0

!

interface Vlan100

description ** Network Devices **

ip address 10.100.150.1 255.255.255.0

!

interface Vlan110

description ** Visitor **

ip address 10.1.110.1 255.255.255.0

ip access-group GUEST in

!

interface Vlan120

description ** Printer **

ip address 10.1.120.1 255.255.255.0

shutdown

!

interface Vlan150

description ASA VLAN

ip address 10.100.100.1 255.255.255.0

!

interface Vlan200

description BlueCoat LAN/VLAN

ip address 10.100.200.1 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 10.100.100.2

ip http server

!

!

!

ip access-list extended GUEST

permit ip 10.1.110.0 0.0.0.255 host 192.168.0.29

permit ip 10.1.110.0 0.0.0.255 host 192.168.0.33

permit ip any any

logging trap notifications

logging 192.168.0.1

!

snmp-server community Pachin RW

snmp-server host 192.168.0.1 version 2c Pachin

!

banner motd ^C

 

##################################################################

# #

# *** Pachin Group *** #

# #

# WARNING! You have accessed a computer managed by Pachin #

# Group. You are required to have authorization from #

# Pachin Group before you proceed and you are strictly #

# limited to the Use set out within that authorization. #

# #

# Unauthorized access to or misuse of this system or the data #

# contained on this system is strictly prohibited and is likely #

# to constitute an offence under the relevant legislation. #

# If you disclose any data or other information obtained #

# through this system without authority,Pachin Group #

# will take Legal Action against you. #

# #

# You may proceed only if you are authorized to use this #

# Computer as detailed above. #

# #

##################################################################

^C

!

line con 0

logging synchronous

login local

stopbits 1

line vty 0 4

login local

line vty 5 15

login local

!

audit

!

end

New Member

Windows 7 cannot obtain an IP address from 4503 Core Switch

Ok there are [potentially] two issues (one MUCH easier to solve than the other) - let's start with the easy one:

What ever port your Win7 box is plugged into, do this:

ADD:

switcport access vlan xxx

REMOVE:

switchport trunk encapsulation dot1q

switchport mode access

(any other commands)

This SHOULD fix the problem.... Here's the reason why:

You are encapsulating most of your ports with Dot1q tagging, however (assuming here) you're Windows 7 network settings are not specifically sending tags/associating with any VLAN - **MEANING** you're on VLAN1, which has no ip address and no DHCP...

If you're really hell-bent to keep your ports as dot1q, you'll need to add the following command to specifically tell your switch that *IF* there are untagged packets, to send them to a specific VLAN other than 1.

switchport trunk native vlan xxx

Let me know if this work.... (it should)

Sean

http://www.sleepyshark.com/about/sean-brown-professional-biography/

773
Views
0
Helpful
6
Replies
CreatePlease login to create content