Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Windows Network Places: Fail to see machines across VLAN

Any help/input/idea is appreciated.

Environment:

(1)Core switches: 3750s running L3 routing

(2) Dis. switches: 2960s

Problem:

Had created a VLAN10 (let's assume I only have two, the default VLAN 1 plus the one in question). Eveything works fine as expected. No routing issues/networking issues. All machines function normally. But the machines on the newly created VLAN10 cannot be seen from any machines(VLAN1) in Network Places (windows). However, machines in the new VLAN10 can see everything. On VLAN1, I can see all machines (again except VLAN10), even those across the WAN, in network places. Again, everything works find, no problem except windows browsing (having said that, the only problem is that the machines not showing up in Network Places. One still can get to it[them] by \\machines, for example). I am wondering if I can make the browsing work. We are Windows 2003 server base environement, no legacy issue. No WINS (and is not going to use WINS no matter what), only DNS, DHCP, etc.

Question: Can I actually browse across VLAN? If not, then why am I able to see those machines across the WAN? Machines in VLAN10 is getting their IPs from the DHCP server, just like the rest of the machines on the network. Here's the short version of the config (catalyst 2960):

!

version 12.2

spanning-tree mode rapid-pvst

spanning-tree loopguard default

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

switchport access vlan 159

switchport mode access

spanning-tree portfast trunk

interface FastEthernet0/48

switchport access vlan 159

switchport mode access

spanning-tree portfast trunk

!

interface GigabitEthernet0/1

switchport mode trunk

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/2

switchport mode trunk

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

!

interface Vlan1

no ip address

no ip route-cache

!

interface Vlan159

ip address x.x.x.x 255.255.255.0

ip helper-address x.x.x.x

no ip route-cache

!

ip default-gateway x.x.x.x (the default G/W is the VLAN interface on the L3 upstream 3750 switch)

ip http server

!

control-plane

!

end

2 REPLIES
New Member

Re: Windows Network Places: Fail to see machines across VLAN

According to your config, you can't route between VLAN 1 and VLAN 159, because VLAN 1 doesn't have an IP address. Therefore, machines can't see each other across VLANs.

New Member

Re: Windows Network Places: Fail to see machines across VLAN

No, VLAN1 and VLAN10 can see each other. The only. The only think is not "showing" right is on VLAN1's network placese. On VLAN10, ALL machines, including VLAN1, show up correctly. On VLAN10 machines, they can connect/ping or whatever NORMALLY within VLAN10 or outside VLAN10. Connectivity at this point is not an issue. The routing part is done on the upstream L3 3750. The fact that VLAN10 shows all, that means the machines seeing the master browser (our DC, which is on VLAN1). the only question is why VLAN 1 can't see (agian, just the seeing part, not connectivity). Somehow netbios did not work both ways in the case. Thank you for your help.

282
Views
0
Helpful
2
Replies
CreatePlease to create content