Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WLC2504 not acepting the DHCP pools from the 3750

Hey,

I got a set of dhcp pool in one 3750 attached to diferent Vlans in the network, the wired network works fine, you can get from any switch port across the LAN a diferente VLANs IP. In my wlc2504 I got 5 WLANs with the DHCP server pointed to the VLAN in the 3750, but I just got one set of ip when i tried to connect to diferent WLAN, without connectivity, I can see all the Ap's, and ping the VLANs in the 3750,

any clue?

4 REPLIES

WLC2504 not acepting the DHCP pools from the 3750

Probably there is a problem with the trunking between the 3750 and the WLC and/or AP's.

Check this link for a sample setup:

http://www.cisco.com/en/US/docs/wireless/technology/controller/deployment/guide/dep.html#wp1050339

regards,

Leo

New Member

Re: WLC2504 not acepting the DHCP pools from the 3750

Thanks for answer

this the config in the 3750 port

interface FastEthernet1/0/24
switchport access vlan 9
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-9
switchport mode trunk

this is the dhcp pool config for the Ap's

ip dhcp pool Core

   network 192.168.9.0 255.255.255.0

   dns-server 192.168.100.20

   default-router 192.168.9.1

   option 43 hex f104.c0a8.0905

   lease 8

this another dhcp pool

ip dhcp pool Guest

   network 192.168.5.0 255.255.255.0

   default-router 192.168.5.1

   dns-server 192.168.100.20

   lease 8

and continue just getting Ip's in the 9.x range

Green

Re: WLC2504 not acepting the DHCP pools from the 3750

Hi,

I think you issue is your switch interface config

interface FastEthernet1/0/24
switchport access vlan 9
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 2-9
switchport mode trunk

Try changing this to

interface FastEthernet1/0/24
no switchport access vlan 9

no switchport mode access
switchport trunk encapsulation dot1q
switchport mode trunk

switchport trunk allowed vlan 2-9
!

HTH

Alex

Regards, Alex. Please rate useful posts.
New Member

Re: WLC2504 not acepting the DHCP pools from the 3750

actually I got it, the problem was, in order to match wlans with vlans, we need to create the Vlans in the WLC like interfaces, under the Controller tab,

switchport access vlan 9 is just for security, just let connect devices in that VLAN

thanks a lot for the comments and help

411
Views
0
Helpful
4
Replies
CreatePlease login to create content