Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

wrr-queue - where to find information?

Hi, I am looking for detailed information on what this command does and how to use it. I have found bits and pieces here and there with google searches but nothing substantial. Does anyone know where I can get detailed information on it?

The commands I am specifically interested in are wrr-queue bandwidth and wrr-queue cos-map.

Thanks in advance.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Silver
Silver

Re: wrr-queue - where to find information?

Because on 6500 device you have 2 threshold levels for the same queue:

wrr-queue cos-map 1 1 1

wrr-queue cos-map 1 2 0

=

queue 1 threshold 1 cos 1

queue 1 threshold 2 cos 0

for more infos:

http://www.cisco.com/en/US/products/hw/switches/ps708/products_command_reference_chapter09186a00801026ef.html

HTH

Andrea

6 REPLIES
Cisco Employee

Re: wrr-queue - where to find information?

This post of mine, should help you understanding the same configs.

http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Network%20Infrastructure&topic=LAN%2C%20Switching%20and%20Routing&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1dde1cdc

If you have any questions, Please revert.

HTH,Please rate if it does.

-amit singh

New Member

Re: wrr-queue - where to find information?

Thank you both for your help.

asingh, in regards to your post in the other conversation, that person had the following setup:

interface FastEthernet4/41

switchport

switchport access vlan 50

switchport mode access

switchport voice vlan 250

no ip address

wrr-queue cos-map 1 1 1

wrr-queue cos-map 1 2 0

wrr-queue cos-map 2 1 2 3 4 6 7

wrr-queue cos-map 2 2 5

mls qos trust cos

spanning-tree portfast

How/why would he have two separate cos-maps for queue 1 and queue 2 on the one interface?

Silver
New Member

Re: wrr-queue - where to find information?

Thank you both for your help.

asingh, in regards to your post in the other conversation, that person had the following setup:

interface FastEthernet4/41

switchport

switchport access vlan 50

switchport mode access

switchport voice vlan 250

no ip address

wrr-queue cos-map 1 1 1

wrr-queue cos-map 1 2 0

wrr-queue cos-map 2 1 2 3 4 6 7

wrr-queue cos-map 2 2 5

mls qos trust cos

spanning-tree portfast

How/why would he have two separate cos-maps for queue 1 and queue 2 on the one interface?

Silver

Re: wrr-queue - where to find information?

Because on 6500 device you have 2 threshold levels for the same queue:

wrr-queue cos-map 1 1 1

wrr-queue cos-map 1 2 0

=

queue 1 threshold 1 cos 1

queue 1 threshold 2 cos 0

for more infos:

http://www.cisco.com/en/US/products/hw/switches/ps708/products_command_reference_chapter09186a00801026ef.html

HTH

Andrea

New Member

Re: wrr-queue - where to find information?

ahh I see. Thank you for the information Andrea.

366
Views
4
Helpful
6
Replies
CreatePlease to create content