Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

X25 Troubleshooting

Hi Everyone,

I'm trying to configure a 1841 Router to do a translate between one central running X.25 (EWSD) and a client running TCP/IP.

The PVCs between the central and the router are ok, but when i try to telnet the central i don't receive and response.

telnet 1.1.1.2 2001

I put my conf below...

If someone see some mistake in my conf or point me some link usefull to start a troubleshooting i will be apreciate that

Thanks in Advanced,

Andre Lomonaco

hostname rot_pra_x25_teste

x25 routing

!

interface Loopback0

ip address 1.1.1.1 255.255.255.252

!

interface FastEthernet0/0

ip address 10.121.243.12 255.255.248.0

duplex auto

speed auto

!

interface Serial0/0/1

description CENTRAL EWSD

no ip address

encapsulation x25 dce

x25 address 621141760006

x25 ltc 5

x25 ips 256

x25 ops 256

clockrate 2000000

lapb T2 300

lapb interface-outage 20000

lapb N1 8248

lapb N2 15

!

translate tcp 1.1.1.2 port 2001 x25 555140000237 pvc 1 packetsize 128 128 wind

size 2 2 max-users 1

translate tcp 1.1.1.2 port 2002 x25 555140000237 pvc 2 packetsize 128 128 wind

size 2 2 max-users 1

translate tcp 1.1.1.2 port 2003 x25 555140000237 pvc 3 packetsize 128 128 wind

size 2 2 max-users 1

translate tcp 1.1.1.2 port 2004 x25 555140000237 pvc 4 packetsize 128 128 wind

size 2 2 max-users 1

logging trap debugging

logging 10.33.52.46

logging 10.33.52.114

!

!

x25 route 555140000237 interface Serial0/0/1

!

line vty 0 4

password X

logging synchronous

login

line vty 5 15

password X

login

transport preferred telnet

5 REPLIES
Hall of Fame Super Gold

Re: X25 Troubleshooting

Whoops I had read badly. Please take debug x25 and debug translate when telnetting from a PC.

New Member

Re: X25 Troubleshooting

Hi Bevilacqua,

I made a debug like you suggest and I got the following results

May 13 17:31:50.985: Serial0/0/1: X.25 O D1 Reset (5) 8 lci 1

*May 13 17:31:50.985: Cause 15, Diag 122 (Network operational (PVC)/Maintenance action)

*May 13 17:31:54.001: Serial0/0/1: X.25 O R/Inactive Restart (5) 8 lci 0

*May 13 17:31:54.001: Cause 7, Diag 0 (Network operational/No additional information)

*May 13 17:31:54.617: Serial0/0/1: X.25 I R3 Restart Confirm (3) 8 lci 0

*May 13 17:31:54.621: Serial0/0/1: X.25 O D1 Reset (5) 8 lci 1

*May 13 17:31:54.621: Cause 29, Diag 115 (Network out of order (PVC)/International link out of order)

*May 13 17:31:54.669: Serial0/0/1: X.25 I D3 Reset Confirm (3) 8 lci 1

*May 13 17:31:54.673: Serial0/0/1: X.25 I D1 Reset (5) 8 lci 2

*May 13 17:31:54.673: Cause 0, Diag 250 (DTE originated/Unknown diagnostic)

*May 13 17:31:54.673: Serial0/0/1: X.25 O D2 Reset Confirm (3) 8 lci 2

*May 13 17:31:54.677: Serial0/0/1: X.25 I P/Inactive Reset (5) 8 lci 3

*May 13 17:31:54.677: Cause 0, Diag 250 (DTE originated/Unknown diagnostic)

*May 13 17:31:54.677: %X25-7-DIAGEVENT: Interface Serial0/0/1, X.25 diagnostic event, Packet on unassigned logical channel, lci 3, packet discarded

*May 13 17:31:54.681: Serial0/0/1: X.25 O R1 Diagnostic (7) 8 lci 0

*May 13 17:31:54.681: error 36 (Packet on unassigned logical channel), 0x10 03 1B (Reset 8 lci 3)

*May 13 17:31:54.685: Serial0/0/1: X.25 I D1 Reset (5) 8 lci 4

*May 13 17:31:54.685: Cause 0, Diag 250 (DTE originated/Unknown diagnostic)

*May 13 17:31:54.685: Serial0/0/1: X.25 O D2 Reset Confirm (3) 8 lci 4

*May 13 17:31:54.869: Serial0/0/1: X.25 I D1 Reset (5) 8 lci 1

*May 13 17:31:54.869: Cause 0, Diag 250 (DTE originated/Unknown diagnostic)

*May 13 17:31:54.869: Serial0/0/1: X.25 O D2 Reset Confirm (3) 8 lci 1

Any tip or sugestion,

Thanks in Advanced and my best regards,

Andre Lomonaco

Hall of Fame Super Gold

Re: X25 Troubleshooting

Please configure SVC range (incoming/outgoing bidir) according to connected device.

New Member

Re: X25 Troubleshooting

Hi Bevilacqua,

First, thanks a lot for your reply..

Can you explain in more detail what i should do ?

You can see in my configuration i have already define the PVCs range between 1 and 4

when i used the command x25 ltc 5.

I wanna use only this 4 PVCs, I don't wanna use SVCs..

First again and my best regards,

Andre Lomonaco

Hall of Fame Super Gold

Re: X25 Troubleshooting

Hi, it seems to me that trouble begins when router sends:

*May 13 17:31:54.621: Serial0/0/1: X.25 O D1 Reset (5) 8 lci 1

*May 13 17:31:54.621: Cause 29, Diag 115 (Network out of order (PVC)/International link out of order)

Can you try:

x25 lic 0

x25 ltc 0

x25 loc 0

to eliminate SVCs altogether. Take debug again. Post it here if different from before.

1105
Views
4
Helpful
5
Replies