Cisco Support Community
Community Member

CX Module failed after reload

Hi there!

I do know if it is some kind of bug, but all the time after reload the CX module all things stop work, regardless of what form do I reset the module.

I already tried to acccess the module and reload, tried to stop services with "services stop" command and after that "reload", tried to shutdown using ASA commands and reload it from ASA... everytime I reload when the module come back all services start perfectly, like example below:

spcx02>show services status


Process           | PID   | Up    | Up Time


AD Interface      | 6284  | True  | 05:03:03

Message Nameserver| 6022  | True  | 05:03:59

HTTP Auth Daemon  | 6094  | True  | 05:03:58

PDTS              | 6073  | True  | 05:03:59

HTTP Inspector    | 6193  | True  | 05:03:37

HTTP Server       | 5972  | True  | 05:03:59

Data Plane        | 6270  | True  | 05:03:06

Management Plane  | 6115  | True  | 05:03:45

HPM Monitor       | 6289  | True  | 05:03:03

Updater           | 6399  | True  | 05:02:52

Card Manager      | 5930  | True  | 05:03:59

ARP Daemon        | 6089  | True  | 05:03:58

Event Server      | 6133  | True  | 05:03:41

TLS Proxy         | 6204  | True  | 05:03:37


spcx02>show ver

Cisco ASA CX Platform 9.1.2 (42)

Cisco Prime Security Manager 9.1.2 (42) for spcx02 firewall


I even can access the GUI using my browser, but all athentication with CDA or AD that before boot was working correctly show up the error:

"Connection failed with error: Could not connect to virtual directory interface."

Everytime I reload I must reinstall the entire module and reconfigure everything. Anyone know if this is a bug that crashes the database or something like this?


Rodrigo Alves

Community Member

CX Module failed after reload

Ah, I forgot to write down that after reload the module and it come back it stop all traffic passing through the firewall and I must remove the policy-map configuration:

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect rsh

  inspect rtsp

  inspect sqlnet

  inspect sunrpc

  inspect xdmcp

  inspect sip 

  inspect netbios

  inspect tftp

  inspect ip-options

  inspect icmp

  inspect h323 h225

  inspect h323 ras

  inspect skinny 

class class-default

  cxsc fail-open auth-proxy

Community Member

CX Module failed after reload

I solve the problem. I was really a bug if Cisco CX software... but yesterday Cisco realease I new software version and after installed it I could stop and start services without need to reinstall everything.

Just I question... Cisco didn't try your software and don't have program of software quality? In what decade Cisco are leving? I think that release publicly some software with king of bug, what it is easy to detect, is a desrespect to your customers around the world.

Last software installed: 9.2.1



CreatePlease to create content