Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

New IE 11 not correctly identified as IE broswer?

This issue came up today when one person in our group upgraded their browser from IE 10 to IE 11.

In our environment we only allow Internet Explorer with some limited Firefox Users as well.

The user agent string for IE 11 is different from IE 10 so it comes up as a non-approved browser. I'm wondering if there will be a fix for this in the

near term or if we have to just manually allow the string for future version/upgrades of IE?

  

WSA systems running 7.5.1-201

IE 10 UAS     -     "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; WOW64; Trident/6.0)"

IE 11 UAS     -     "Mozilla/5.0 (Windows NT 6.1; Win64; x64; Trident/7.0; rv:11.0) like Gecko"           

It sort of appears that under Identities - user agent strings section, that the available choices for IE are not keeping up. For example, IE choices list

Version 8.x MSIE 8

Version 7.x MSIE 7

Version 6.x MSIE 6

Version 5.x or earlier   MSIE [54321]

Internet Explorer Any Version    MSIE          (This doesn't match any version 11.x according to the UAS since no MSIE)

Thanks in advance...

KJ

  • Web Security
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

It sounds like you have the

It sounds like you have the authentication Identity set up to match based on user agent using the predefined browser user agents. Due to a change with IE 11, the IE 11 user agent does not match any of the IE user agents that are predefined in the Identity. To match the user agent, please add the following string under the custom user agents field in the authentication Identity:

Trident

 

I hope you find it useful.

 

 

miguel

 

 

3 REPLIES
Cisco Employee

New IE 11 not correctly identified as IE broswer?

I would recommend that you open a TAC case to have them confirm and submit this defect.  This is not the first time I've seen a browser release a new version, but does not trigger from the "Any Version" selection.

Basically, by checking that "Any Version" box, it just adds all the known strings for you.  It sounds like it is just not included at this point.

You're probably going to need to work around it by placing that user agent string manually in the Identity.

-Vance

New Member

It sounds like you have the

It sounds like you have the authentication Identity set up to match based on user agent using the predefined browser user agents. Due to a change with IE 11, the IE 11 user agent does not match any of the IE user agents that are predefined in the Identity. To match the user agent, please add the following string under the custom user agents field in the authentication Identity:

Trident

 

I hope you find it useful.

 

 

miguel

 

 

New Member

Hi Miguel,We actually fixed

Hi Miguel,

We actually fixed this not long after I submitted this post which I should have updated...

Your suggestion for uas would work as well but we actually went with, {rv:11.0}, for the string. I do worry from time to time MS could change it with new version releases of IE but we'll just deal with it when-if it changes...

Thanks for the suggestion though...good info. to keep around... :-)

Kerry

807
Views
5
Helpful
3
Replies
This widget could not be displayed.