Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Cisco WebEx Enabled TelePresence, conferences have been started, but no participiants are visible

I create telepresence conference with external webex via XML api and encountered some problems.
I got telepresence and webex conferense as result but while they actually start then webex doesn't see telepresence
participant and vice versa telepresence terminal doesn't see webex.

My algorithm:

1. Send request to Webex with XML API

====== REQUEST ======

<?xml version="1.0" encoding="utf-8"?>
<serv:message xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:serv="http://www.webex.com/schemas/2002/06/service">
  <header xmlns="">
    <securityContext>
      <siteName>[miscrosite_name]</siteName>
      <webExID>new_test_user</webExID>
      <password>PASSWORD</password>
    </securityContext>
  </header>
  <body xmlns="">
    <bodyContent xsi:type="java:com.webex.service.binding.meeting.CreateMeeting">
      <accessControl>
    <meetingPassword>[meeting_password]</meetingPassword>
  </accessControl>
      <metaData>
    <confName>My Tps conference glued with Wbx</confName>
  </metaData>
      <participants>
    <maxUserNumber>4</maxUserNumber>
    <attendees>
      <attendee>
        <person>
          <name>[attendee_name]</name>
          <email>[attendee_url]</email>
        </person>
        <language>RUSSIAN</language>
        <locale>Russia</locale>
        <timeZoneID>33</timeZoneID>
      </attendee>
    </attendees>
  </participants>
      <enableOptions>
    <chat>true</chat>
    <chatHost>true</chatHost>
    <chatPresenter>true</chatPresenter>
    <chatAllAttendees>true</chatAllAttendees>
    <poll>true</poll>
    <audioVideo>true</audioVideo>
    <attendeeList>true</attendeeList>
  </enableOptions>
      <attendeeOptionsType>
    <emailInvitations>false</emailInvitations>
  </attendeeOptionsType>
      <schedule>
    <startDate>03/13/2014 16:24:00</startDate>
    <openTime>900</openTime>
    <joinTeleconfBeforeHost>false</joinTeleconfBeforeHost>
    <duration>20</duration>
  </schedule>
      <telephony>
    <telephonySupport>CALLBACK</telephonySupport>
    <enableTSP>true</enableTSP>
    <tspAccountIndex>1</tspAccountIndex>
    <intlLocalCallIn>true</intlLocalCallIn>
  </telephony>
    </bodyContent>
  </body>
</serv:message>
 
====== RESPONSE ======

<?xml version="1.0" encoding="UTF-8"?>
<serv:message xmlns:att="http://www.webex.com/schemas/2002/06/service/attendee" xmlns:com="http://www.webex.com/schemas/2002/06/common" xmlns:meet="http://www.webex.com/schemas/2002/06/service/meeting" xmlns:serv="http://www.webex.com/schemas/2002/06/service">
  <serv:header>
    <serv:response>
      <serv:result>SUCCESS</serv:result>
      <serv:gsbStatus>PRIMARY</serv:gsbStatus>
    </serv:response>
  </serv:header>
  <serv:body>
    <serv:bodyContent xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:type="meet:createMeetingResponse">
      <meet:meetingkey>[meeting_key]</meet:meetingkey>
      <meet:iCalendarURL>
        <serv:host>[host]</serv:host>
        <serv:attendee>[attendee]</serv:attendee>
      </meet:iCalendarURL>
      <meet:guestToken>[guest_token]</meet:guestToken>
    </serv:bodyContent>
  </serv:body>
</serv:message>

2. Send request to TMS (full request and response log on demand)
Embedded ExternalConference:
  <ExternalConference>
    <WebEx>
      <MeetingKey>[meeting_key</MeetingKey>
      <SipUrl>110@[mcu_url]</SipUrl>
      <ElementsToExclude>None</ElementsToExclude>
      <MeetingPassword>[meeting_password]</MeetingPassword>
      <JoinMeetingUrl>[join_meeting_url]</JoinMeetingUrl>
      <HostMeetingUrl>[host_meeting_url]</HostMeetingUrl>
      <HostKey/>
      <Telephony>true</Telephony>
      <TmsShouldUpdateMeeting>true</TmsShouldUpdateMeeting>
      <SiteUrl>[site_url]</SiteUrl>
      <UsePstn>false</UsePstn>
      <OwnedExternally>true</OwnedExternally>
      <Warnings>true</Warnings>
      <Errors>true</Errors>
    </WebEx>
  </ExternalConference>


3. On conference start:
Webex conference started but there is no telepresence participant. (https://supportforums.cisco.com/sites/default/files/media/winxp.png)
Telepresence terminal received call and to be working and blinking with red bulb (https://supportforums.cisco.com/sites/default/files/media/telepresence_shot.jpg), in Tms panel I see that webex is booked. Log from tms:

13/03/2014 16:24:37    Administrator TMS         Conference created
13/03/2014 16:24:37    network service network service         Conference started
13/03/2014 16:24:37    network service network service         Non-secure conference. Original value of the setting was 'if possible' and not all participants support encryption.
13/03/2014 16:24:38    network service network service    MCU    Meeting allocated on port: 3
13/03/2014 16:24:38    network service network service    MCU    SIP Dial => [tandberg-dev-sip_url]
13/03/2014 16:24:38    network service network service    MCU    SIP Dial => 110@[mcu_sip_url]
13/03/2014 16:24:41    network service network service    MCU    Call connected: sip:[tandberg-dev-sip_url]
13/03/2014 16:25:09    network service network service    MCU    Call disconnected: 110@[mcu_sip_url], Cisco WebEx Meeting. Normal, unspecified

 


I suspect that some incorrect xml params are sent in <ExternalConference>.


Thanx in advance

Everyone's tags (2)
1 REPLY
Cisco Employee

Hi yzemlyanuhin,Unfortunately

Hi

Unfortunately, you will need to reach out to TP TAC Support for this issue.  Your product service is different than Webex Telepresence cloud service.  This forum is only for Webex Telepresence.  To reach TP TAC, please call 800-553-2447.

Regards,

Jason

401
Views
0
Helpful
1
Replies
CreatePlease to create content