Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CMS register errors

Can't reregister a WAE back to the CM. I've deleted it from the CM and did a "deregister force" on it and still won't reregister. Any ideas? I've tried everything. I don't want to use the rescure disk at a remote site!

version 4.4.1

cms deregister force

Deregistering WAE device from Central Manager will result in loss of data on encrypted file systems, imported certificate/private keys for SSL service and cifs/wafs preposition credentials. If secure store is initialized and open, clear secure store and wait for one datafeed poll rate to retain cifs/wafs preposition credentails.

Do you really want to continue (yes|no) [no]?yes

Disabling management service.

management services are already disabled.

Sending de-registration request to CM

Unable to get cdm ip address setting. Please make sure 'cdm ip' is set

Device de-regsitration failed, removing device registration information.

Please delete the device record on the Central Manager.

SSMGR RETURNING: 7 (Success)

Removing cms database tables.

rm: cannot remove directory `/state/emdb/global': Directory not empty

Failed to remove cms database tables(Unable to remove emdb files, 2), please use 'cms database delete' cli commandWARNING (resetxssfilter.sh): Device manager is not running, failed to disable security filter

Re-initializing SSL managed store and restarting SSL accelerator.Deregistration complete. Save current cli configuration using 'copy running-config startup-config' command because CMS service has been disabled.

cms database delete

Are you sure you want to remove database files (yes|no) [no]?yes

Removing database files...

rm: cannot remove directory `/state/emdb/global': Directory not empty

Failed to delete database, Unable to remove emdb files(2)

CMS services are not currently running. Please create CMS database tables using 'cms database create' cli command and then start CMS services using 'cms enable' command.For Unregistered devices use only 'cms enable' command to register the device and create the cms database tables.

cms enable

register: EMDB service is not ready or is not running

cms: unable to register node

FAILED to enable management services

cms database delete

Are you sure you want to remove database files (yes|no) [no]?yes

Removing database files...

rm: cannot remove directory `/state/emdb/global': Directory not empty

Failed to delete database, Unable to remove emdb files(2)

CMS services are not currently running. Please create CMS database tables using 'cms database create' cli command and then start CMS services

using 'cms enable' command.For Unregistered devices use only 'cms enable' command to register the device and create the cms database tables.

3 REPLIES
Cisco Employee

CMS register errors

did you try cms database create ?

and then try to add wae.

New Member

CMS register errors

Yep. We have a failed hard disk. I'm waiting for the RMA on it. I think that may be the problem here. It happened right when the hard disk failed again on it. The hard disks are always failing randomly in our environment.

cms database delete

Are you sure you want to remove database files (yes|no) [no]?yes

Removing database files...

rm: cannot remove directory `/state/emdb/global': Directory not empty

Failed to delete database, Unable to remove emdb files(2)

CMS  services are not currently running. Please create CMS database tables  using 'cms database create' cli command and then start CMS services

using  'cms enable' command.For Unregistered devices use only 'cms enable'  command to register the device and create the cms database tables.

bdpwaas2#show alarms

Critical Alarms:

----------------

        Alarm ID                 Module/Submodule               Instance

   ---------------             --------------------          ---------------

   1 mstore_key_failure        sslao                        mstore_key_failure      

   2 svcdisabled               nodemgr                      emdb                    

   3 svcdisabled               nodemgr                      cifsao                  

   4 svcdisabled               nodemgr                      device_mgr              

   5 svcdisabled               nodemgr                      actastor_watchdog       

Major Alarms:

-------------

None

Minor Alarms:

-------------

None

show disk det

Physical disk information:

  disk00: Present    9WJ1NY25   (h00 c00 i00 l00 - Int DAS-SATA)

          476937MB(465.8GB)

  disk01: Not present or not responding  (*)

(*) Disk drive won't be used until replaced.

Mounted file systems:

MOUNT POINT      TYPE       DEVICE                SIZE     INUSE      FREE USE%

/sw              internal   /dev/md0             991MB     710MB     281MB  71%

/swstore         internal   /dev/md1             991MB     477MB     514MB  48%

/state           internal   /dev/md2            5951MB     199MB    5752MB   3%

/vbspace         GUEST      /dev/data1/vbsp   188467MB     128MB  188339MB   0%

.../local1/spool PRINTSPOOL /dev/data1/spool     991MB      32MB     959MB   3%

/obj1            CONTENT    /dev/data1/obj    121015MB     128MB  120887MB   0%

/ackq1           internal   /dev/data1/ackq     1189MB       0MB    1189MB   0%

/plz1            internal   /dev/data1/plz      2379MB       1MB    2378MB   0%

/dre1            CONTENT    /dev/data1/dre    119031MB  116977MB    2054MB  98%

Software RAID devices:

  DEVICE NAME  TYPE     STATUS                PHYSICAL DEVICES AND STATUS

  /dev/md0     RAID-1   ONE OR MORE DRIVES ABNORMAL  disk00/00[GOOD] 

  /dev/md1     RAID-1   ONE OR MORE DRIVES ABNORMAL  disk00/01[GOOD] 

  /dev/md2     RAID-1   ONE OR MORE DRIVES ABNORMAL  disk00/02[GOOD] 

  /dev/md3     RAID-1   ONE OR MORE DRIVES ABNORMAL  disk00/03[GOOD] 

  /dev/md4     RAID-1   ONE OR MORE DRIVES ABNORMAL  disk00/04[GOOD] 

  /dev/md5     RAID-1   ONE OR MORE DRIVES ABNORMAL  disk00/05[GOOD] 

  *** NOTE ***

  One or more RAID constituent disk partitions appear to be abnormal.

  This could be because of

  A drive was identified as bad or shutdown

  Possible I/O errors on a disk drive

  Please run "show alarms critical detail support"

  to check any critical disk errors.

  RAID-1 volumes will continue to operate on the remaining disk drive.

  Please refer to the product documentation for further

  information on how to handle this situation.

Disk encryption feature is disabled.

Cisco Employee

CMS register errors

Yes. I would suggest to get rid of any hardware failures before trying anything on the config side.

Regards.

1738
Views
0
Helpful
3
Replies
CreatePlease login to create content