Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

QoS Question

Hello All,

I'm using a Cisco WAN emulator in my LAB to simulate a WAN link of 4Mbps with 250ms delay. When I FTP a large file, I'm getting just above 2Mbps and seeing a lot of output packet drops on the WAN interface. It doesn't ever fill the pipe unless I completely remove the QoS policy and the output packet drops don't show up. The WAAS is running version 4.2.1 and the BDP values are set to default adaptive. The models are 574 at the remote and 7341 for the core side.

Is this a normal behavior when you have QoS applied to your WAN interface? Are there any best practice to follow when you're using WAAS and QoS? The traffic that is being protected is not running during the FTP transfer so there  shouldn't be any output packet drops.

QoS Config:

access-list 170 remark **** Silver Traffic ****
access-list 170 remark ** Deny Fragments **
access-list 170 deny   ip any any fragments
access-list 170 remark ** CITRIX **
access-list 170 permit tcp any any eq 1494
access-list 170 permit tcp any any eq 2598
access-list 170 permit tcp any eq 2598 any
access-list 170 remark ** Terminal Services **
access-list 170 permit tcp any any eq 3389
access-list 170 permit tcp any eq 3389 any
access-list 170 remark ** TELNET **
access-list 170 permit tcp any any eq telnet
access-list 170 permit tcp any eq telnet any


class-map match-any Silver
match ip precedence 3
match ip dscp cs3
class-map match-any App_Traffic
match access-group 170


policy-map LAB_WAN-child
class Silver
    bandwidth 800
class class-default
    fair-queue
     random-detect
policy-map LAB_WAN
class class-default
    shape average 4096000
  service-policy LAB_WAN-child
policy-map LAB_LAN
class App_Traffic
  set ip dscp cs3
class class-default


interface FastEthernet0/1
description *** P2P to labrem01r ***
ip address 172.16.205.189 255.255.255.252
ip flow ingress
load-interval 30
duplex full
speed 100
no cdp enable
service-policy output LAB_WAN

interface FastEthernet4/0
description *** P2P to labcorewan-x1r ***
ip address 172.16.205.186 255.255.255.252
ip flow ingress
load-interval 30
duplex full
speed 100
service-policy input LAB_LAN

3 REPLIES
New Member

Re: QoS Question

I posted this type of question under the routing and switching forum. One of the responses was to see if you can disable bursty behavior on the WAAS. Since the WAAS sends burst of traffic out to the WAN, it's causing output drops on our QoS policy. I'm unable to fill the pipe, unless I remove QoS.

Is anyone else experiencing this or has QoS turned on and is not having difficulty maxing out their WAN link.

New Member

Re: QoS Question

What if you changed the WAAS QOS marking? I believe it is AF21 by default. If you gave it a higher DSCP level (for example AF41) just for testing does the random detect allow a higher bandwidth before it starts to drop the traffic?

New Member

Re: QoS Question

The WAAS is set to copy DSCP values and not to mark them. The DSCP value is 0 for default traffic.

580
Views
0
Helpful
3
Replies
CreatePlease to create content