Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

WAAS Optimization problem

Hello experts,

I have a problem about the WAAS optimization.

The topology is...

Center: 7200 Router working with WCCP (512 WAE)

Edge: 2800 Router working with WCCP (612 WAE)

When i tried to reach the Database (behind the 7200 Router) from the Edge site. its working! but during this time, when i look the Current Connection status, there is no optimization traffic(you can see the attach file).

I have done this setup, demo etc. too many times, but the first time i encountered such a problem.

you can see the configuration at the below.

By the way, when i look the "show ip wccp" command output. there is no traffic on Service identifier 62. Do we  need to see increased this traffic?

Thanks in advance for  your help.

BM-7206-METRO#show ip wccp
Global WCCP information:
    Router information:
        Router Identifier:                   10.200.200.193
        Protocol Version:                    2.0

    Service Identifier: 61
        Number of Service Group Clients:     1
        Number of Service Group Routers:     1
        Total Packets s/w Redirected:        37207
          Process:                           0
          Fast:                              0
          CEF:                               37207
        Service mode:                        Open
        Service access-list:                 -none-
        Total Packets Dropped Closed:        0
        Redirect access-list:                199
        Total Packets Denied Redirect:       1074214
        Total Packets Unassigned:            0
        Group access-list:                   -none-
        Total Messages Denied to Group:      0
        Total Authentication failures:       0
        Total Bypassed Packets Received:     0

    Service Identifier: 62
        Number of Service Group Clients:     1
        Number of Service Group Routers:     1
        Total Packets s/w Redirected:        0
          Process:                           0
          Fast:                              0
          CEF:                               0
        Service mode:                        Open
        Service access-list:                 -none-
        Total Packets Dropped Closed:        0
        Redirect access-list:                -none-
        Total Packets Denied Redirect:       0
        Total Packets Unassigned:            0
        Group access-list:                   -none-
        Total Messages Denied to Group:      0
        Total Authentication failures:       0
        Total Bypassed Packets Received:     0


**************************************************
**************************************************

CORE_WAE

configure terminal
primary-interface gigabitEthernet 1/0
device mode application-accelerator

central-manager address 10.10.10.10
cms enable

wccp version 2
wccp router-list 1 2.2.2.1 (ROUTER IP add)
wccp tcp-promiscuous router-list-num 1


**************************************************
**************************************************

EDGE_WAE

configure terminal
primary-interface gigabitEthernet 1/0
device mode application-accelerator

central-manager address 10.10.10.10
cms enable

wccp version 2
wccp router-list 1 1.1.1.1
wccp tcp-promiscuous router-list-num 1


**************************************************
**************************************************

CORE_ROUTER

ip wccp version 2
ip wccp 61
ip wccp 62

interface gi 2/0 (LAN)
ip wccp 61 redirect in

interface gi 3/0.26 (WAN) (Note: also this interface have a Tunnel int. connect to edge router tunnel int.)
ip wccp 62 redirect in

interface gi 1/0 (WAE LAN)
ip wccp redirect exclude in

ip cef


**************************************************
**************************************************

EDGE_ROUTER

ip wccp version 2
ip wccp 61
ip wccp 62


interface gi 1/0 (LAN)
ip wccp 61 redirect in

interface ATM 2/0.1 (WAN) (Note: also this interface have a Tunnel int. connect to central router tunnel  int.)
ip wccp 62 redirect in

interface gi 2/0 (WAE LAN)
ip wccp redirect exclude in

ip cef

**************************************************
**************************************************

8 REPLIES
Cisco Employee

Re: WAAS Optimization problem

Is the traffic going over the GRE tunnel between these sites?  Based on the output you provided, I suspect you need to apply ip wccp redirect 62 in on the tunnel interface itself.

Regards,

Zach

Community Member

Re: WAAS Optimization problem

Hello Zach,

Yes, the traffic going over the gre tunnel between the sites. When i tried to apply the "ip wccp redirect 62" command under the tunnel interface. I can not reach the edge router (with telnet, ssh or etc.)

I think, the problem occurs from the IPSEC traffic or something securtiy issue or MTU size. I also check the documents(cisco.com) for both situation, but everything seems to be ok.

bythe way

If you need any command output, i can provide. also routers configuration (i can email to you.)

thanks.

Cisco Employee

Re: WAAS Optimization problem

Can you tell me what IOS version you are running and provide a copy of the your router configuration?

Thanks,

Zach

Community Member

Re: WAAS Optimization problem

Hi Zach

Center router IOS version is c7200-advipservicesk9_li-mz.124-11.T.bin

Edge router IOS version is c2800nm-adventerprisek9-mz.124-9.T2.bin

Also you can see the configurations at the attach

Thanks,

My best.

CORE WAE CONFIG:
Based on the input, the following configurations will be done:
       central-manager address 10.166.0.10
       interface GigabitEthernet 1/0
         ip address 10.166.0.20 255.255.0.0
         autosense
       exit
       ip default-gateway 10.166.0.1
       ip name-server 10.201.0.201
       ip domain-name  tcmb.gov.tr
       primary-interface GigabitEthernet 1/0
       hostname CORE
       clock timezone UTC 0 0
       wccp version 2
       wccp router-list 8 10.166.0.1
       wccp tcp-promiscuous router-list 8
       cms enable

EDGE WAE CONFIG:

Based on the input, the following configurations will be done:
        central-manager address 10.166.0.10
        interface GigabitEthernet 1/0
          ip address 10.126.2.20 255.255.255.0
          autosense
        exit
        ip default-gateway 10.126.2.1
        ip name-server 10.201.0.201
        ip domain-name  tcmb.gov.tr
        primary-interface GigabitEthernet 1/0
        hostname EDGE
        clock timezone UTC 0 0
        wccp version 2
        wccp router-list 8 10.126.2.1
        wccp tcp-promiscuous router-list 8
        cms enable

Community Member

Re: WAAS Optimization problem

Hi Zach,

Is there any update about the problem?

thanks

Cavit

Cisco Employee

Re: WAAS Optimization problem

It's possible that you are running into IOS defect CSCsg30875.  Can you try using an access-list with the WCCP services that excludes traffic destined to the router IP addresses?

Thanks,

Zach

Community Member

Re: WAAS Optimization problem

Hi Zach,

it's working now,

when i apply the ip wccp command to tunnel interface, with exclude the all telnet and ssh traffic. Optimization working fine, somehow when i have downloaded something from the internet, i cant see the any compression about  HTTP traffic. (I choose the FULL optimization for HTTP traffic)

anyway i am working on this problem... thank you very much for your help.

My Best

Cavit Davutoglu.

Cisco Employee

Re: WAAS Optimization problem

Thanks for the update Cavit.

Please feel free to create a new post if you want to troubleshoot the HTTP acceleration problem.

Regards,

Zach

829
Views
0
Helpful
8
Replies
CreatePlease to create content