Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

WCCP Issue

We have an issue with WCCP on a 2811 router with an NM-WAE 502.

Has anyone seen this error ?

Nov 30 10:14:50.595: %WCCP-1-SERVICELOST: Service 61 lost on WCCP client 10.2.100.250

Nov 30 10:14:50.595: %WCCP-1-SERVICELOST: Service 62 lost on WCCP client 10.2.100.250

Thanks

Colin

6 REPLIES
New Member

WCCP Issue

Hi Colin

This is an indication of WCCP communication loss between the router and the WAE.

Can you post your WCCP config for the router and WAE.
To what interface does 10.2.100.250 belong? Do you have a loopback on the router?

Cheers

Phillip

New Member

WCCP Issue

router config...

ip wccp 61 redirect-list wccp_redirect

ip wccp 62 redirect-list wccp_redirect

!

!

ip cef

!

ip inspect log drop-pkt

ip inspect WAAS enable

ip inspect name internet tcp

ip inspect name internet udp

ip inspect name internet ftp

ip inspect name Internet udp

ip inspect name Internet tcp

ip inspect name Internet icmp

ip inspect name Internet telnet

ip inspect name Internet ssh

ip inspect name Internet ftp

ip inspect name Internet http

ip inspect name Internet https

ip inspect name Internet tftp

no ip domain lookup

!

!

interface Loopback0

ip address 109.204.113.145 255.255.255.248

!

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 10.2.1.254 255.255.255.0

ip wccp 61 redirect in

ip wccp 62 redirect out

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 10.2.2.254 255.255.255.0

!

!

interface FastEthernet0/1

description Connection to BT Wholesale EFM 10Mb

ip address 109.204.113.246 255.255.255.252

ip access-group outside-in in

ip inspect internet out

ip nat outside

ip virtual-reassembly

duplex full

speed 10

crypto map vpn-access

!

!

interface Integrated-Service-Engine1/0

ip address 10.2.100.1 255.255.255.0

ip wccp redirect exclude in

ip nat inside

ip virtual-reassembly

service-module ip address 10.2.100.250 255.255.255.0

!Application: Restarted at Sat Jun 24 10:10:58 2006

service-module ip default-gateway 10.2.100.1

no keepalive

!

router bgp 65530

no synchronization

bgp log-neighbor-changes

network 109.204.113.144 mask 255.255.255.248

neighbor 109.204.113.245 remote-as 20500

no auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 109.204.113.245 200

ip route 94.195.246.11 255.255.255.255 109.204.109.229

i

ip access-list extended wccp_redirect

permit ip 10.1.0.0 0.0.255.255 10.2.1.0 0.0.0.255

permit ip 10.2.1.0 0.0.0.255 10.1.0.0 0.0.255.255

permit ip 10.2.100.0 0.0.0.255 10.1.0.0 0.0.255.255

permit ip 10.1.0.0 0.0.255.255 10.2.100.0 0.0.0.255

!

NM-WAE config...

primary-interface GigabitEthernet 1/0

!

!

!

interface GigabitEthernet 1/0

ip address 10.2.100.250 255.255.255.0

no autosense

bandwidth 1000

full-duplex

exit

interface GigabitEthernet 2/0

shutdown

exit

!

!

ip default-gateway 10.2.100.1

!

no auto-register enable

!

! ip path-mtu-discovery is disabled in WAAS by default

!

ip name-server 10.1.8.1

!

!

!

ntp server 10.1.9.254

!

!

bypass static 10.2.4.7 any-server

!

wccp router-list 1 109.204.113.145

wccp tcp-promiscuous router-list-num 1

wccp version 2

!

egress-method generic-gre intercept-method wccp

!

!

transaction-logs flow enable

!

!

!

!

!

windows-domain netbios-name "LON-WAAS-NM"

!

authentication login local enable primary

authentication configuration local enable primary

!

!

!

!

!

!

!

!

!

!

crypto ssl services global-settings

   version all

   exit

!

WCCP Issue

Hi Colin,

Generic GRE as the return method (egress method) is not recommended by an ISR router, but only on Cat 6500/Cisco 7600.

Check this URL :

http://www.cisco.com/en/US/prod/collateral/contnetw/ps5680/ps6870/white_paper_c11-608042.html

What IOS version is the router running ?

What WAAS software are you using ?

Is the WCCP lost situation permanent or did it come up immediately after ?

Best Regards

Finn Poulsen

Cisco Employee

WCCP Issue

Hi Colin,

As earlier user pointed out, this is a communication failure between NME and the router. As this is an NME module, is this doing WCCP with 2811 itself (local 2811 where NME is installed?). If yes, there may be something else.

But if the router is not local NME module, this is clearly communication failure between NME and the router - 109.204.113.145.

If this is still down, try pinging WCCP router from NME and vice versa. These kind of issues can be caused by routing changes, ip address changes, etc. Please make sure router and NME can talk to each other over UDP port 2048.

Regards.

PS: Please mark this as Answered, if this answers your question.

New Member

WCCP Issue

All,

     Thanks for your help & advice, but i have now opened up a service request with Cisco TAC as this is not a config issue!

Cisco Employee

WCCP Issue

Thanks for the update, Colin. Please share the resolution with us, if you can.

Regards.

655
Views
0
Helpful
6
Replies