Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

WCCP missing assignment alarm for service id

Hello

our central manager frequently reports for one WAE

WCCP missing assignment alarm for service id: 62.

WCCP missing assignment alarm for service id: 61.

But the WAE seems to run nornal and we can't find eny problem and event on the WAE (7341 device). By screening the CCO documentaion we also couldn't find any explanation for this error log.

We have an installation with app. 30 WAEs/WAVEs in with software release 4.2.3. 

Could you please provide us some hints for troubleshooting.

Many thanks in advance!

11 REPLIES
New Member

Re: WCCP missing assignment alarm for service id

New Member

Re: WCCP missing assignment alarm for service id

I tried the wiki and the WAE itself seems to be running fine. The CM still reports the error and a couldn't find an explanation in the wiki.

Cisco Employee

Re: WCCP missing assignment alarm for service id

Are you using a multicast WCCP setup?

Do all the buckets show as allocated on the routers?

New Member

Re: WCCP missing assignment alarm for service id

In the meanwhile we checked the syslog and found some c

orrelating events:

2010 Oct 14 09:52:29 derz01oe3 wccp: %WAAS-WCCP-5-500024: Removing router

ID 10.2.0.146 from router table for service 61.

2010 Oct 14 09:52:29 derz01oe3 wccp: %WAAS-WCCP-5-500024: Removing router

ID 10.2.0.147 from router table for service 61.

2010 Oct 14 09:52:30 derz01oe3 wccp: %WAAS-WCCP-5-500024: Removing router

ID 10.2.0.146 from router table for service 62.

2010 Oct 14 09:52:30 derz01oe3 wccp: %WAAS-WCCP-5-500024: Removing router

ID 10.2.0.147 from router table for service 62.

2010 Oct 14 09:52:32 derz01oe3 wccp: %WAAS-WCCP-5-500008: A new view from

the router 10.2.0.146 with the given change number: 4. Service 61.

2010 Oct 14 09:52:32 derz01oe3 wccp: %WAAS-WCCP-5-500012: New router notif

:

ied. Rtr_Id 10.2.13.8 for service 61.

2010 Oct 14 09:52:32 derz01oe3 wccp: %WAAS-WCCP-5-500008: A new view from

the router 10.2.0.147 with the given change number: 5. Service 61.

2010 Oct 14 09:52:32 derz01oe3 wccp: %WAAS-WCCP-5-500008: A new view from

the router 10.2.0.146 with the given change number: 4. Service 62.

2010 Oct 14 09:52:32 derz01oe3 wccp: %WAAS-WCCP-5-500012: New router notif

ied. Rtr_Id 10.2.13.8 for service 62.

2010 Oct 14 09:52:32 derz01oe3 wccp: %WAAS-WCCP-3-500078: Clearing WCCP al

arm: /alm/maj/WCCP/svc062/missing_assignment

2010 Oct 14 09:52:32 derz01oe3 wccp: %WAAS-WCCP-5-500008: A new view from

the router 10.2.0.147 with the given change number: 5. Service 62.

2010 Oct 14 09:52:35 derz01oe3 wccp: %WAAS-WCCP-5-500008: A new view from

the router 10.2.0.147 with the given change number: 5. Service 61.

2010 Oct 14 09:52:35 derz01oe3 wccp: %WAAS-WCCP-3-500078: Clearing WCCP al

arm: /alm/maj/WCCP/svc061/missing_assignment

2010 Oct 14 09:52:35 derz01oe3 wccp: %WAAS-WCCP-5-500008: A new view from

the router 10.2.0.146 with the given change number: 4. Service 61.

The WAE is connected to a 6500 with 2 supervisor engines. We forced a switch to the second supervisor engine. By this measure the alarms vanished.

We will verify if there  any known WCCP bugs for the actual  IOS release on the 6500.

Cisco Employee

Re: WCCP missing assignment alarm for service id

Hi again,

To be honest it is very unlikely that the problem is on the switch. It just executes whatever the client sends.

I'm suspecting that you upgraded from a previous version without disabling the WCCP on the switch? Sometimes if you do this the state gets out of sync between the lead-wae and the switch. By doing a failover your forced to redo this and this cleared up the confusion.

Best regards, Peter

New Member

Re: WCCP missing assignment alarm for service id

Hello,

The wccp missing assignment alarm is seen on the wae's when either one of the below events occur

* RA’s(Redirect Assignments) are constantly getting dropped. Router never received an updated assignment.

* One or more other WAEs have 100% weight, causing WAE to not own any buckets (even though its still part of the farm)
* There are more WAEs than the number of (mask) buckets, so one or more WAEs does not get any assignments
* Configured mask value of WAE is different from rest of the farm.
* WAE cannot see one of the routers hence it is not included in the assignment. (Missing router in WAE’s router list config)
* WAE is configured for L2-redirect but router is not L2-adjacent to the WAE.
When any one of the above events occur the wae reports the missing assignment alarm
Regards
-Smita Nambiar
Cisco PDI HelpDesk

New Member

Re: WCCP missing assignment alarm for service id

Hello

I have the same issue and I noticed when we install a new location with two waves and wccp, it has for some reason an impact on exicting waves running in wccp mode:

the alarm ''WCCP missing assignment alarm for service id: 61 or 62'' riased on locations that were already in production.

!!!!!!

new location : 192.168.X.21 is one of  the new wave, 192.168.X.219 is the 2nd wave.A.B.C.D is the router loopback ip address

A.B.C.D

Existing waves (on different locations) already running in WCCP are : 192.168.Y.64.

Router (192.168.M.52) for another location where waves : 192.168.M.50 & 192.168.M.52 are already in service: Loopback ip is E.F.G.H

any idea why configuring wccp in one location has an impact on other locations

thnak you in advance

2011 Dec 14 08:55:41 N064WAP1009 wccp: %WAAS-WCCP-5-500008: A new view from the router 192.168.M.52 with the given change number: 12. Service 61.

2011 Dec 14 08:55:41 N064WAP1009 wccp: %WAAS-WCCP-5-500012: New router notified. Rtr_Id A.B.C.D for service 61.

2011 Dec 14 08:55:41 N064WAP1009 wccp: %WAAS-WCCP-5-500014: New device notified 192.168.X.219 for service 61.

2011 Dec 14 08:55:41 N064WAP1009 wccp: %WAAS-WCCP-5-500026: New entry being created for 192.168.X.219 is seen by router A.B.C.E for service 61.

2011 Dec 14 08:55:41 N064WAP1009 wccp: %WAAS-WCCP-5-500008: A new view from the router 192.168.M.52 with the given change number: 12. Service 62.

2011 Dec 14 08:55:41 N064WAP1009 wccp: %WAAS-WCCP-5-500012: New router notified. Rtr_Id A.B.C.D for service 62.

2011 Dec 14 08:55:41 N064WAP1009 wccp: %WAAS-WCCP-5-500014: New device notified 192.168.X.219 for service 62.

2011 Dec 14 08:55:41 N064WAP1009 wccp: %WAAS-WCCP-5-500026: New entry being created for 192.168.X.219 is seen by router A.B.C.E for service 62.

2011 Dec 14 08:55:54 N064WAP1009 wccp: %WAAS-WCCP-5-500008: A new view from the router 192.168.M.52 with the given change number: 13. Service 61.

2011 Dec 14 08:55:54 N064WAP1009 wccp: %WAAS-WCCP-5-500014: New device notified 192.168.X.21 for service 61.

2011 Dec 14 08:55:54 N064WAP1009 wccp: %WAAS-WCCP-5-500026: New entry being created for 192.168.X.21 is seen by router A.B.C.E for service 61.

2011 Dec 14 08:55:54 N064WAP1009 wccp: %WAAS-WCCP-5-500008: A new view from the router 192.168.M.52 with the given change number: 13. Service 62.

2011 Dec 14 08:55:54 N064WAP1009 wccp: %WAAS-WCCP-5-500014: New device notified 192.168.X.21 for service 62.

2011 Dec 14 08:55:54 N064WAP1009 wccp: %WAAS-WCCP-5-500026: New entry being created for 192.168.X.21 is seen by router A.B.C.E for service 62.

2011 Dec 14 08:56:09 N064WAP1009 wccp: %WAAS-WCCP-4-500016: No assignment sent: 192.168.Y.64 is not seen by all routers for service 61

2011 Dec 14 08:56:09 N064WAP1009 wccp: %WAAS-WCCP-4-500016: No assignment sent: 192.168.Y.64 is not seen by all routers for service 62

2011 Dec 14 08:58:55 N064WAP1009 wccp: %WAAS-WCCP-3-500078: Raising WCCP missing assignment alarm: WCCP missing assignment alarm for service id: 61.

2011 Dec 14 08:58:55 N064WAP1009 wccp: %WAAS-WCCP-3-500078: Raising WCCP missing assignment alarm: WCCP missing assignment alarm for service id: 62.

2011 Dec 14 08:59:03 N064WAP1009 wccp: %WAAS-WCCP-5-500008: A new view from the router 192.168.M.52 with the given change number: 14. Service 61.

2011 Dec 14 08:59:03 N064WAP1009 wccp: %WAAS-WCCP-5-500008: A new view from the router 192.168.M.52 with the given change number: 14. Service 62.

2011 Dec 14 08:59:19 N064WAP1009 wccp: %WAAS-WCCP-4-500016: No assignment sent: 192.168.Y.64 is not seen by all routers for service 61

2011 Dec 14 08:59:19 N064WAP1009 wccp: %WAAS-WCCP-4-500016: No assignment sent: 192.168.Y.64 is not seen by all routers for service 62

2011 Dec 14 08:59:31 N064WAP1009 wccp: %WAAS-WCCP-5-500028: Removing web cache 192.168.X.21 due to timeout for service 61.

2011 Dec 14 08:59:31 N064WAP1009 wccp: %WAAS-WCCP-5-500028: Removing web cache 192.168.X.21 due to timeout for service 62.

2011 Dec 14 09:01:53 N064WAP1009 wccp: %WAAS-WCCP-5-500008: A new view from the router 192.168.M.52 with the given change number: 15. Service 61.

2011 Dec 14 09:01:53 N064WAP1009 wccp: %WAAS-WCCP-5-500014: New device notified 192.168.X.21 for service 61.

2011 Dec 14 09:01:53 N064WAP1009 wccp: %WAAS-WCCP-5-500026: New entry being created for 192.168.X.21 is seen by router E.F.G.H for service 61.

2011 Dec 14 09:01:53 N064WAP1009 wccp: %WAAS-WCCP-5-500008: A new view from the router 192.168.M.52 with the given change number: 15. Service 62.

2011 Dec 14 09:01:53 N064WAP1009 wccp: %WAAS-WCCP-5-500014: New device notified 192.168.X.21 for service 62.

2011 Dec 14 09:01:53 N064WAP1009 wccp: %WAAS-WCCP-5-500026: New entry being created for 192.168.X.21 is seen by router E.F.G.H for service 62.

2011 Dec 14 09:02:09 N064WAP1009 wccp: %WAAS-WCCP-4-500016: No assignment sent: 192.168.Y.64 is not seen by all routers for service 61

2011 Dec 14 09:02:09 N064WAP1009 wccp: %WAAS-WCCP-4-500016: No assignment sent: 192.168.Y.64 is not seen by all routers for service 62

Cisco Employee

Re: WCCP missing assignment alarm for service id

Hi,

This kind of issue can occur if there is a mis-config on the WAE / router. One / two things you may want to verify on WAE:

1. Please make sure you have right address under wccp router list on WAE.

2. If you are using L2 redirection, please make sure routr is L2 adjecent.

Any change in WCCP farm (addition / removal of routers OR WAEs) will result in WCCP bucket relocation / reassignment of hash on that local WCCP farm only.

From my real customer experience, I had a customer who had put in remote site router-id in the WCCP router list. Please make sure that is not the case in your config.

Following commands will tell you which WAE and Routers are talking to each other in that particular farm. If you see any unexpected entries, verify your configuratrion.

On WAE:

WAE-674-1#sh wccp routers

WAE-674-1#sh wccp wide-area-engine

On Router / Switch:

2911-1#sh ip wccp summary

2911-1#sh ip wccp 61 view

2911-1#sh ip wccp 62 view

Hope this helps.

Regards.

New Member

Re: WCCP missing assignment alarm for service id

Hello Bhavin

you are absolutely right. this issue was caused by a misconfigured.

thank you very much

Cisco Employee

Re: WCCP missing assignment alarm for service id

Glad to know that your issue is addressed.

Thanks for the update. Can you please mark this as Answered, so that other people can view this as answer to their questions in the future?

Thanks again.


New Member

Re: WCCP missing assignment alarm for service id

to Hello Bhavin

am I allow to do that since I am not the first person that opened the case ?

If yes, where can I change the status  from

Not Answered

to

  Answered

thank you

2902
Views
0
Helpful
11
Replies
CreatePlease login to create content