Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

7920/ 1100 Series AP problem

Switch Configuration:

Do you trunk the port going to the AP?

AP Configurations:

Do you have to broadcast the voice (SSID) for the 7920 phone to authenticate?

Do you have to broadcast the voice (SSID) in order for the phone to layer 2 roam?

We're having problems with our current configurations:

Currently, we have the switch port configured like this:

interface FastEthernet0/48

switchport access vlan 90

switchport mode access

switchport voice vlan 15

no ip address

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

wrr-queue bandwidth 20 1 80 1

wrr-queue min-reserve 1 5

wrr-queue min-reserve 2 6

wrr-queue min-reserve 3 7

wrr-queue min-reserve 4 8

wrr-queue cos-map 1 0 1 2 4

wrr-queue cos-map 3 3 6 7

wrr-queue cos-map 4 5

priority-queue out

spanning-tree portfast

On the AP, we have two SSIDs, each assigned their respective vlans (Voice and Data).

On the Data VLAN, we are using DHCP.

Which ever SSID (VLAN) we broadcast, is the only one that seems to work. If we dont broadcast the voice vlan, the phones, even when configured with a specific SSID, wont work. It saids no AP found.

If we broadcast the voice, the laptops wont get their ip from the data SSID.

If someone could give me a detailed example configuration of the switch, AP, and phone (if needed), that would help a lot.

2 REPLIES
New Member

Re: 7920/ 1100 Series AP problem

you must configure the port to trunnk the vlans that you are mapping to your SSID

here is an example (of the trunking only) switch port config:

interface FastEthernet0/18

switchport trunk encapsulation dot1q

switchport trunk native vlan 400

switchport trunk allowed vlan 400,410,420,430

switchport mode trunk

Which trunks 4 vlans to the AP.

The AP config relating to the multiple ssids, vlans and bridge groups is below:

dot11 mbssid

!

dot11 ssid SSID4

vlan 430

authentication <>

accounting <>

mbssid guest-mode dtim-period 20

information-element ssidl advertisement wps

!

dot11 ssid SSID1

vlan 400

authentication <>

accounting <>

mbssid guest-mode dtim-period 20

information-element ssidl advertisement wps

!

dot11 ssid SSID2

vlan 410

authentication <>

accounting <>

mbssid guest-mode dtim-period 20

information-element ssidl advertisement wps

!

dot11 ssid SSID3

vlan 420

authentication <>

accounting <>

mbssid guest-mode dtim-period 20

information-element ssidl advertisement wps

interface Dot11Radio0.400

encapsulation dot1Q 400 native

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.410

encapsulation dot1Q 410

no ip route-cache

bridge-group 2

bridge-group 2 subscriber-loop-control

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

bridge-group 2 spanning-disabled

!

interface Dot11Radio0.420

encapsulation dot1Q 420

no ip route-cache

bridge-group 3

bridge-group 3 subscriber-loop-control

bridge-group 3 block-unknown-source

no bridge-group 3 source-learning

no bridge-group 3 unicast-flooding

bridge-group 3 spanning-disabled

!

interface Dot11Radio0.430

encapsulation dot1Q 430

no ip route-cache

bridge-group 4

bridge-group 4 subscriber-loop-control

bridge-group 4 block-unknown-source

no bridge-group 4 source-learning

no bridge-group 4 unicast-flooding

bridge-group 4 spanning-disabled

!

interface Dot11Radio0

no ip address

no ip route-cache

!

****optionally use encrption on your vlans'

encryption vlan 400

!

****

ssid SSID1

!

ssid SSID2

!

ssid SSID3

!

ssid SSID4

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

hold-queue 160 in

!

interface FastEthernet0.1

encapsulation dot1Q 400 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.2

encapsulation dot1Q 410

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

!

interface FastEthernet0.3

encapsulation dot1Q 420

no ip route-cache

bridge-group 3

no bridge-group 3 source-learning

bridge-group 3 spanning-disabled

!

interface FastEthernet0.4

encapsulation dot1Q 430

no ip route-cache

bridge-group 4

no bridge-group 4 source-learning

bridge-group 4 spanning-disabled

New Member

Re: 7920/ 1100 Series AP problem

When using SSID's with VLANS, you must trunk to the switch in order for it to work. I would also suggest using WPA-TKIP for the 7920 phones for security and roaming. I have a few customers setup that way using WDS and RADIUS and they work wonderfully.

191
Views
0
Helpful
2
Replies
CreatePlease login to create content