Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

About Switch voice vlan over Wireless Bridge?

Dears,

I want to do it:

C3560 --- e0 / Root-AP / Radio0 ======== Radio0 / Non-Root AP / e0 --- CISCO7911 IPPhone --- PC

Config in C3560:

switchport access vlan 10

switchport mode access

switchport voice vlan 100

Root to Non-Root only connect via ONE SSID, not muilt-SSID config!

The PC can get DHCP ip via VLAN10, but the IPPHONE cannot get the voice vlan information.

Could the CISCO AP distinguish the voice vlan or data vlan?

or I must to setup muilt-SSID between AP, then switch set the trunk?

THANKS.

7 REPLIES

Re: About Switch voice vlan over Wireless Bridge?

That would work, you only need the one infrastructure SSID. You do need to configure the sub interfaces for the VLAN that you want to pass across the link.

I would also advise that you look at the deployment guide and configure QoS across the link so the voice traffic gets priority

Steve

Sent from Cisco Technical Support iPhone App

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
Community Member

Re: About Switch voice vlan over Wireless Bridge?

Dear Sir,

So, I don't set the muilt-ssid between AP!

Just only one!

Then set the Root AP's sub-interface(on tag) link to c3560.

Is it the same on non-root ap to ip-phone?

Sent from Cisco Technical Support iPhone App

Community Member

About Switch voice vlan over Wireless Bridge?

Hi mr.marslin

DO you have your issues resolved? can you share your config for your switches ,root and non-root bridge?

VIP Purple

About Switch voice vlan over Wireless Bridge?

Hi Xiao,

This post may give you a similar configuration what you looking for. In here vlan1 (192.168.2.0/24) is the Voice vlan & vlan6 (192.168.6.0/24) is the Data vlan. Vlan999 (192.168.99.x/24) is the management vlan & native vlan for trunk links.

http://mrncciew.com/2013/08/02/a-wireless-bridge-with-qos/

HTH

Rasika

***** Pls rate all useful responses ****

Community Member

About Switch voice vlan over Wireless Bridge?

Hi Rasika,

I m try to figure it out but here is the issue i 'm facing. the bridge is up but the vlan 407 which i 'm trying to pass down from the root to the non-root site are not sucessfully. client not able to grab any dhcp.

here is my simple network topo

network(switch)-trunk--root----non-root---client

======================

Root

APRootbridgeNCS#ter len 0

APRootbridgeNCS#show run

Building configuration...

Current configuration : 3646 bytes

!

! Last configuration change at 00:03:38 UTC Mon Mar 1 1993

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname APRootbridgeNCS

!

logging rate-limit console 9

enable secret 5 $1$efLb$9ZkSogqdPsxPPHbjKDzyB.

!

no aaa new-model

no ip routing

ip domain name SP

!

!

dot11 syslog

dot11 vlan-name Native vlan 1

!

dot11 ssid BridgeManager

   vlan 1

   authentication open

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1453738646

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1453738646

revocation-check none

rsakeypair TP-self-signed-1453738646

!

!

crypto pki certificate chain TP-self-signed-1453738646

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31343533 37333836 3436301E 170D3132 31303330 32333030

  35375A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 34353337

  33383634 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100B4E0 CD142CDE 72D043F9 53E42C02 66EB231A DFB66643 EDF555D6 D5E899D1

  26A8354A 5AFD0767 ED5D2CDC F0EFB35F 858AEA4E 982F7B41 5BACAB1E 367D898E

  45976884 F004A057 153340C1 85F3EF88 B3380524 FFD40E31 ADD50130 D9F25679

  1E927AC2 2A5313E7 EDF7441C 005E24D1 4BE5B0AB 3104C372 95DA1FBE 3DA68EC8

  E0590203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 144D5B4B 2779F932 A67800CC 2BA1F95A 1B9C10F7 85301D06

  03551D0E 04160414 4D5B4B27 79F932A6 7800CC2B A1F95A1B 9C10F785 300D0609

  2A864886 F70D0101 05050003 81810031 9BA6CEB5 C0433449 57ABC3BA 8B793EA6

  5CBEE20D CF831858 FD9428C5 AD02448C B16B0B09 CB675B07 5A009639 35B8461C

  1BDAA409 48C250F2 A48A4DA1 089822A8 81627865 0705C828 C029BE93 9ABF1D70

  23370EFF 2CF57969 5B163654 06E3781D 9C2DB3BA 46D37A7D 4EB85171 AABBEE57

  0D874DD8 F43F3EA4 42F03C07 BB65B9

        quit

username SPAdmin privilege 15 secret 5 $1$gP5W$WozkY1ELCLZRXIq22I4lp/

username cisco privilege 15 secret 5 $1$78Mn$W43d0RuN4XxrrEdTvtTys0

!

!

ip ssh version 2

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

shutdown

antenna gain 0

station-role root

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio1

no ip address

no ip route-cache

!

ssid BridgeManager

!

antenna gain 0

no dfs band block

stbc

power local -4

channel dfs

station-role root bridge

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1.407

description LWAPP

encapsulation dot1Q 407

no ip route-cache

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.407

encapsulation dot1Q 407

no ip route-cache

bridge-group 47

!

interface BVI1

ip address 192.168.7.101 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.7.1

no ip http server

ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

transport input all

line vty 5 15

login local

transport input all

!

end

--------------------------------------------------------

noon-root

APNonrootbridgeNCS#show run

Building configuration...

Current configuration : 3678 bytes

!

! Last configuration change at 10:38:15 SG Mon Mar 1 1993

version 15.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname APNonrootbridgeNCS

!

logging rate-limit console 9

enable secret 5 $1$NVEP$InaBq1wYMgpii/zAnzE.7/

!

no aaa new-model

clock timezone SG 8 0

no ip routing

ip domain name SP

!

!

dot11 syslog

dot11 vlan-name Native vlan 1

!

dot11 ssid BridgeManager

   vlan 1

   authentication open

!

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1453738562

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-1453738562

revocation-check none

rsakeypair TP-self-signed-1453738562

!

!

crypto pki certificate chain TP-self-signed-1453738562

certificate self-signed 01

  3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 31343533 37333835 3632301E 170D3132 31303330 31363038

  31325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 34353337

  33383536 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  8100B52A 97AD2866 A783E40D 0050D441 93960196 AE65BAE9 EC989E8E 1FCF50A2

  FCFAB3B7 3AC370ED 7E299197 3B6F5C80 025A4982 53A57840 97E37230 A0E2DDB3

  470243F5 693C26DD 25208857 A0D6EFE8 22B6753A 6875C024 62A7566F 4444BA6D

  C77567C4 314BEA0E AB778111 0A6E422C 8206D9A0 49F1DB32 4E773552 052ACD0A

  F5EB0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603

  551D2304 18301680 14FE9D3D 3C7E992F E7252886 D13256C7 4BD5CCCB FB301D06

  03551D0E 04160414 FE9D3D3C 7E992FE7 252886D1 3256C74B D5CCCBFB 300D0609

  2A864886 F70D0101 05050003 81810083 5D6E3021 97756D8F 42E1F01D B2B615EE

  E36A2EBF 6AE967F6 6FC22C7D 39522857 806C8920 4C5BBD52 995DBD29 1DDFAB62

  14241267 831DEE5F F9ED159C 2EB248C6 297188E0 122FF7C6 5097D4A9 133E31BB

  98826FB0 094577CE EEADF7E9 4F4089DA 675ECF63 1FA42528 D32C8CB7 0429FA7C

  B6DE5731 02B0673E FC2D8023 4F47BF

        quit

username SPAdmin privilege 15 secret 5 $1$qU3Z$iQX5tW3HxE3PJTnull4XA1

username cisco privilege 15 password 7 151C081F0723382778

!

!

ip ssh version 2

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

shutdown

antenna gain 0

stbc

station-role root access-point

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Dot11Radio1

no ip address

no ip route-cache

!

ssid BridgeManager

!

antenna gain 19

stbc

power local -4

station-role workgroup-bridge

infrastructure-client

!

interface Dot11Radio1.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface Dot11Radio1.407

encapsulation dot1Q 407

no ip route-cache

bridge-group 47

!

interface GigabitEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface GigabitEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

bridge-group 1 spanning-disabled

!

interface GigabitEthernet0.407

description lwapp

encapsulation dot1Q 407

no ip route-cache

bridge-group 47

!

interface BVI1

ip address 192.168.7.102 255.255.255.0

no ip route-cache

!

ip default-gateway 192.168.7.1

no ip http server

ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

login local

transport input all

!

workgroup-bridge client-vlan 407

end

APNonrootbridgeNCS#show ip int b

Interface                  IP-Address      OK? Method Status                Protocol

BVI1                       192.168.7.102   YES manual up                    up     

Dot11Radio0                unassigned      YES NVRAM  administratively down down   

Dot11Radio1                unassigned      YES NVRAM  up                    up     

Dot11Radio1.1              unassigned      YES unset  up                    up     

Dot11Radio1.407            unassigned      YES unset  up                    up     

GigabitEthernet0           unassigned      YES NVRAM  up                    up     

GigabitEthernet0.1         unassigned      YES unset  up                    up     

GigabitEthernet0.407       unassigned      YES unset  up                    up     

Virtual-Dot11Radio0        unassigned      YES unset  up                    up     

Virtual-Dot11Radio0.1      unassigned      YES unset  up                    up     

Virtual-Dot11Radio0.407    unassigned      YES unset  up                    up     

APNonrootbridgeNCS#wr

Building configuration...

[OK]

===============================================

switch

10G-Temp_Switch#sh run int fa1/0/47

Building configuration...

Current configuration : 132 bytes

!

interface FastEthernet1/0/47

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 407

switchport mode trunk

end

VIP Purple

About Switch voice vlan over Wireless Bridge?

Hi Xiao

Since you have posted your query seperately, I have replied to it here

https://supportforums.cisco.com/thread/2254004?tstart=0

HTH

Rasika

Bronze

Hi,Connect non-root AP switch

Hi,

Connect non-root AP switch-port with 7911 IP phone and then connect PC with IP like daisy chain and then check.

2699
Views
0
Helpful
7
Replies
CreatePlease to create content