Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AP121 Clients losing connection

Hello all,

At our home/ office we have four AP121 clustered together as one. Every now and then our connected clients (iphone, ipad, macbook, windows tablets and laptops, …) loose the connection with the wireless and then we have to reconnect again. 

This is getting a bit tiresome and so I've decided to try and fix this, but I cannot find the fault myself. So I'm asking help :)

Thank you in advance!

 

Our setup is as follows:

Broadband modem -> Cisco 1941 router -> SG300-28 -> SG300-24P -> AP's 1-4

 

Update: Here is the configuration

 

Router config

 

ip dhcp pool data

 network 10.0.90.0 255.255.255.192

 dns-server 10.0.0.2 10.0.0.3 

 default-router 10.0.90.1 

 domain-name gregoir.local

 lease 0 1

!

ip dhcp pool wireless-guest

 network 192.168.1.0 255.255.255.192

 dns-server 8.8.8.8 8.8.4.4 

 default-router 192.168.1.1 

 domain-name gregoir-guest.local

 lease 0 1

!

!

!

ip domain list gregoir.local

ip domain name gregoir.local

ip name-server 10.0.0.2

ip name-server 10.0.0.3

ip cef

no ipv6 cef

multilink bundle-name authenticated

!

!

!

interface GigabitEthernet0/1.50

 description WIRELESS VLAN$ETH-LAN$$FW_INSIDE$

 encapsulation dot1Q 50

 ip address 10.0.50.1 255.255.255.192

 ip nat inside

 ip virtual-reassembly in

!

interface GigabitEthernet0/1.90

 description DATA VLAN$ETH-LAN$$FW_INSIDE$

 encapsulation dot1Q 90

 ip address 10.0.90.1 255.255.255.192

 ip nat inside

 ip virtual-reassembly in

!

!

!

ip access-list extended guest-internet

 deny   ip 192.168.1.0 0.0.0.255 10.0.0.0 0.0.0.63

 deny   ip 192.168.1.0 0.0.0.255 10.0.10.0 0.0.0.63

 deny   ip 192.168.1.0 0.0.0.255 10.0.30.0 0.0.0.63

 deny   ip 192.168.1.0 0.0.0.255 10.0.50.0 0.0.0.63

 deny   ip 192.168.1.0 0.0.0.255 10.0.70.0 0.0.0.63

 deny   ip 192.168.1.0 0.0.0.255 10.0.90.0 0.0.0.63

 deny   ip any 10.0.0.0 0.0.0.63

 deny   ip any 10.0.10.0 0.0.0.63

 deny   ip any 10.0.30.0 0.0.0.63

 deny   ip any 10.0.50.0 0.0.0.63

 deny   ip any 10.0.70.0 0.0.0.63

 deny   ip any 10.0.90.0 0.0.0.63

 permit ip any any log

 

 

 

 

SWITCH 1: SG300-28

 

interface vlan 50

 name wireless

 ip dhcp relay enable

!

!

!

interface vlan 90

 name data

 ip dhcp relay enable

!

!

!

interface gigabitethernet25

 no negotiation

 description "GI25 -> C1941RTR"

 spanning-tree link-type point-to-point

 spanning-tree bpduguard enable

 switchport trunk allowed vlan add 10,25,30,50,70,90

 macro description switch

 !next command is internal.

 macro auto smartport dynamic_type switch

!

!

!

interface Port-channel1

 description "SG300-28 -> SF300-24P"

 spanning-tree link-type point-to-point

 switchport trunk allowed vlan add 10,25,30,50,70,90  

 macro description switch

 !next command is internal.

 macro auto smartport dynamic_type switch

 

 

 

 

SWITCH 2: SG300-24P

 

interface vlan 50

 name Wireless

 ip dhcp relay enable

!

!

interface vlan 90

 name Data

 ip dhcp relay enable

!

!

!

interface range fastethernet1-4

 description WIRELESS

 switchport trunk allowed vlan add 25

 switchport trunk native vlan 90

!     

!

!                                          

1 REPLY
New Member

Problem seems to be fixed.

Problem seems to be fixed. 

For those interested it where the channels of the radio that needed reconfiguring (too much interference from other AP's).

115
Views
0
Helpful
1
Replies
CreatePlease login to create content