Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

Autonomous AP QoS

hi Guys,

I am running some tests with autonomous AP QoS, it seems QoS is not working as expected in my setup and I am not able to figure out what I have done wrong. basically I have a pretty simeply setup, I have a 3560 switch connected to the 1260 Autonomous AP, I have configured marking for RTP traffic to DSCP EF, and through packet capture I am able to confirm RTP traffic left 3560 and sending to the AP is marked as DSCP EF.

I have got "dot11 priority-map avvid" configured on the autonomous AP and a open SSID, 7925 connects to this open voice ssid and I am able to see "VO" queue is incrementing from the 7925 phone, as expected.

now I have got the following QoS configured:

======================================

class-map match-all SCCP

match access-group name control_traffic

class-map match-all ef_traffic

match  dscp ef

class-map match-all RTP

match access-group name rtp_traffic

policy-map voice_policy

class RTP

  set cos 1

class SCCP

  set cos 1

class ef_traffic

  set cos 1

class class-default

  set cos 1

ip access-list extended control_traffic

permit udp any any eq 2000

permit udp any eq 2000 any

ip access-list extended rtp_traffic

permit udp any any range 16384 32767

permit udp any range 16384 32767 any

========================================

I have applied the policy-map to both ethernet and d0 subinterfaces, however it seems the phone still using the voice queue, not the background queue. I have tested with different combinations with traffic going in and out of the subinterface, still no change. if I do a "show policy-map int g0.666" (ssid is mapped to vlan 666 and policy map applied under subinterface g0.666 and d0.666), I am not able to see much traffic getting captured by the policy map, however at the mean time I was making a phone call for testing and I could see the voice queue incrementing on the phone.

could you please help with my configuration and what could went wrong?

thanks for your help.

2 REPLIES
Community Member

Do you have the QoS Element

Do you have the QoS Element for Wireless IP phone feature enabled?

well, for me setting the COS

well, for me setting the COS value (using policy map) on the radio interface does not make sense , as the COS is concerned on the trunk ports only , the packet inside the AP does not have any dot1q heard(after de-capsulating the dot1q tag from the switch ,) also the AP will not transmit the wireless frame with dot1q header ,  

 

this can make change if applied on the AP Ethernet egress , as the frame will be leaving the AP's Ethernet port with dot1q tag , 

 

as per my understanding the effect of changing the COS/DSCP will be on the next hope device , not on the same device which changed the value,  so if  packet received at the AP switchport with COS 5 , it will be treated as voice packet even if the AP is changing the COS vlaue on that traffic.  

 

maybe appling that policy on the AP ethernet ingress , will place that frame on the AP BE queue , 

test it and let us know, 

 

the AP does not classify traffic it prioritize traffic based on DSCP/COS device type , so the best way to test the QOS functionality is by collecting capture on the AP to see the traffic COS value leaving the AP. 

 

1569
Views
0
Helpful
2
Replies
CreatePlease to create content