Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco 871 Wireless config can't get dhcp address

I have an Cisco 871 router configured to connect back to my home office.  I can get a DHCP address when connected wired through the FE0 interface.  However, I cannot get an IP address through wireless.  I need to get an ip address in vlan 101 in the 10.38.201 subnet.  Here is the relavant config.  I have also attached the full config.

dot11 ssid nexusis

vlan 101

authentication open

authentication key-management wpa

guest-mode

wpa-psk ascii 7 06575D72181B5F4E5D

!

ip dhcp smart-relay

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.1.201 192.168.1.254

ip dhcp excluded-address 192.168.1.1 192.168.1.104

ip dhcp excluded-address 192.168.1.1 192.168.1.99

ip dhcp excluded-address 10.38.201.10 10.38.201.12

!

ip dhcp pool wireless

   network 10.38.201.16 255.255.255.240

   default-router 10.38.201.17

   option 150 ip 10.38.32.8

   dns-server 10.38.16.32

   domain-name nexusis.com

!

bridge irb

!

!

interface Loopback0

ip address 10.38.14.30 255.255.255.255

!

interface Tunnel0

bandwidth 1000

ip address 10.38.200.3 255.255.255.128

no ip redirects

ip mtu 1400

ip nhrp authentication DMVPN_NW

ip nhrp map 10.38.200.125 64.138.140.21

ip nhrp map multicast 64.138.140.21

ip nhrp network-id 100000

ip nhrp holdtime 360

ip nhrp nhs 10.38.200.125

ip tcp adjust-mss 1360

ip ospf network broadcast

ip ospf hello-interval 30

--More--                            ip ospf priority 0

delay 1000

qos pre-classify

tunnel source FastEthernet4

tunnel mode gre multipoint

tunnel key 100000

tunnel protection ipsec profile SDM_Profile1

!

interface Null0

no ip unreachables

!

interface FastEthernet0

switchport trunk native vlan 101

switchport mode trunk

switchport voice vlan 101

spanning-tree portfast

!

interface FastEthernet1

switchport mode trunk

switchport voice vlan 101

!

interface FastEthernet2

switchport mode trunk

--More--                            switchport voice vlan 101

!

interface FastEthernet3

switchport mode trunk

switchport voice vlan 101

!

interface FastEthernet4

description $FW_OUTSIDE$$ES_WAN$

ip address dhcp client-id FastEthernet4

ip access-group 101 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

ip flow ingress

ip nat outside

ip ips sdm_ips_rule in

ip inspect DEFAULT100 out

ip virtual-reassembly

ip ospf cost 100

duplex auto

speed auto

no cdp enable

--More--                            service-policy output SDM-Pol-FastEthernet4

!

interface Dot11Radio0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip flow egress

ip virtual-reassembly

!

encryption mode ciphers aes-ccm

!

encryption vlan 101 mode ciphers aes-ccm

!

ssid nexusis

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

channel 2462

station-role root

no cdp enable

!

--More--                           interface Dot11Radio0.101

encapsulation dot1Q 101 native

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 spanning-disabled

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$

no ip address

bridge-group 1

!

interface Vlan101

ip address 10.38.201.17 255.255.255.240

ip nbar protocol-discovery

!

interface Dialer0

no ip address

!

interface BVI1

description $ES_LAN$$FW_INSIDE$

--More--                            ip address 192.168.2.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip flow ingress

ip nat inside

ip ips sdm_ips_rule out

ip virtual-reassembly

ip tcp adjust-mss 1452

!

bridge 1 protocol ieee

bridge 1 route ip

6 REPLIES
Bronze

Cisco 871 Wireless config can't get dhcp address

Please check the below link for Step by Stey   DHCP Configuration in WLC-871

http://www.piglet-net.net/tech/cisco/cisco-871W-simple.html

Re: Cisco 871 Wireless config can't get dhcp address

So bridge group 1 is tied to BVi1, not vlan 101.
Since the DHCP scope isn't for BVI1, you won't get an IP address.

I would set a different bridge group # for dot11radio 0.101 and then put that bridge group on vlan 101 as well.

Sent from Cisco Technical Support iPhone App

Cisco 871 Wireless config can't get dhcp address

I'd move the IP address from the VLAN 101 interface to the BVI 1 interface, and then add bridge-group 1 under the VLAN

basicaly

interface Vlan101

no ip address

bridge-group 1

Interface BVI 1

ip address 10.38.201.17 255.255.255.240

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Cisco 871 Wireless config can't get dhcp address

Kindly find the link below to configure DHCP steps and even the VLAN configuration.

http://www.cisco.com/en/US/docs/routers/access/800/850/software/configuration/guide/dhcpvlan.html#wpxref42306

Silver

Cisco 871 Wireless config can't get dhcp address

Kindly check the following link for wifi deployment(template)

                        https://supportforums.cisco.com/docs/DOC-16087

Cisco Employee

Cisco 871 Wireless config can't get dhcp address

interface Vlan101 and interface Dot11Radio0.101 both should be mappped to the same bridge group.

2737
Views
4
Helpful
6
Replies