Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Cisco network Avaya IP phones

We have a Cisco network with Avaya phone system. I am working on QoS and would love some of you to give it a quick look.

Our network: 3750 stack as our core, 2960S switches in the perimeter closets, a 5508 wireless controller, 3502i wireless AP's, Avaya 9608 IP phones, and Avaya 3645 wireless phones. The 3645 phones are probably our biggest problem at this point. About 25% of the time calls are dropped or choppy. Wireless on the data side is fantastic. I assume phones connecting via wireless should still be tagged with a 6 (avaya thinks COS 6 = voice). I have my 5508 QoS set to use platinum for voice for the phone ssid. VLAN 500 Data VLAN 200 Voice. Also I've read in several spots the AP ports need to trust dscp but if that is the case why swap to cos?

Our Standard Port Configuration for a 3502i Cisco AP

interface GigabitEthernet1/0/19

description Wireless AP Uplink

switchport access vlan 500

switchport mode access

switchport voice vlan 200

srr-queue bandwidth share 10 10 60 20

priority-queue out

mls qos trust dscp

auto qos trust

spanning-tree portfast

Our Standard Port Configuration for an end user with a 9608 phone and desktop computer

interface GigabitEthernet1/0/19

switchport access vlan 500

switchport mode access

switchport voice vlan 200

srr-queue bandwidth share 10 10 60 20

priority-queue out

mls qos trust cos

auto qos trust

spanning-tree portfast

Our Standard Port Configuration for a Trunk Port (non core)

interface GigabitEthernet1/0/24

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

priority-queue out

mls qos trust cos

macro description cisco-switch

auto qos trust

spanning-tree link-type point-to-point

Port Configuration for a WLC 5508 (connected at our core)

interface GigabitEthernet1/0/23

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

priority-queue out

mls qos trust cos

auto qos trust

spanning-tree link-type point-to-point

channel-group 1 mode on

interface GigabitEthernet2/0/26 for a Trunk Port (core)

description PoE Stack in Engineering

switchport trunk encapsulation dot1q

switchport mode trunk

load-interval 30

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

macro description cisco-switch | cisco-switch

spanning-tree link-type point-to-point

Core QoS

mls qos map cos-dscp 0 8 16 26 32 46 46 56

mls qos srr-queue input bandwidth 90 10

mls qos srr-queue input threshold 1 8 16

mls qos srr-queue input threshold 2 34 66

mls qos srr-queue input buffers 67 33

mls qos srr-queue input cos-map queue 1 threshold 2 1

mls qos srr-queue input cos-map queue 1 threshold 3 0

mls qos srr-queue input cos-map queue 2 threshold 1 2

mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7

mls qos srr-queue input cos-map queue 2 threshold 3 3 5

mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15

mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7

mls qos srr-queue input dscp-map queue 1 threshold 3 32

mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23

mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48

mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56

mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63

mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31

mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47

mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 3 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 2 4

mls qos srr-queue output cos-map queue 4 threshold 2 1

mls qos srr-queue output cos-map queue 4 threshold 3 0

mls qos srr-queue output dscp-map queue 1 threshold 3 40 41 42 43 44 45 46 47

mls qos srr-queue output dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31

mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3 16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 3 threshold 3 32 33 34 35 36 37 38 39

mls qos srr-queue output dscp-map queue 4 threshold 1 8

mls qos srr-queue output dscp-map queue 4 threshold 2 9 10 11 12 13 14 15

mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7

mls qos queue-set output 1 threshold 1 138 138 92 138

mls qos queue-set output 1 threshold 2 138 138 92 400

mls qos queue-set output 1 threshold 3 36 77 100 318

mls qos queue-set output 1 threshold 4 20 50 67 400

mls qos queue-set output 2 threshold 1 149 149 100 149

mls qos queue-set output 2 threshold 2 118 118 100 235

mls qos queue-set output 2 threshold 3 41 68 100 272

mls qos queue-set output 2 threshold 4 42 72 100 242

mls qos queue-set output 1 buffers 10 10 26 54

mls qos queue-set output 2 buffers 16 6 17 61

we have dual 46's to map to 5 and 6 for Cisco and Avaya. Any tips would be greatly appreciated.

9 REPLIES
Cisco Employee

Re: Cisco network Avaya IP phones

Brian,

My suggestion would be to check out the doc below.  It is a very good read and difficult to find

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_tech_note09186a0080c01d2c.shtml

Let me know if you have any follow up questions after that.

As far as Avaya best practice with Cisco is concerned, I am assuming you followed something similar to this:

http://devconnect.avaya.com/public/download/interop/Cisco-Wireless.pdf

There should be a newer version of this somewhere out there I remember seeing it at one point.

Cheers,
Erwin

______________________________________

How helpful was I? Don't forget to rate me when you have the chance!

Cheers, Erwin ______________________________________ How helpful was I? Don't forget to rate me when you have the chance!
VIP Purple

Re: Cisco network Avaya IP phones

Hi Brian,

Few things to highlight. In wireless frames , all voice packets comes as User Priority (UP) 6 as long as end device is WMM capable (I believe it is the case with this Avaya phone). that's why they refer CoS is 6, but it is WMM UP value they are talking about not CoS in your wired network.

When these wireless frames with UP of 6 come to Cisco AP they will map it into DSCP=EF (equivalent CoS=5) in CAPWAP headers & send it to WLC.(original IP packet DSCP is intact).Please check your voice WLAN configured correctly with key settings like this

1. WLAN QoS profile set to Platinum

2. Platinum QoS profile 802.1p value set to 6

3. WLAN's WMM  setting should be either "required" or "Allow" 

4. Voice admission control status is enabled

Do not get confused Cisco CoS =5 & Avaya CoS=6 as they were refering to two different  thing & as long as you configure WLC with the above settings it will take care about these WMM-UP to Cisco AVVID mapping.

Therefore you should not map CoS=5 & CoS=6 into DSCP 46 in your switches mapping table. This will resulting all your routing, CAPWAP mgt & network control traffic (DSCP=48 or CS6 packets) mapped to same quese where voice packet goes. Leave CoS=6 mappint to DSCP=48.

Also once you trust DSCP on AP connected switchport, you do not want to trust CoS in all inter-switch trunk ports. This will lead to re-write original packet DSCP based on the cos-dscp mapping table everytime packet goes through a inter-switch trunk link. Best practice is to TRUST DSCP in your inter-switch trunk links.

You did not mention about 2960 switch QoS configuration, it is really important to have consistant QoS mapping values in all of your switches, not only two core switches. This will ensure end-to-end QoS preservation.

It would be better if you could take some packet captures & verify Avaya wireless phones voice traffic goes to your wired network as DSCP=EF traffic.

See the below post to get more information how I did this

http://mrncciew.wordpress.com/2012/11/28/understanding-wireless-qos-part-1

Also in which band (2.4GHz or 5GHz) these phones operate ? If it is 2.4GHz it is challenging to give such sensitive services as it is already congested.  If option is availabe, you have to use 5GHz for voice.

If you could post output of "show wlan to see how you have configured the WLAN with other parameters.That will help us to understand any other settings which need to be optimized.

Regards

Rasika

New Member

Re: Cisco network Avaya IP phones

The non core trunk listed above is the 2960 port config. I see we should be trusting DSCP on these trunks.

Our Standard Port Configuration for a Trunk Port (non core) - 2960S

interface GigabitEthernet1/0/24

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

priority-queue out

mls qos trust dscp

auto qos trust

spanning-tree link-type point-to-point

Our WLC is configured as you suggested above.

VIP Purple

Re: Cisco network Avaya IP phones

Hi Brian,

As requested go to WLC CLI & get "show wlan " output to get an idea how exactly you configured your voice SSID.

Also "show mls qos map" & "show mls qos interface gig 1/0/24 statistics" of your 2960 switch if that port connect back to your core. Do you see your trunk links is having high utilization ? What is normal bandwidth usage of those trunk links ?

Regards

Rasika

Re: Cisco network Avaya IP phones

on the WLC, under Wireless > QoS > Profiles did you go in and enable the dot1p tag?

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: Cisco network Avaya IP phones

Yes. Originally we didn't have that selected but changed it a month ago.

Thanks for the tip on that.

Re: Cisco network Avaya IP phones

What VLAN is the management for the WLC?  ALl the frames to and from the AP are going to be in the WLC management VLAN.  If you are not tagging that VLAN, then the QoS isn't going to work.

From the trunk port config to the WLC, you are tagging VLAN 1 for management(default)

Can you post the output of

show interface summary

HTH,
Steve

------------------------------------------------------------------------------------------------
Please remember to rate useful posts, and mark questions as answered

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
New Member

Re: Cisco network Avaya IP phones

core3750G#show  interface summary

*: interface is up

IHQ: pkts in input hold queue     IQD: pkts dropped from input queue

OHQ: pkts in output hold queue    OQD: pkts dropped from output queue

RXBS: rx rate (bits/sec)          RXPS: rx rate (pkts/sec)

TXBS: tx rate (bits/sec)          TXPS: tx rate (pkts/sec)

TRTL: throttle count

  Interface               IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL

-------------------------------------------------------------------------

* Vlan1                    0     0    0     0  1000    2  1000    2    0

* Vlan50                   0     0    0     0     0    0     0    0    0

* Vlan100                  0     0    0     0     0    1     0    0    0

* Vlan200                  0     0    0     0  6000    7  6000    7    0

* Vlan201                  0     0    0     0     0    0     0    0    0

* Vlan300                  0     0    0     0  2000    3     0    0    0

* Vlan301                  0     0    0     0  4000    6  1000    1    0

* Vlan302                  0     0    0     0  1000    1     0    0    0

* Vlan303                  0     0    0     0  1000    2     0    0    0

* Vlan304                  0     0    0     0  2000    3     0    0    0

* Vlan305                  0     0    0     0  1000    1     0    0    0

* Vlan306                  0   252    0     0     0    0     0    0    0

* Vlan307                  0     0    0     0     0    0     0    0    0

  Interface               IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL

-------------------------------------------------------------------------

* Vlan308                  0     0    0     0  2000    2  2000    2    0

* Vlan400                  0     0    0     0     0    0     0    0    0

* Vlan401                  0     0    0     0     0    0     0    0    0

* Vlan700                  0     0    0     0     0    0     0    0    0

* Vlan800                  0     0    0     0     0    0     0    0    0

* Vlan999                  0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/1     0     0    0   232     0    0     0    0    0

* GigabitEthernet1/0/2     0     0    0     0     0    0  2000    3    0

  GigabitEthernet1/0/3     0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/4     0     0    0 50919     0    0     0    0    0

* GigabitEthernet1/0/5     0     0    0     0     0    1  1000    2    0

* GigabitEthernet1/0/6     0     0    0     0  4000    1  3000    1    0

* GigabitEthernet1/0/7     0     0    0 25111     0    0     0    0    0

  GigabitEthernet1/0/8     0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/9     0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/10    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/11    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/12    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/13    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/14    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/15    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/16    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/17    0     0    0     0     0    0     0    0    0

  Interface               IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL

-------------------------------------------------------------------------

  GigabitEthernet1/0/18    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/19    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/20    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/21    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/22    0     0    0     0     0    0     0    0    0

  GigabitEthernet1/0/23    0     0    0     0     0    0     0    0    0

* GigabitEthernet1/0/24    0     0    0     0 162000  157 316000  206    0

* GigabitEthernet1/0/25    0     0    0     0 93949000  10118 49716000  8038    0

* GigabitEthernet1/0/26    0     0    0     0 40000   30 105000   87    0

* GigabitEthernet1/0/27    0     0    0     0 572000  144 508000  190    0

* GigabitEthernet1/0/28    0     0    0     0 9445000  3095 56042000  5238    0

* GigabitEthernet2/0/1     0     0    0     0 872000  328 999000  755    0

* GigabitEthernet2/0/2     0     0    0   110 33732000  4942 4225000  3717    0

* GigabitEthernet2/0/3     0     0    0     0 198000   25 75000   79    0

* GigabitEthernet2/0/4     0     0    0     0 612000  281 513000  342    0

* GigabitEthernet2/0/5     0     0    0  9777 504000   75 399000  137    0

* GigabitEthernet2/0/6     0     0    0    91 49000   42 98000   97    0

  GigabitEthernet2/0/7     0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/8     0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/9     0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/10    0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/11    0     0    0     0     0    0     0    0    0

  Interface               IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL

-------------------------------------------------------------------------

  GigabitEthernet2/0/12    0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/13    0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/14    0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/15    0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/16    0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/17    0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/18    0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/19    0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/20    0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/21    0     0    0     0     0    0     0    0    0

  GigabitEthernet2/0/22    0     0    0     0     0    0     0    0    0

* GigabitEthernet2/0/23    0     0    0     0 1147000  150 150000  151    0

* GigabitEthernet2/0/24    0     0    0     0 25000    6 38000   13    0

* GigabitEthernet2/0/25    0     0    0     0 2651000  361 597000  334    0

  GigabitEthernet2/0/26    0     0    0     0     0    0     0    0    0

* GigabitEthernet2/0/27    0     0    0     0 10122000  1713 8924000  1660    0

* GigabitEthernet2/0/28    0     0    0     0 3665000  904 4491000  820    0

* GigabitEthernet3/0/1     0     0    0 45777     0    0     0    0    0

* GigabitEthernet3/0/2     0     0    0 45916 691000  618 549000  876    0

* GigabitEthernet3/0/3     0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/4     0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/5     0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/6     0     0    0     0     0    0     0    0    0

  Interface               IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL

-------------------------------------------------------------------------

  GigabitEthernet3/0/7     0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/8     0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/9     0     0    0     0     0    0     0    0    0

* GigabitEthernet3/0/10    0     0    0     0 217000    4 125000   12    0

  GigabitEthernet3/0/11    0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/12    0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/13    0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/14    0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/15    0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/16    0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/17    0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/18    0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/19    0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/20    0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/21    0     0    0     0     0    0     0    0    0

  GigabitEthernet3/0/22    0     0    0     0     0    0     0    0    0

* GigabitEthernet3/0/23    0     0    0     0 4862000  841 1125000  591    0

* GigabitEthernet3/0/24    0     0    0     0 5416000  680 983000  551    0

* GigabitEthernet3/0/25    0     0    0    85 4331000  395 502000  299    0

  GigabitEthernet3/0/26    0     0    0     0     0    0     0    0    0

* GigabitEthernet3/0/27    0     0    0     0 1174000  744 1929000  760    0

* GigabitEthernet3/0/28    0     0    0     0 17477000  5762 57270000  7734    0

* GigabitEthernet4/0/1     0     0    0   307 12000   11 24000   14    0

  Interface               IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL

-------------------------------------------------------------------------

* GigabitEthernet4/0/2     0     0    0     0 3146000  402 1187000  358    0

  GigabitEthernet4/0/3     0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/4     0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/5     0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/6     0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/7     0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/8     0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/9     0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/10    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/11    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/12    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/13    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/14    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/15    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/16    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/17    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/18    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/19    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/20    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/21    0     0    0     0     0    0     0    0    0

  GigabitEthernet4/0/22    0     0    0     0     0    0     0    0    0

* GigabitEthernet4/0/23    0     0    0     0 250000  137 893000  212    0

* GigabitEthernet4/0/24    0     0    0     0 232000  128 523000  194    0

  Interface               IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL

-------------------------------------------------------------------------

  GigabitEthernet4/0/25    0     0    0     0     0    0     0    0    0

* GigabitEthernet4/0/26    0     0    0   249 6906000  1152 2542000  987    0

* GigabitEthernet4/0/27    0     0    0     0 34000    8 73000   61    0

* GigabitEthernet4/0/28    0     0    0     0 1367000  492 1451000  490    0

* Port-channel1            0     0    0     0 14772000  2905 14379000  2733    0

New Member

Cisco network Avaya IP phones

The only port with any significant drops is:  * GigabitEthernet3/0/2     0     0    0 45916 691000  618 549000  876    0.

Uou can issue the following command:  #show mls qos inter g 3/0/2 stat

From this output you can determine which queue is dropping packets and the associated dscp tagging.  Ideally you are not dropping voice traffic.

5529
Views
0
Helpful
9
Replies