Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IP Helper problem I think

Hi all

I'm trying to configure my Cisco AP which is currently transporting my data network to also carry my voice traffic, I have set-up two vlans which are vlan 1 for data and vlan 2 for my voice.

My Swtich is configured as the DHCP server and my cabled phones are working well and getting IP's from the Switch however my wireless IP Phone is not and I'm getting DHCP time outs.

Below are my AP and Switch configurations and as you will see I have dropped in the ip helper address on a couple of lines which as failed to resolve my issue.

Switch

hostname SW
ip routing
no ip domain-lookup
ip dhcp excluded-address 10.50.50.250
!        
ip dhcp pool Voice
   network 10.50.50.0 255.255.255.0
   default-router 10.50.50.250
   option 150 ip 192.168.3.253
   dns-server 194.168.4.100 194.168.8.100
   lease 14
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/44
description CISCO AP
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2
switchport mode trunk
switchport nonegotiate
srr-queue bandwidth share 10 10 60 20
srr-queue bandwidth shape  10  0  0  0
mls qos trust cos
macro description cisco-wireless
auto qos voip trust
spanning-tree bpduguard enable
!
!
interface Vlan1
description *** Data Vlan ***
ip address 192.168.3.250 255.255.255.0
!
interface Vlan2
description *** Voice Vlan ***
ip address 10.50.50.250 255.255.255.0
ip helper-address 192.168.3.250
!
ip default-gateway 192.168.3.254
ip classless
ip http server
ip http authentication local
!
!
control-plane

AP

hostname AP
no aaa new-model
!
dot11 ssid data
   vlan 1
   authentication open
   guest-mode
!
dot11 ssid voice
   vlan 2
   authentication open
!
power inline negotiation prestandard source
!
username Cisco password 7 xxxxxxxxxxxx
!
bridge irb
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 1 key 1 size 128bit 7 2E17A6E627A58FA4D039AD5B57BB transmit-key
encryption vlan 1 mode wep mandatory
!
encryption vlan 2 key 1 size 128bit 7 E3BEDBF25198B75AF471C34CFBB0 transmit-key
encryption vlan 2 mode wep mandatory
!
ssid data
!
ssid voie
!
antenna transmit right
antenna receive right
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.2
encapsulation dot1Q 2
no ip route-cache
bridge-group 2
bridge-group 2 subscriber-loop-control
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
bridge-group 2 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
shutdown
!
encryption vlan 1 key 1 size 128bit 7 7xxxxx transmit-key
encryption vlan 1 mode wep mandatory
!
encryption vlan 2 key 1 size 128bit 7 xxxxx transmit-key
encryption vlan 2 mode wep mandatory
!
ssid data
!
no dfs band block
channel dfs
station-role root
!
interface Dot11Radio1.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio1.2
encapsulation dot1Q 2
no ip route-cache
bridge-group 2
bridge-group 2 subscriber-loop-control
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
bridge-group 2 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface FastEthernet0.2
encapsulation dot1Q 2
ip helper-address 192.168.3.250
no ip route-cache
bridge-group 2
no bridge-group 2 source-learning
bridge-group 2 spanning-disabled
!
interface BVI1
ip address 192.168.3.244 255.255.255.0
no ip route-cache
!
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip

Thanks all

Martyn

2 REPLIES
New Member

Re: IP Helper problem I think

Hi all, do you need more information from me to help dianognose my problem?

Thanks

Martyn

New Member

Re: IP Helper problem I think

I have mad a couple of changes on my ap which atill has not resolved my issue...

interface FastEthernet0.1
encapsulation dot1Q 1 native
ip helper-address 10.50.50.250
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface FastEthernet0.2
encapsulation dot1Q 2
ip helper-address 10.50.50.250
no ip route-cache
bridge-group 2
no bridge-group 2 source-learning
bridge-group 2 spanning-disabled

which points VLAN 2 on my switch, still no joy.

Am I barking up the wrong tree here?

Thanks

792
Views
0
Helpful
2
Replies
CreatePlease to create content