Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

No audio between two 7920 phones when vlan is configured on Access Point

Hi Folks,

I have configured two 7920 wireless IP phone with CME installed on 2651XM router, and associating the 7920 Wireless IP Phone with 1200 Cisco Access Point.

Without VLAN configured on the Access Point , the two phones can establish a call and the voice is hared from both side without any problem.

As soon as I configure VLANs on the access point , problems get started, here is the exact symptoms :

1 – no audio can be hared when a call is made between two 7920, although I can ring the other 7920 and it shows connected on the LCD but without any audio.

2 - there is no problems If I call between a 7920 phone and 7912 phone, the audio can be hared in both directions.

Thanks Allot

Here is the configuration of the AP

ap#show run

Building configuration...

Current configuration : 3291 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ap

!

ip subnet-zero

!

no aaa new-model

dot11 vlan-name Data vlan 3

dot11 vlan-name Management vlan 1

dot11 vlan-name Voice vlan 2

dot11 arp-cache

class-map match-all _class_Data-Packets0

match ip precedence 0

class-map match-all _class_Voice-Packets0

match ip precedence 0

!

!

policy-map Voice-Packets

class _class_Voice-Packets0

set cos 0

policy-map Data-Packets

class _class_Data-Packets0

set cos 0

!

bridge irb

!

!

interface Dot11Radio0

no ip address

no ip route-cache

!

encryption vlan 2 key 1 size 128bit 7 E6050B0DB7423C1AAEF307F0D9D8 transmit-key

encryption vlan 2 mode wep mandatory

!

ssid data

vlan 3

authentication open

!

ssid management

vlan 1

authentication open

!

ssid voice

vlan 2

authentication open

!

short-slot-time

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

power local cck 20

power local ofdm 20

power client 20

channel 2437

station-role root

!

interface Dot11Radio0.1

encapsulation dot1Q 1 native

service-policy input Data-Packets

service-policy output Data-Packets

no ip route-cache

bridge-group 1

bridge-group 1 subscriber-loop-control

bridge-group 1 block-unknown-source

no bridge-group 1 source-learning

no bridge-group 1 unicast-flooding

bridge-group 1 spanning-disabled

!

interface Dot11Radio0.2

encapsulation dot1Q 2

service-policy input Voice-Packets

service-policy output Voice-Packets

no ip route-cache

bridge-group 2

bridge-group 2 spanning-disabled

!

interface Dot11Radio0.3

encapsulation dot1Q 3

service-policy input Data-Packets

service-policy output Data-Packets

no ip route-cache

bridge-group 3

bridge-group 3 subscriber-loop-control

bridge-group 3 block-unknown-source

no bridge-group 3 source-learning

no bridge-group 3 unicast-flooding

bridge-group 3 spanning-disabled

!

interface FastEthernet0

no ip address

no ip route-cache

duplex auto

speed auto

!

interface FastEthernet0.1

encapsulation dot1Q 1 native

no ip route-cache

bridge-group 1

no bridge-group 1 source-learning

bridge-group 1 spanning-disabled

!

interface FastEthernet0.2

encapsulation dot1Q 2

ip address 172.16.1.100 255.255.255.0

no ip route-cache

bridge-group 2

no bridge-group 2 source-learning

bridge-group 2 spanning-disabled

!

interface FastEthernet0.3

encapsulation dot1Q 3

no ip route-cache

bridge-group 3

no bridge-group 3 source-learning

bridge-group 3 spanning-disabled

!

interface BVI1

no ip address

no ip route-cache

!

ip http server

no ip http secure-server

ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag

ip radius source-interface BVI1

logging snmp-trap emergencies

logging snmp-trap alerts

logging snmp-trap critical

logging snmp-trap errors

logging snmp-trap warnings

bridge 1 route ip

!

!

!

3 REPLIES
New Member

Re: No audio between two 7920 phones when vlan is configured on

Sorry for the spelling heard not hared :)

To add more notes: the switch is connected to the access point via the port 1/0/45 and the switch is connected to the CME router via 1/0/17 and to the remaining IP Phones via 1/0/46 and 1/0/43

Let me post the configuration of the switch:

Switch#show run

Building configuration...

Current configuration : 2411 bytes

!

version 12.2

.

.

!

hostname Switch

!

!

switch 1 provision ws-c3750-48p

ip subnet-zero

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

!

interface FastEthernet1/0/17

switchport access vlan 2

!

!

interface FastEthernet1/0/41

switchport access vlan 2

!

interface FastEthernet1/0/42

!

interface FastEthernet1/0/43

switchport access vlan 2

!

interface FastEthernet1/0/44

!

interface FastEthernet1/0/45

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-3

switchport mode trunk

switchport nonegotiate

!

interface FastEthernet1/0/46

switchport access vlan 2

!

interface Vlan1

no ip address

shutdown

!

interface Vlan2

ip address 172.16.1.150 255.255.255.0

!

interface Vlan3

ip address 192.168.80.1 255.255.255.0

!

interface Vlan30

no ip address

New Member

Re: No audio between two 7920 phones when vlan is configured on

For the ap config, should add the following to the radio interfaces for vlan 2, where X matches the bridge #.

bridge-group 2 subscriber-loop-control

bridge-group 2 block-unknown-source

no bridge-group 2 source-learning

no bridge-group 2 unicast-flooding

Also usually would put IP for mgmt on BVI which maps to native VLAN.

Should work after applying this change as these phones are in the same VLAN, so no routing is needed.

Also should unshut int vlan 1, since you are using that VLAN in your network. Otherwise change the 1/0/45 to vlan 2 and make that the native vlan on the AP side as well.

New Member

Re: No audio between two 7920 phones when vlan is configured on

Thank you , it is working great now, I was also missing many other items such as setting the data rate to 11 Mbps as required and the more higher data rates as enable, also my COS was set to 0 , it should be set either to 5 or 6.

Thanks again

234
Views
0
Helpful
3
Replies
CreatePlease login to create content