Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 

QoS config for 7920 IP phones

Hi,

I have a network with some AP1100 with 12.2(11)JA, in the document "Wireless IPT Design Guide for the Cisco 7920 IP Phone" I can read:

"The Cisco 7920 IP Phones support a QoS similar to EDCF for upstream (toward the AP) traffic. In additional, the Cisco 7920 dynamically announces its presence with the Cisco Aironet AP to ensure its downstream traffic is placed into the high priority queue on the AP. This dynamic announcement is done through Cisco Discovery Protocol (CDP). The CDP packets are sent from the Cisco 7920 to the AP and identify the phone so that the AP can place all traffic to the phone in the high priority queue.

If we have the CDP enable in the Wireless VLAN

do I need to apply any QoS, or this is done by the AP automatically? because of the sentence: "the AP can place all traffic TO the phone in the high priority queue" besides this having the "QoS Element for Wireless Phones setting" which maps to the IOS command dot11 phone is mandatory?.

Well my last question is that we have configured in the switch ports (Catalyst 2950 EI) where tere are APs connected, as the document recommends:

interface FastEthernet0/9

switchport access vlan 2

switchport voice vlan 6

no ip address

mls qos trust cos

auto qos voip trust

spanning-tree portfast

And I can read that the IP phone uses cos 6 for all its voice packets. Is this transmitted through the Fast Ethernet Interface of the wireless point? and we don't change it in any policy in the APs; in this case I think that we musn't apply "auto qos voip trust" which automatically generates "mls qos trust cos" because all the Cisco Catalyst LAN is configured for carrying voice which enters with cos 5. Is this correct?

I have captured packets , and all the packets the packets that came from the IP phone have CoS 0 and IP DSCP 0.

I also tried to apply a policy out in the Fastethernet port of the AP and set all the packets for the voice VLAN to 5 and even this method doesn't work, all packets have CoS 0 and IP DSCP 0.

Anyoune has other suggestion?

Regards.

Regards

2 REPLIES
Cisco Employee

Re: QoS config for 7920 IP phones

CoS bits are only carried on 802.1Q trunks - you will not see the COS value a frame had when observing it on the wireless link, and an IP phone will not set CoS bits (just EDCF/TOS bits).

802.1D, section H2.4 defines CoS 5 as Video and CoS 6 as Voice

RFC 3246 defines the EF PHB; (TOS 5) while the standards never explicit state this is to be used for voice, it is fairly obvious that voice as an application probably fits the "low delay, low jitter, low loss" service this PHB defines better than any other application.

The AP uses the frames CoS value to assign the frame to the appropriate EDCF queue within the AP. Frames in the voice queue will have a lower CWmin than traffic in other queues.

The If frames arriving at the AP have a CoS value (only 802.1Q trunks can carry the 802.1p CoS bits), then they are queued according to that COS value and classifications based on Precedence/DSCP/filters are ignored.

If no CoS is specified, it is possible to classify traffic to the appropriate CoS (which is thereby mapped into the corresponding EDCF queue) based on; IP precedence or IP DSCP or IP Protocol 119 (Spectralink) or a filter (MAC, Ethertype, IP address/port/protocol).

from the IOS manual http://www.cisco.com/univercd/cc/td/doc/product/wireless/airo1100/accsspts/i12211ja/i12211sc/s11qos.htm#1046778 ;

-- Default Cisco AVVID networks map voice traffic to TOS-5 == DSCP-EF

-- Default Cisco switch behavior is to map TOS-5 value directly to CoS-5 value on an Ethernet VLAN trunk

-- Default Cisco AP behavior is to map CoS-5 to the AP's "video" EDCF queue (5) which has worse QoS characteristics (CWmin/CWmax) than the "voice" EDCF queue (6).

For traffic from the network to the AP

---------------------------------------

-- EITHER - Reclassify ToS-5 to CoS-6 at the switches at the edge of the network.

Take DSCP EF traffic and classify it with a CoS of 6 ONLY on the links facing the AP’s. This is not default behavior AND probably ONLY works with L3 aware switches (3550 and above). It will require a service policy applied outbound on the AP facing interface.

-- Or - Change the EDCF values for Queue 5 to match those required for voice (queue-6)

For traffic from the AP to the network

---------------------------------------

configure the edge switch to set CoS 6 / DSCP ???? traffic to have a CoS of 5 and a DSCP of EF

Re: QoS config for 7920 IP phones

Thanks a lot,

My problem is that I have 2950 EI switches in all my wiring closets, and of course I don't like to trust DSCP values from all the AP traffic. Because of this, for traffic from the AP to the edge L2 Switch I only can set the voice traffic to have a DSCP of EF using policers in the wireless ports, but not the CoS of 5.

What I would like to know is: if this DSCP value set in the ingress port is going to be used as the DSCP of the packet for internal use, and DSCP-to-CoS map of the switch will map EF value to CoS 5, and with this the packets will be placed in queue 4 (expedite queue), configured for Voice.

I don' know if I must configure int the ingress port " mls qos trust dscp ", what do you think?

class-map match-all WirelessVoice

match access-group name WLANtoEth

!

policy-map WirelessVoiceIn

class WirelessVoice

set ip dscp 46

interface FastEthernet0/9

mls qos trust dscp

service-policy input WirelessVoiceIn

For the same reason (L2 Switch in the wiring closet), for the traffic from the network to the AP I think I'll Change the EDCF values for Queue 5 to match those required for voice (queue-6).

614
Views
10
Helpful
2
Replies
CreatePlease to create content