Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

WLC 5580 Interfaces with LAG

Dear all,

I have a 5508 WLC and i am configuring it to support for wireless Vlans, i have configured the vlans on the core switch, then i have connected the WLC to the core switch using two cables, and enabled LAG.

I have also configured an interface for every vlan that i have and a wireless SSID for the interfaces.

the controller is directly connected to the core switch (6500), and the LAG seems to work fine.

the LAG configuration is:

int port-channel 5

switchport

switchport trunk encaps dot1q

switchport mode trunk

interface g1/1/2

switchport

switchport trunk encap dot1q

switchport mode trunk

channel-group 5 mode on

Show lag summary on the controller is : LAG enabled.

now i have a management interface, interface vlan tag is 2.

and the SSID's can be seen as broadcasted, now when i connect to a wireless SSID i cant ping the gateway, but when i connect to the management interface SSID everything is fine.

also when i connect to another SSID, and give it an IP address from the management subnet i also can ping everything.

but when i give my LapTop an IP from the Wireless vlan subnet that should take i cannot ping anything even the gateway.

any idea.

thanx in advance

7 REPLIES

WLC 5580 Interfaces with LAG

another note

the AP interface is configured as:

int g1/0/2

switchport mode trunk

switchport trunk native vlan 2

speed 100

duplex full

Hall of Fame Super Silver

Re: WLC 5580 Interfaces with LAG

The AP's do not need to be in a trunk port just an access port unless they are in h-reap mode. Make sure that you only allow the vlans you have on the wlc defined on the trunk port. Also make sure you are not routing the service port. The service port and the management ip of the wlc should not be able to communicate.

Thanks,

Scott Fella

Sent from my iPhone

-Scott
*** Please rate helpful posts ***

WLC 5580 Interfaces with LAG

Dear Scott,

thanx alot for your reply.

i have canged the port that is connected to the AP to:

int g1/1/2

switchport mode access

switchport access vlan 2

i am not running H-Reap, also the AP are joined  to the controller through the management interface and i didn't configure the Service-port.

still cannot ping vlan gateway unless i give my device an ip from the managenet vlan subnet.

WLC 5580 Interfaces with LAG

it seems that i have forgot to assign the wireless interface to the created Wlan.

it is now working, finally.

thanks scott

Hall of Fame Super Silver

Re: WLC 5580 Interfaces with LAG

one other thing.... I wouldn't hard set the speed and duplex on the AP unless you also configure it on the AP. I just noticed that when you had it set as a trunk.

Sent from Cisco Technical Support iPhone App

-Scott
*** Please rate helpful posts ***

WLC 5580 Interfaces with LAG

i have just set the speed and duplexity because the AP interface is fastethernet and the switch that is connected to is gig ethernet.

and it cannot be seen as a cdp neighbor unless you modify the speed, but no clear reason of the duplexity :-)

WLC 5580 Interfaces with LAG

What VLAN are you putting the clients on?  If you do a show vlan brief on the switch, do you see that vlan created?  If you connect a wired device in the  'wireless clients' VLAN, can you ping and get to the internet?

Steve

HTH, Steve ------------------------------------------------------------------------------------------------ Please remember to rate useful posts, and mark questions as answered
2357
Views
0
Helpful
7
Replies
CreatePlease login to create content