Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Clarifying the upgrade/migration path to Prime Infrastructure 2.0

Upgrade  note:   If you have an HA setup, it's important to note that HA must be  REMOVED (not just disabled) prior to starting an upgrade.   Administration > High Availability > HA Configuration > Remove  button.

Note - If you installed your current version using a Small OVA, you will need to migrate to a new server, as an upgrade from a Small OVA is not supported for PI 2.0.  See the "Performing an Inline Upgrade" section of the PI 2.0 quick start guide for further details.

Current VersionUpgrade Path
Required Files - in install order
Notes

NCS 1.1.0.58



You must upgrade to a version that is supported to upgrade to Prime Infrastructure 2.0.  There are two options below:





1.1.0.58 => 1.1.1.24 => 2.0.0.0.294

ncs_patch-1.1.0.58-upgrade-12.tar.gz

Patch required to resolve many issues.  Backup and Restore required before proceeding.



NCS-upgrade-bundle-1.1.1.24.tar.gz

Upgrade bundle taking current patched version to NCS 1.1.1.24



ncs_1_1_1_24-Update.13.4.tar.gz

Patch required to upgrade to PI 1.3.0.20.



PI-Upgrade-2.0.0.0.294.tar.gz

Upgrade bundle taking current patched version to PI 2.0.0.0.294






1.1.0.58 => 1.3.0.20 => 2.0.0.0.294

ncs_patch-1.1.0.58-upgrade-12.tar.gz

Patch required to to upgrade to 1.3.0.20.  Backup and Restore required before proceeding.



PI-upgrade-bundle-1.3.0.20.tar.gz

Upgrade bundle taking current patched version to PI 1.3.0.20



PI-Upgrade-2.0.0.0.294.tar.gz

Upgrade bundle taking current patched version to PI 2.0.0.0.294





NCS 1.1.1.24

1.1.1.24 => 2.0.0.0.294

ncs_1_1_1_24-Update.13.4.tar.gz

Patch required to upgrade to PI 2.0.0.294.  Backup and Restore required before proceeding.



PI-Upgrade-2.0.0.0.294.tar.gz

Upgrade bundle taking current patched version to PI 2.0.0.0.294






Migrating to a new PI 2.0 server?

ncs_1_1_1_24-Update.13.4.tar.gz

Patch must be installed AND backup and restore must be done prior to attempting to restore a new backup into a new PI 2.0.0.0.294 server.




NCS 1.1.2.12 (FIPS) - See Service Advisory below

1.1.2.12 => 1.3.0.20 => 2.0.0.0.294

Must take a backup of existing 1.1.2.12 and restore into a patched version of 1.3.0.20 (new server)



NCS-patch-1.3.0.20-CSCue74129.tar.gz

Patch required on top of 1.3.0.20.  Once patch is installed, you can restore the backup from 1.1.2.12



PI-Upgrade-2.0.0.0.294.tar.gz

Upgrade bundle taking current patched version to PI 2.0.0.0.294





NCS 1.1.3.2 (FIPS) - See Service Advisory below

1.1.3.2 => 1.3.0.20 => 2.0.0.0.294

Must take a backup of existing 1.1.3.2 and restore into a patched version of 1.3.0.20 (new server)



NCS-patch-1.3.0.20-CSCue74129.tar.gz

Patch required on top of 1.3.0.20.  Once patch is installed, you can restore the backup from 1.1.3.2



PI-Upgrade-2.0.0.0.294.tar.gz

Upgrade bundle taking current patched version to PI 2.0.0.0.294





PI 1.2.0.103

1.2.0.103 => 1.2.1.12 => 2.0.0.0.294

pi_1.2.1.12_update.tar.gz

Installed on 1.2.0.103, upgrades to 1.2.1.12



PI_1_2_1_12u-Update.1.tar.gz

installed on upgraded server now running 1.2.1.12.  This fixes bug CSCue50717.



PI-Upgrade-2.0.0.0.294.tar.gz

Upgrade bundle taking current patched version to PI 2.0.0.0.294






Migrating to a new PI 2.0 server?

pi_1.2.1.12_update.tar.gz

Installed on 1.2.0.103, upgrades to 1.2.1.12


PI_1_2_1_12u-Update.1.tar.gzAfter this patch is installed, a backup of existing PI 1.2.1.12 server can be restored into a new PI 2.0.0.0.294 server.




PI 1.2.1.12

1.2.1.12 => 2.0.0.0.294

PI_1_2_1_12-Update.1.0.tar.gz 

Patch required to upgrade to PI 1.3.0.20



PI-Upgrade-2.0.0.0.294.tar.gz

Upgrade bundle taking current patched version to PI 2.0.0.0.294






Migrating to a new PI 2.0 server?

PI_1_2_1_12-Update.1.0.tar.gz 

After patch is installed, a backup from existing PI 1.2.1.12 server can be restore into a new  PI 2.0.0.0.294 server.





PI 1.3.0.20

1.3.0.20 => 2.0.0.0.294

PI-Upgrade-2.0.0.0.294.tar.gz

Upgrade bundle taking current patched version to PI 2.0.0.0.294






Migrating to a new PI 2.0 server?

PI_1_3_0_20-Update.1.12.tar.gz

After patch is installed, a backup from existing PI 1.3.0.20 server can be restore into a new  PI 2.0.0.0.294 server.

Upgrade   note:   If you have an HA setup, it's important to note that HA must  be  REMOVED (not just disabled) prior to starting an upgrade.    Administration > High Availability > HA Configuration > Remove   button.

Documentation Links:

PI 2.0 Release notes, covering Upgrading Prime Infrastructure:  http://www.cisco.com/en/US/docs/net_mgmt/prime/infrastructure/2.0/release/notes/cpi_rn.html#wp43830

Official documentation covering Upgrading to Prime Infrastructure 2.0: http://www.cisco.com/en/US/docs/net_mgmt/prime/infrastructure/2.0/quickstart/guide/cpi_qsg.html#wp56675

Service Advisory for NCS 1.1.2.12 and NCS 1.1.3.2:  http://www.cisco.com/en/US/docs/net_mgmt/prime/infrastructure/1.3/software/advisory/Software_Advisory_CPI_1_1_2_and_1_1_3.pdf


Installing the point patch:  http://www.cisco.com/en/US/docs/net_mgmt/prime/infrastructure/2.0/quickstart/guide/cpi_qsg.html#wp70056

Performing Inline Upgrade:  http://www.cisco.com/en/US/docs/net_mgmt/prime/infrastructure/2.0/quickstart/guide/cpi_qsg.html#wp66122

Software Links:

NCS 1.1.0.58 - PI 1.2.1.12 patches: http://tools.cisco.com/squish/53bFA

PI 1.3.0.20 Upgrade Bundle: http://tools.cisco.com/squish/F171c

PI 1.3.0.20 Update 1 patch:  http://tools.cisco.com/squish/ab3d5

PI 2.0.0.0.294 Upgrade Bundle:  http://tools.cisco.com/squish/fBe19

Reviewing the "Tips for upgrading to Prime Infrastructure " support forums document is also extremely helpful.

Comments
Community Member

Do the licences migrate as well?

Cisco Employee

Thank you very much for this guide.

Community Member

Great post, really helpful table.

This information is not easy to put together with so many options and twists and turns in the upgrade process.

Thank you

10015
Views
25
Helpful
3
Comments