cancelar
Mostrando los resultados de 
Buscar en lugar de 
Quiere decir: 
Avisos
¡Bienvenido a la nueva Comunidad de Soporte de Cisco! Nos encantaría conocer su opinión
New Member

Re direccionamiento de llamadas a partir de translation-rule

Hola comunidad de Cisco,

Estoy necesitando crear un translation-rule con un grupo de números y que éstos sean re dirigidos hacia un voicemail.

¿Tienen idea de como hacerlo?

Actualmente estamos bloqueando ese grupo de números, pero en realidad que lo necesario no es bloquear sino redirigir a la contestadora:

voice translation-rule 100

rule 1 reject /0123456489/

Copio aquí la config del Gateway.

User Access Verification

Current configuration : 18120 bytes
!
! Last configuration change at 16:09:34 PYT Mon Nov 7 2016 by softnet
! NVRAM config last updated at 16:30:41 PYT Mon Nov 7 2016 by softnet
! NVRAM config last updated at 16:30:41 PYT Mon Nov 7 2016 by softnet
version 15.1
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname CCMX-TAM
!
boot-start-marker
boot system flash:c3845-spservicesk9-mz.151-4.M10.bin
boot-end-marker
!
!
card type e1 0 1
logging buffered 4096
enable secret 5 $1$nHME$bqqS42YAtNI.5D6mEG/4E1
!
no aaa new-model
clock timezone GMT -5 0
clock summer-time PYT recurring 3 Sun Oct 0:00 4 Sun Mar 0:00
network-clock-participate wic 0
network-clock-participate wic 1
network-clock-select 1 E1 0/0/0
!
dot11 syslog
ip source-route
no ip dhcp use vrf connected
ip dhcp excluded-address 10.13.13.1 10.13.13.49
ip dhcp excluded-address 10.13.17.1 10.13.17.49
ip dhcp excluded-address 10.13.11.1 10.13.11.49
!
ip dhcp pool xxx-VoIP-H1A
 network 10.13.11.0 255.255.255.0
 option 150 ip 10.13.11.10
 default-router 10.13.11.1
 domain-name cl.lan.com
!
ip dhcp pool Xxx-VoIP-H1B
 network 10.13.13.0 255.255.255.0
 option 150 ip 10.13.11.10
 default-router 10.13.13.1
 domain-name cl.lan.com
!
ip dhcp pool xxxxxxxx
 network 10.13.17.0 255.255.255.0
 option 150 ip 10.13.11.10
 default-router 10.13.17.1
 domain-name cl.lan.com
!
!
!
no ip cef
!
!
no ip domain lookup
ip host ipbilling.com.ar 201.212.1.60
ip host tam-py.ipbilling.com.ar 201.212.1.60
ip name-server 10.0.16.10
ip name-server 200.85.32.2
ip name-server 200.85.32.3
no ipv6 cef
multilink bundle-name authenticated
!
!
!
isdn switch-type primary-4ess
!
voice-card 0
 dsp services dspfarm
!
!
voice call send-alert
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 no supplementary-service h450.2
 no supplementary-service h450.3
 sip
  bind control source-interface GigabitEthernet0/0
  bind media source-interface GigabitEthernet0/0
!
voice class codec 1
 codec preference 1 g711ulaw
 codec preference 2 g711alaw
 codec preference 3 g729r8
 codec preference 4 g729br8
!
!
voice iec syslog
!
!
voice translation-rule 1
 rule 1 /\(^104$\)/ /1\1/
!
voice translation-rule 89
 rule 1 /^89/ /9/
!
voice translation-rule 100
 rule 1 reject /0123456789/
 rule 2 reject /0123456789/
!
voice translation-rule 101
!
!
voice translation-profile 555_Bloqueados
 translate calling 100
!

!
http client connection timeout 2
!
application
 service ipbc flash://ipbc.tcl
 !
 service aa flash:app-b-acd-aa-2.1.2.2.tcl
  param number-of-hunt-grps 1
  paramspace english index 1
  param drop-through-option 1
  param handoff-string aa
  paramspace english language en
  param max-time-vm-retry 1
  param aa-pilot 200
  paramspace english location flash:
  param drop-through-prompt LlamadaEspera.au
  param call-retry-timer 30
  param voice-mail 222
  param max-time-call-retry 700
  param service-name csqfideli
 !
 service aa2 flash:app-b-acd-aa-2.1.2.2.tcl
  paramspace english index 1
  param voice-mail 222
  param max-time-call-retry 700
  param aa-pilot 450
  param number-of-hunt-grps 1
  param handoff-string aa2
  paramspace english language en
  param call-retry-timer 30
  param service-name csq
  paramspace english location flash:
  param drop-through-option 2
  param drop-through-prompt LlamadaEspera.au
  param max-time-vm-retry 1
 !
 service aa3 flash:app-b-acd-aa-2.1.2.2.tcl
  param max-time-vm-retry 1
  paramspace english index 1
  param voice-mail 222
  param max-time-call-retry 700
  param aa-pilot 451
  param number-of-hunt-grps 1
  paramspace english language en
  param handoff-string aa3
  param call-retry-timer 30
  paramspace english location flash:
  param service-name csq
  param drop-through-option 3
  param drop-through-prompt LlamadaEspera.au
 !
 service aa5 flash:app-b-acd-aa-2.1.2.2.tcl
  paramspace english index 1
  param max-time-vm-retry 1
  param voice-mail 222
  param max-time-call-retry 700
  param aa-pilot 453
  paramspace english language en
  param number-of-hunt-grps 1
  param handoff-string aa5
  paramspace english location flash:
  param call-retry-timer 30
  param service-name csq
  param drop-through-option 5
  param drop-through-prompt LlamadaEspera.au
 !
 service csq flash:app-b-acd-2.1.2.2.tcl
  param aa-hunt5 603
  param aa-hunt2 607
  param number-of-hunt-grps 3
  param queue-manager-debugs 1
  param aa-hunt3 605
  param queue-len 5
 !
 service ipbc2 flash://ipbc.tcl
 !
 service csqfideli flash:app-b-acd-2.1.2.2.tcl
  param aa-hunt1 601
  param number-of-hunt-grps 1
  param queue-manager-debugs 1
  param queue-len 15
 !
 service aaopera flash:app-b-acd-aa-2.1.2.2.tcl
  paramspace english index 1
  param drop-through-option 1
  param drop-through-prompt LlamadaEspera.au
  param max-time-vm-retry 1
  paramspace english language en
  param voice-mail 222
  param max-time-call-retry 700
  param aa-pilot 455
  param number-of-hunt-grps 1
  param handoff-string aaopera
  paramspace english location flash:
  param call-retry-timer 30
  param service-name csqopera
 !
 service csqopera flash:app-b-acd-2.1.2.2.tcl
  param queue-manager-debugs 1
  param number-of-hunt-grps 1
  param queue-len 5
  param aa-hunt1 609
 !
 monitor
  stats
  event-log
 !
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO3845-MB sn FOC111559PE
archive
 log config
  hidekeys
 path flash:bk-04-10-2016
username cris password 7 104D08140C
!
controller E1 0/0/0
 pri-group timeslots 1-31
!
controller E1 0/0/1
 pri-group timeslots 1-31
!
controller E1 0/1/0
 pri-group timeslots 1-31 service mgcp
!
controller E1 0/1/1
!
ip ftp username tam
ip ftp password 7 0010120B560B5A50
!
class-map match-any VoIP-Control-UnTrust
 match access-group name VoIP-Control
class-map match-any VoIP-RTP-UnTrust
 match protocol rtp audio
 match access-group name VoIP-RTCP
class-map match-any VoIP-Remark
 match ip dscp ef
 match ip dscp cs3
 match ip dscp af31
!
!
policy-map Policy-UnTrust
 class VoIP-RTP-UnTrust
  set cos 5
 class VoIP-Control-UnTrust
  set cos 3
 class VoIP-Remark
  set cos 0
 class class-default
  fair-queue
!
!
!
!
!
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.255
!
interface GigabitEthernet0/0
 ip address 10.13.11.14 255.255.255.0
 duplex auto
 speed auto
 media-type rj45
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.13.11.14
!
interface GigabitEthernet0/1
 description conectado a ROUTERWEBSERVICE
 ip address 192.168.169.2 255.255.255.252
 duplex auto
 speed 100
 media-type rj45
!
interface Serial0/0/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
interface Serial0/0/1:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
interface Serial0/1/0:15
 no ip address
 encapsulation hdlc
 isdn switch-type primary-net5
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 no cdp enable
!
interface Service-Engine1/0
 ip unnumbered GigabitEthernet0/0
 service-module ip address 10.13.11.13 255.255.255.0
 service-module ip default-gateway 10.13.11.14
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
ip http path flash:
ip route 0.0.0.0 0.0.0.0 10.13.11.1 name Default
ip route 10.13.11.13 255.255.255.255 Service-Engine1/0
ip route 201.212.1.60 255.255.255.255 192.168.169.1 name ROUTETOIPBILLING
!
ip access-list extended Tam
 permit ip host 10.144.100.96 any
 permit ip host 10.144.103.156 any
 permit ip 10.144.100.0 0.0.0.255 any
 permit ip 192.168.169.0 0.0.0.3 any
 permit ip 10.13.10.0 0.0.0.255 any
ip access-list extended VoIP-Control
 permit tcp any any eq 1720
 permit tcp any any range 11000 11999
 permit udp any any eq 2427
 permit tcp any any eq 2428
 permit tcp any any range 2000 2002
 permit udp any any eq 1719
 permit udp any any eq 5060
ip access-list extended VoIP-RTCP
 permit udp any any range 16384 32767
!
logging 10.13.11.185
!
snmp-server community public RO
!
tftp-server flash:P00303020214.bin
!
control-plane
!
!
voice-port 0/0/0:15
 cptone AR
 bearer-cap Speech
!
voice-port 0/1/0:15
 echo-cancel coverage 64
 shutdown
!
voice-port 0/0/1:15
 bearer-cap Speech
!
ccm-manager redundant-host 10.13.11.11
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 10.13.11.10
ccm-manager config
!
mgcp
mgcp call-agent 10.13.11.10 2427 service-type mgcp version 0.1
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 ecm
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!
sccp local GigabitEthernet0/0
sccp ccm 10.13.11.11 identifier 1 version 7.0
sccp ccm 10.13.11.10 identifier 2 version 7.0
sccp
!
sccp ccm group 2
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 2 register TRANSCODER1
 switchback method graceful
!
sccp ccm group 1
 associate ccm 1 priority 1
 associate ccm 2 priority 2
 associate profile 1 register CFB_HW
 switchback method graceful
!
dspfarm profile 2 transcode
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 codec g722-64
 maximum sessions 2
 associate application SCCP
!
dspfarm profile 1 conference
 codec g711ulaw
 codec g711alaw
 codec g729ar8
 codec g729abr8
 codec g729r8
 codec g729br8
 maximum sessions 4
 associate application SCCP
!
dial-peer cor custom
 name Servicios
 name Emergencias
!
!
dial-peer cor list INTERNOS
 member Servicios
 member Emergencias
!
!
dial-peer voice 1 voip
 corlist outgoing INTERNOS
 destination-pattern 7...
 session protocol sipv2
 session target ipv4:10.13.11.13
 dtmf-relay sip-notify h245-alphanumeric cisco-rtp sip-kpml rtp-nte h245-signal
 codec g711ulaw
 no vad
!
dial-peer voice 999 voip
 service ipbc
 incoming called-number 9T
 voice-class codec 1
 dtmf-relay h245-alphanumeric
 no vad
!
dial-peer voice 3 voip
 corlist outgoing INTERNOS
 destination-pattern [^9]..
 session target ipv4:10.13.11.10
 voice-class codec 1
 dtmf-relay h245-alphanumeric cisco-rtp rtp-nte h245-signal
 no vad
!
dial-peer voice 10 pots
 corlist incoming INTERNOS
 translation-profile incoming BRASIL
 incoming called-number .
 direct-inward-dial
 port 0/0/0:15
!
dial-peer voice 11 pots
 corlist incoming INTERNOS
 incoming called-number .
 direct-inward-dial
 port 0/0/1:15
!
dial-peer voice 12 pots
 corlist incoming INTERNOS
 destination-pattern 9.T
 port 0/0/0:15
!
dial-peer voice 13 pots
 corlist incoming INTERNOS
 destination-pattern 9.T
 port 0/0/1:15
!
dial-peer voice 14 voip
 session protocol sipv2
 session target ipv4:10.13.11.10
 voice-class codec 1
!
dial-peer voice 89 voip
 translation-profile incoming CALLS-CHILE
 session protocol sipv2
 incoming called-number 89.T
 voice-class codec 1
!
dial-peer voice 4 pots
 corlist incoming INTERNOS
 call-block translation-profile incoming 555_Bloqueados
 call-block disconnect-cause incoming user-busy
 incoming called-number 555
 direct-inward-dial
 port 0/0/0:15
!
dial-peer voice 5 pots
 corlist incoming INTERNOS
 call-block translation-profile incoming 555_Bloqueados
 call-block disconnect-cause incoming user-busy
 incoming called-number 555
 direct-inward-dial
 port 0/1/0:15
!
dial-peer voice 9 pots
 corlist incoming INTERNOS
 shutdown
 incoming called-number .
 direct-inward-dial
 port 0/1/0:15
!
dial-peer voice 2 voip
 corlist incoming INTERNOS
 translation-profile outgoing BRASIL
 shutdown
 destination-pattern 1104
 session target ipv4:10.13.11.10
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 100 voip
 description TEST BRASIL
 shutdown
 destination-pattern 1104
 session target ipv4:10.13.11.10
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 101 pots
 shutdown
 incoming called-number 103
 direct-inward-dial
 port 0/1/0:15
!
!
sip-ua
!
!
alias exec proc show process cpu
alias exec proce show process cpu h
alias exec acce telnet 10.13.11.12
!
line con 0
 logging synchronous
 login local
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 exec-timeout 0 0
 logging synchronous
 login local
 transport input all
line vty 5 15
 exec-timeout 0 0
 no login
 transport input all
line vty 16 769
 no login
 transport input all
!
scheduler allocate 20000 1000
ntp master 3
ntp server 10.13.11.14
end

2 RESPUESTAS
Cisco Employee

Hola!

Hola!

La pregunta quedo posteada en la seccion de wireless/mobility, tal vez quieras mejor ponerla aca:

https://supportforums.cisco.com/es/community/5461/colaboracion-voz-y-video

New Member

Muchas gracias por la

Muchas gracias por la sugerencia Karlcisn

30
Visitas
0
ÚTIL
2
Respuestas