Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

A9K-RSP-4G and A9K-RSP-8G tftp timeout from rommon

We have two A9K-RSP-4G and another pair of A9K-RSP-8G processors. We are unable to boot tftp from rommon to either the 4G or the 8G processors. We have tftp booted RSP-440's many times with the same laptops with no issues.

We have tried:

3 different laptops and different network drivers.

3 different TFTP servers, solarwinds, tftpd32, and tftp64

We have tried different network interface speeds, 10M/half-duplex, 1G auto negotiate, etc.

We are using manufactured CAT6 Ethernet cables and have tried several.

We have tried MGT LAN 0 and 1 on each RSP.

This is an example of the message we receive:

Mgt LAN 0 interface is selected
tsec_init_hw: configuring FE (port 1) for: Auto Speed, Auto Duplex

tsec_init_interface: hardware initialization completed

Receiving asr9k-mini-px.vm-5.1.2 from 24.220.8.110 !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
tftp_service_timeout: ACK RETRY! Block=8506, retry=4.
tftp_service_timeout: ACK RETRY! Block=8506, retry=3.
tftp_service_timeout: ACK RETRY! Block=8506, retry=2.
tftp_service_timeout: ACK RETRY! Block=8506, retry=1. [TIMED OUT]
Aborting due to tftp_service_timeout end
TFTP: Operation terminated.

The transfer may go to 5% or even 85% but will never complete.

Again, works perfectly on RSP440's but will not work on 4G or 8G processors.

We opened a ticket with Cisco TAC and spent 3hrs swapping laptops and changing settings (tftp block size, timeout's, etc.).

Any ideas?

 

Thanks,

Jamie

 

 

4 REPLIES
Cisco Employee

Hi Jamie, Have you tried some

Hi Jamie,

 

Have you tried some of the additional steps in this doc such as disabling the CPU watchdog and changing TFTP values (timeout, retries, etc) https://supportforums.cisco.com/document/123576/asr9000xr-understanding-turboboot-and-initial-system-bring

 

Also email me the SR number and I can take a look at any additional outputs in the case (email is my userid).

 

Thanks,

Sam

New Member

The Cisco TAC engineer did

The Cisco TAC engineer did disable the watchdog. He also tried adjusting the timeout, block size, and negotiation settings. I will email you the TAC case number.

Thank you for taking a look at this.

Jamie

 

 

New Member

We have the same problem.How

We have the same problem.

How did you resolved it?

 

Thanks

Roberto

New Member

We worked with TAC for

We worked with TAC for several days and did not find a resolution. We had plans to replace the 4G and 8G processors with RSP440's and decided to not waste any further time trying to fix this. We moved forward with the 440's instead. Sorry no answer here. Good Luck!

365
Views
0
Helpful
4
Replies
CreatePlease login to create content