Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

ASR 9000 Layer 2 connectivity problem

Hi all,

I have a problem of Layer 2 connectivity which is like this:

I have a 3750 switch, ASR 9010, ASR 1006 that are connected like this:

Switch 3750 --------------------- ASR 9010 ---------------- ASR 1006

The problem is that I cannot ping from Switch 3750 to ASR 1006 .

I am using ASR 9010 like a Layer 2 switch. The configurations are like this:

Switch 3750

interface Tengigabit 0/0/0    /interface connected to ASR 9010/

no switchport

ip address 10.2.1.1  255.255.255.0

ASR 9010

interface Tengigabit 0/0/0/0     /interface connected to Switch 3750/

cdp

interface Tengigabit 0/0/0/0.2 l2transport

encapsulation dot1q 2 exact

rewrite ingress tag pop 1 symmetric

interface Tengigabit 0/0/0/1     /interface connected to ASR 1006/

cdp

interface Tengigabit 0/0/0/1.2 l2transport

encapsulation dot1q 2 exact

rewrite ingress tag pop 1 symmetric

interface BVI2

ipv4 address 10.2.1.254 255.255.255.0

l2vpn

bridge group VL2

  bridge-domain VL2

   interface Tengigabit 0/0/0/0

   interface Tengigabit 0/0/0/1

   routed interface BVI2

ASR 1006

interface Tengigabit 0/1/0     /interface connected to ASR 9010/

ip address 10.2.1.2  255.255.255.0

All the interfaces have been enabled with the command [no shutdown] . Also when I issue the command [show ip interface brief] in Switch 3750 or ASR 1006, I found the interfaces in the up/up state.

Can someone please tell me what I am missing? I want to get this logical topology:

Switch 3750-------------------VLAN 2----------------------ASR 1006

Thank you all.

Mohamed Nidhal Beyrem Jaziri
CCIE Routing & Switching 38232
Tunisia       

Mohamed Nidhal Beyrem Jaziri CCIE Routing & Switching 38232 Tunisia
1 ACCEPTED SOLUTION

Accepted Solutions
New Member

Re: ASR 9000 Layer 2 connectivity problem

From the A9K you are matching on Tag 2 that is not tagged from 1K or switch

Sent from Cisco Technical Support iPad App

8 REPLIES
New Member

Re: ASR 9000 Layer 2 connectivity problem

From the A9K you are matching on Tag 2 that is not tagged from 1K or switch

Sent from Cisco Technical Support iPad App

New Member

ASR 9000 Layer 2 connectivity problem

Thank You Ahmed for your quick reply.

What must I do in Swtch 3750 and ASR 1006 to tag the frames as they go to ASR 9010?

Mohamed Nidhal Beyrem Jaziri
CCIE Routing & Switching 38232
Tunisia

Mohamed Nidhal Beyrem Jaziri CCIE Routing & Switching 38232 Tunisia
New Member

Re: ASR 9000 Layer 2 connectivity problem

There is alots of things to do for this easier and simpler

However for you setup to work you need From 3750 to pass tagged you shall configure int to 9k as trunk
And put the IP address under interface vlan2 also create vlan 2 on switch

You wil have to do same from 1K but with efp and rewrite functions.

I can send you configuration tommorow if you got stucked

Sent from Cisco Technical Support iPad App

New Member

Re: ASR 9000 Layer 2 connectivity problem

Thank you Ahmed,

I agree with you that we can use an easier solution with simply routed ports on Switch 3750, ASR 9010 and ASR 1006, but the goal of the configuration is to use the ASR 9010 as a switch.

Do you think that this configuration will work:

Switch 3750

vlan 2

interface Tengigabit 0/0/0

switchport trunk encapsulation dot1q

switchport mode trunk

interface vlan 2

ip address 10.2.1.1  255.255.255.0

ASR 9010

Same configuration as above

ASR 1006

interface Tengigabit 0/1/0

no ip address

cdp

interface Tengigabit 0/1/0.2 l2transport

encapsulation dot1q 2 exact

rewrite ingress tag pop 1 symmetric

Mohamed Nidhal Beyrem Jaziri
CCIE Routing & Switching 38232
Tunisia

Mohamed Nidhal Beyrem Jaziri CCIE Routing & Switching 38232 Tunisia
New Member

Re: ASR 9000 Layer 2 connectivity problem

For the above you will still have to create bvi on ASR1K and map the subinterface with the bvi on the same bridge domain/group


Thanks Ahmed Moshref
Sent from Cisco Technical Support iPad App

New Member

Re: ASR 9000 Layer 2 connectivity problem

Thanks Ahmed,

We forgot that ASR 1006 runs with IOS-XE and not IOS-XR, therefore we can't use the EFP concept. But what do you think about this configuration:

ASR 1006

interface Tengigabit 0/1/0

no ip address

interface Tengigabit 0/1/0.2

encapsulation dot1Q  2

ip address 10.2.1.2  255.255.255.0

Mohamed Nidhal Beyrem Jaziri
CCIE Routing & Switching 38232
Tunisia

Mohamed Nidhal Beyrem Jaziri CCIE Routing & Switching 38232 Tunisia
New Member

Re: ASR 9000 Layer 2 connectivity problem

Here is the final and functional config, I tested it in this morning and it is working:

Switch 3750

vlan 2

interface vlan 2

ip address 10.2.1.1  255.255.255.0

interface TenGigabitEthernet1/0/1

switchport trunk encapsulation dot1q

switchport mode trunk

ASR 9010

Same configuration as above

ASR 1006

interface Tengigabit 0/1/0

no ip address

interface Tengigabit 0/1/0.2

encapsulation dot1Q  2

ip address 10.2.1.2  255.255.255.0

Thank you all

Mohamed Nidhal Beyrem Jaziri
CCIE Routing & Switching 38232
Tunisia

Mohamed Nidhal Beyrem Jaziri CCIE Routing & Switching 38232 Tunisia
New Member

Re: ASR 9000 Layer 2 connectivity problem

Good that you get it done! :)

Sent from Cisco Technical Support iPad App

576
Views
10
Helpful
8
Replies
CreatePlease login to create content