Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ASR 9010 switchport mode dot1q-tunnel QinQ Access

Is there an IOS-XR ASR equivalent for a QinQ edge access port? On IOS the interface config would be:

int fa 1/1
switchport
switchport mode dot1q-tunnel
switchport access vlan 100

10 REPLIES

In IOS-XR (ASR) you have no

In IOS-XR (ASR) you have no layer 2 vlan separation like on IOS.

Every interface can tag/untag on any vlan number and they wont see each other unless they are put together by a bridge-group.

Are you trying to do a L2 pseudowire? a VFI or xconnect will do this for you passing all the client´s vlans without a "dot1q-tunnel".

EFP (Tagging) on XR:
https://supportforums.cisco.com/document/59741/asr9000xr-flexible-vlan-matching-evc-vlan-tag-rewriting-irbbvi-and-defining-l2

Layer2 VPN (point to point PW):
http://www.cisco.com/c/en/us/support/docs/routers/asr-9000-series-aggregation-services-routers/116453-technote-ios-xr-l2vpn-00.html

New Member

I am trying to configure a

I am trying to configure a pseudowire connection to where the customer facing port can send either tagged or untagged frames. Also same scenario for VPLS facing port. MY issue that I ran into was matching any type of encapsulation and then pushing a tag. I couldn't get this to work.

Do you have ASR on both sides

Do you have ASR on both sides? If you do, VFI will work for you, lets say:

CE------G1/1/1/1(1.1.1.1- PE1)---------------------(PE - 2.2.2.2) G2/2/2/2--------- CE

 

On PE1:

interface g1/1/1/1

l2transport

no shut

 

l2vpn

bridge group PE1

bridge-domain CE1

interface g1/1/1/1

vfi CE1

neighbor 2.2.2.2 pw-id 100

 

On PE2:

interface g2/2/2/2

l2transport

no shut

 

l2vpn

bridge group PE2

bridge-domain CE2

interface g2/2/2/2

vfi CE2

neighbor 1.1.1.1 pw-id 100

 

New Member

If you do not put an

If you do not put an encapsulation on the port, does it explicitly pass all traffic? Also, I need to hand the xconnect off on the far side to a trunk port which means I need to distinguish the connection with a provider tag. How would I do this? I was thinking of doing an ingress push rewrite operation.

Yes, if you just put a

Yes, if you just put a physical interface in l2transport it takes all the incoming traffic and sends it to the bridge-domain (just like an access port on ios)

 

If you need to hand off and receive on the other side with encapsulation, you just receive the packets with dot1q vlan and strip the vlan off on outgoing:

Ej:

interface TenGigE0/4/0/0.500 l2transport

 encapsulation dot1q 500
 rewrite ingress tag pop 1 symmetric

 

That configuration receives packets tagged with vlan 500 and pops it before sending them to the bridge domain.

When sending packets out, it places the tag again.

We (ISP) use this with corporative clients, using different vlans on each side or access on one side/trunk on the other.

Try this and see if this works for your scenario

Regards,

New Member

We need to be able to accept

We need to be able to accept ANY type of l2 traffic from the customer on receiving end and then push a tag on it regardless of its original VLAN tag or even if it's untagged. We can't bind the ingress port to match a specific encapsulation.

On PE1 you are receiving all

On PE1 you are receiving all the traffic and sending it to PE2

On PE2 you are taking all this traffic and pushing a vlan on it (put the encapsulation and the rewrite only on PE2 interface)

You need to to the same backwards? Receive all traffic on PE2 and push a vlan on PE1?
 

New Member

We need to receive all

We need to receive all traffic on PE1 (tagged or untagged), transport via xconnect over MPLS core to PE2 and hand off with a known specific provider tag (S-TAG).

So my question is how do I receive any traffic on PE1 and hand out a specific tag on PE2?

PE1 (1.1.1.1):g0/0/0

PE1 (1.1.1.1):
g0/0/0/0
description Interface CE1 (All traffic)
l2transport

l2vpn

bridge group PE1
bridge-domain PE1-2
interface g0/0/0/0
vfi PE1-2
neighbor 2.2.2.2 pw-id 100

PE2(2.2.2.2):

g0/0/0/2.200 l2transport
description Interface CE2 (Tagged)
encapsulation dot1q 200
rewrite ingress tag pop 1 symm

l2vpn

bridge group PE2
bridge-domain PE2-1
interface g0/0/0/2
vfi PE2-1
neighbor 1.1.1.1 pw-id 100

That configuration does the following:
Receive ALL traffic from CE1, sends it trough VFI to PE2, and delivers it to CE2 tagged with vlan 200

Receive traffic tagged with 200 from CE2, pop tag, sends it trough VFI to PE1, and delivers all to CE1

New Member

eduardopozo56:What would you

eduardopozo56:

What would you do if you wanted to preserve VLAN tags from EACH CE as they traverse the xconnect? I.E. a "pseudowire of a 802.1q trunk" ?

788
Views
5
Helpful
10
Replies