Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

BFD issue between ASR9K-BE and ASR903-PO

Hi,

I have the topology where ASR9K bundle interface is connected with ASR900 port-channel interface and use BFD signal but the port never come up, below is the detail.

 

ASR9K            => IOS-XR 4.3.2, linecard: A9K-MOD80-TR, A9K-MPA-4x10GE

ASR903          => IOS-XE  3.10, linecard:  A900-IMA1X

 

ASR9K Configuration

=========================================================

interface TenGigE0/0/1/2

bundle id 11 mode active

carrier-delay up 0 down 0

load-interval 30

!

interface Bundle-Ether11

bfd address-family ipv4 multiplier 3

bfd address-family ipv4 destination 172.16.11.2

bfd address-family ipv4 fast-detect

bfd address-family ipv4 minimum-interval 15

mtu 9211

ipv4 address 172.16.11.1 255.255.255.252

load-interval 30

!

router isis NKT0020

interface Bundle-Ether11

  circuit-type level-2-only

  bfd minimum-interval 15

  bfd multiplier 3

  bfd fast-detect ipv4

  point-to-point

  hello-password hmac-md5 encrypted 0525261B601C401E480112

  link-down fast-detect

  address-family ipv4 unicast

   metric 10

   mpls ldp sync

  !

!

=========================================================

 

ASR903 Configuration

=========================================================

interface TenGigabitEthernet0/0/0

mtu 9194

no ip address

carrier-delay up 5

carrier-delay down msec 0

cha!nnel-group 11 mode active

end

!

interface Port-channel11

mtu 9194

ip address 172.16.11.2 255.255.255.252

ip router isis NKT0020

load-interval 30

carrier-delay up msec 50

carrier-delay down msec 0

mpls ip

mpls ldp igp sync delay 10

mpls traffic-eng tunnels

mpls traffic-eng backup-path Tunnel62011

bfd interval 15 min_rx 15 multiplier 3

no bfd echo

isis circuit-type level-2-only

isis network point-to-point

 isis metric 10

isis authentication mode md5

isis authentication key-chain ISIS

ip rsvp bandwidth

ip rsvp signalling hello bfd

end

!

router isis NKT0020

bfd all-interfaces

!

=========================================================

 

ASR9K BFD status

=========================================================

RP/0/RSP0/CPU0:pn1#show bfd session detail destination 172.16.11.2

Fri Mar 28 12:12:03.656 BKK

I/f: TenGigE0/0/1/2, Location: 0/0/CPU0

Dest: 172.16.11.2

Src: 172.16.11.1

State: DOWN for 0d:0h:8m:48s, number of times UP: 0

Session type: PR/V4/SH/BM

Received parameters:

Version: 0, desired tx interval: 0 us, required rx interval: 0 us

Required echo rx interval: 0 us, multiplier: 0, diag: None

My discr: 0, your discr: 0, H/D/F/P/C/A: 0/0/0/0/0/0

Transmitted parameters:

Version: 1, desired tx interval: 12 s, required rx interval: 12 s

Required echo rx interval: 0 us, multiplier: 3, diag: None

My discr: 2147549186, your discr: 0, state DOWN, D/F/P/C/A: 0/0/0/1/0

Timer Values:

Local negotiated async tx interval: 2 s

Remote negotiated async tx interval: 12 s

Desired echo tx interval: 0 s, local negotiated echo tx interval: 0 s

Echo detection time: 0 s, async detection time: 0 s

Local Stats:

Intervals between async packets:

   Tx: Number of intervals=100, min=1670 ms, max=2001 ms, avg=1841 ms

       Last packet transmitted 458 ms ago

   Rx: Number of intervals=0, min=0 s, max=0 s, avg=0 s

       Last packet received 0 s ago

Intervals between echo packets:

   Tx: Number of intervals=0, min=0 s, max=0 s, avg=0 s

       Last packet transmitted 0 s ago

   Rx: Number of intervals=0, min=0 s, max=0 s, avg=0 s

       Last packet received 0 s ago

Latency of echo packets (time between tx and rx):

   Number of packets: 0, min=0 us, max=0 us, avg=0 us

Session owner information:

                            Desired               Adjusted

  Client               Interval   Multiplier Interval   Multiplier

  -------------------- --------------------- ---------------------

  bundlemgr_distrib    15 ms      3          12 s       3        

Session association information:

  Interface            Dest Addr / Type                   

  -------------------- -----------------------------------

  BE11                 172.16.11.2                            

                       BFD_SESSION_SUBTYPE_RTR_BUNDLE_INTERFACE

 

I/f: Bundle-Ether11, Location: 0/RSP0/CPU0

Dest: 172.16.11.2

Src: 172.16.11.1

State: DOWN for 0d:1h:6m:20s, number of times UP: 0

Session type: PR/V4/SH/BI

Session owner information:

                            Desired               Adjusted

  Client               Interval   Multiplier Interval   Multiplier

  -------------------- --------------------- ---------------------

  bundlemgr_distrib    15 ms      3          15 ms      3        

Session association information:

  Interface            Dest Addr / Type                  

  -------------------- -----------------------------------

  Te0/0/1/2            172.16.11.2                            

                       BFD_SESSION_SUBTYPE_RTR_BUNDLE_MEMBER

=========================================================

 

ASR900 BFD status

=========================================================

DN1#show bfd neighbors ipv4 172.16.11.1 details

 

IPv4 Sessions

NeighAddr                              LD/RD         RH/RS     State     Int

172.16.11.1                             1/0          Down      Down      Po11

Session Host: Hardware

OurAddr: 172.16.11.2   

Handle: 1

Local Diag: 1, Demand mode: 0, Poll bit: 0

MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3

Received MinRxInt: 12000000, Received Multiplier: 3

Holddown (hits): 0(0), Hello (hits): 12000(0)

Rx Count: 0

Tx Count: 93

Elapsed time watermarks: 0 0 (last: 0)

Registered protocols: TE/FRR CEF

Downtime: 00:00:01

Last packet: Version: 1                  - Diagnostic: 0

             State bit: Down             - Demand bit: 0

             Poll bit: 0                 - Final bit: 0

             C bit: 1                                  

             Multiplier: 3               - Length: 24

             My Discr.: 2147549186       - Your Discr.: 0

             Min tx interval: 12000000   - Min rx interval: 12000000

             Min Echo interval: 0      

DN1#

=========================================================

 

Please help figure it out how to make this works.

Regard,

Marit

251
Views
0
Helpful
0
Replies
CreatePlease login to create content