Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

CRS-1 Turboboot error

Hello,

 

I am trying to TURBOBOOT from a usb on the CRS16 PRP cards but have been unsuccessful.  I have read all the installation guides and follow it verbatim and still come up short. ALl the pre requirements for the upgrade have been met.  My ROMMMON is 2.06 and my ios-XR is 4.0.3.  I am upgrading the XR to 4.2.4.  I can upgrade using TFTP just fine. Same commands and file with TFTP.  With the usb drive method, it will not come up. i have tried TURBOBOOT with and without (format) and still get the same results.

Here are some logs to see if you can help me....

 

 

rommon 14 > dir disk2:
disk2:\Directory of: disk2:\

  04/07/14  06:24p04/07/14  06:24p            6,982,634  hfr-px-4.2.4.CSCtg68851.pie
  04/04/14  01:03p04/04/14  01:03p              998,299  hfr-px-4.2.4.CSCts44399.pie
  04/04/14  01:03p04/04/14  01:03p           95,642,401  hfr-px-4.2.4.CSCub59736.pie
  08/02/13  04:39p08/02/13  04:39p              651,602  hfr-px-4.2.4.CSCub85590.pie
  07/16/13  04:39p07/16/13  04:39p              582,383  hfr-px-4.2.4.CSCuc24002.pie
  04/04/14  01:05p04/04/14  01:05p           84,539,661  hfr-px-4.2.4.CSCuc47809.pie
  02/21/13  12:45p02/21/13  12:45p            2,238,105  hfr-px-4.2.4.CSCuc56287.pie
  04/04/14  01:06p04/04/14  01:06p              355,218  hfr-px-4.2.4.CSCud75358.pie
  05/06/13  12:18p05/06/13  12:18p            2,153,692  hfr-px-4.2.4.CSCud79136.pie
  03/29/13  04:53p03/29/13  04:53p            6,750,017  hfr-px-4.2.4.CSCue21974.pie
  08/02/13  04:46p08/02/13  04:46p            1,988,716  hfr-px-4.2.4.CSCuf51534.pie
  04/04/14  01:06p04/04/14  01:06p            6,751,150  hfr-px-4.2.4.CSCuh98262.pie
  04/04/14  01:06p04/04/14  01:06p              291,410  hfr-px-4.2.4.CSCui60347.pie
  04/04/14  01:06p04/04/14  01:06p               20,750  hfr-px-4.2.4.CSCui60438.pie
  04/04/14  01:06p04/04/14  01:06p              179,317  hfr-px-4.2.4.CSCul08827.pie
  04/07/14  06:27p04/07/14  06:27p           83,058,624  hfr-px-4.2.4.CSCum36930.pie
  04/07/14  06:24p04/07/14  06:24p              440,392  hfr-px-4.2.4.CSCum61677.pie
  04/07/14  06:24p04/07/14  06:24p            6,752,529  hfr-px-4.2.4.CSCun54759.pie
  04/06/14  05:40a04/06/14  05:40a <DIR>          4,096  LOST.DIR
  11/21/12  02:37p11/21/12  02:37p                  147  admin-config-pre-stage.txt
  11/21/12  02:37p11/21/12  02:37p                  441  global-config-pre-stage.txt
  12/14/12  07:40a12/14/12  07:40a          144,556,493  hfr-diags-px.pie-4.2.4
  12/14/12  07:41a12/14/12  07:41a            4,625,865  hfr-doc-px.pie-4.2.4
  12/14/12  07:41a12/14/12  07:41a           40,411,687  hfr-fpd-px.pie-4.2.4
  12/14/12  07:40a12/14/12  07:40a            5,124,807  hfr-k9sec-px.pie-4.2.4
  12/14/12  07:41a12/14/12  07:41a           13,360,601  hfr-mcast-px.pie-4.2.4
  12/14/12  07:40a12/14/12  07:40a            3,286,003  hfr-mgbl-px.pie-4.2.4
  12/14/12  07:41a12/14/12  07:41a          273,798,794  hfr-mini-px.pie-4.2.4
  12/14/12  07:41a12/14/12  07:41a          355,548,629  hfr-mini-px.vm-4.2.4
  12/14/12  07:41a12/14/12  07:41a           10,079,580  hfr-mpls-px.pie-4.2.4
         29 File(s) 1,151,169,947 bytes
          1 Dir(s)

rommon 15 > set
PS1=rommon ! >
ACTIVE_FCD=1
IOX_ADMIN_CONFIG_FILE=
BSI=0
BOOT_DEV_SEQ_CONF=
BOOT_DEV_SEQ_OPER=
TURBOBOOT=on,disk0,format
?=0


rommon 16 > boot disk2:hfr-mini-px.vm-4.2.4
mcp_boot: booting disk2:hfr-mini-px.vm-4.2.4.
mbi_file_exist: file found.
mcp_boot: file read into bigbuf. launching image.

get_elf_magic read =0xaa55aa55   0x0
 –|X: default
loadprog: bad file magic number:      0x0
mcp_boot: error reading image file.

 

TIA

Everyone's tags (2)
2 REPLIES
Cisco Employee

Hello, When using a USB drive

Hello,

 

When using a USB drive for turboboot a different 'boot' command is needed.

Instead use 'mediaboot'.

https://supportforums.cisco.com/document/123576/asr9000xr-understanding-turboboot-and-initial-system-bring#USB

 

Thanks,

Sam

Cisco Employee

Hi Sam, Jimmy,I don't think

Hi Sam, Jimmy,

I don't think that's mediaboot works for CRS (at least it was not the case in the past).

I personally performed the exact same operation than Jimmy in the past, successfully.

May be you should try with the latest rommon (I see that 2.07 is listed in the chart as the one for 4.2.4, you should go to 2.08 directly). Also you should give a try at a different USB stick. Finally, you should check the MD5 and file integrity too.

Cheers,

N.

218
Views
0
Helpful
2
Replies
CreatePlease login to create content