cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2140
Views
0
Helpful
4
Replies

Different physical interfaces with same Vlan ID

P. Muilman
Level 1
Level 1

Hello,

Can we configure the same vlan id on two different physical interfaces on a ASR9010?

I found this in the documentation page 1022:
http://www.cisco.com/en/US/docs/routers/crs/software/crs_r4.3/interfaces/command/reference/b_interfaces_cr43xcrs.pdf
"All VLAN IDs must be unique among all subinterfaces configured on the same physical interface"

Is this possible on a ASR9010?

interface GigabitEthernet6/20.2
description connection vlan 2 interface A 
encapsulation dot1Q 2 
vrf forwarding customer A 
ip address 10.10.10.10 255.255.255.0

interface GigabitEthernet6/10.2
description connection vlan 2 interface B 
encapsulation dot1Q 2 
vrf forwarding customer B 
ip address 11.11.11.11 255.255.255.0

2 Accepted Solutions

Accepted Solutions

Nicolas Fevrier
Cisco Employee
Cisco Employee

Hello,

yes you can

VLAN IDs are only locally significant in your L3 interfaces, so no problem.

Cheers,

N.

View solution in original post

Hi Peter,

I'm not sur the particular case of re-using the same vlan ID on different L3 interfaces is particularly documented, but if I start a config on a real router based on your example:

RP/0/RP1/CPU0:A#conf

Wed Jul  3 17:24:22.643 PDT

RP/0/RP1/CPU0:A(config)#vrf custA

RP/0/RP1/CPU0:A(config-vrf)#address-family ipv4 unicast

RP/0/RP1/CPU0:A(config-vrf-af)#exit

RP/0/RP1/CPU0:A(config-vrf)#exit

RP/0/RP1/CPU0:A(config)#vrf custB                  

RP/0/RP1/CPU0:A(config-vrf)#address-family ipv4 unicast

RP/0/RP1/CPU0:A(config-vrf-af)#exit

RP/0/RP1/CPU0:A(config-vrf)#exit

RP/0/RP1/CPU0:A(config)#int GigabitEthernet0/4/3/3.2

RP/0/RP1/CPU0:A(config-subif)#dot1q vlan 2

RP/0/RP1/CPU0:A(config-subif)#vrf custA

RP/0/RP1/CPU0:A(config-subif)#ipv4 address 4.5.6.7/30

RP/0/RP1/CPU0:A(config)# exit

RP/0/RP1/CPU0:A(config)# int GigabitEthernet0/4/3/2.2 

RP/0/RP1/CPU0:A(config-subif)#dot1q vlan 2  

RP/0/RP1/CPU0:A(config-subif)#vrf custB                     

RP/0/RP1/CPU0:A(config-subif)#ipv4 address 5.6.7.1/30       

RP/0/RP1/CPU0:A(config-subif)#exit

RP/0/RP1/CPU0:A(config)#show

Wed Jul  3 17:29:00.889 PDT

Building configuration...

!! IOS XR Configuration 4.3.1.23I

vrf custA

address-family ipv4 unicast

!

!

vrf custB

address-family ipv4 unicast

!

!

interface GigabitEthernet0/4/3/2.2

vrf custB

ipv4 address 5.6.7.1 255.255.255.252

dot1q vlan 2

!

interface GigabitEthernet0/4/3/3.3

vrf custB

ipv4 address 5.6.7.1 255.255.255.252

dot1q vlan 2

!

end

RP/0/RP1/CPU0:A(config)#commit

Wed Jul  3 17:29:03.906 PDT

RP/0/RP1/CPU0:A(config)#show run int GigabitEthernet0/4/3/2.2

Wed Jul  3 17:29:33.799 PDT

interface GigabitEthernet0/4/3/2.2

vrf custB

ipv4 address 5.6.7.1 255.255.255.252

dot1q vlan 2

!

RP/0/RP1/CPU0:A(config)#sh run int GigabitEthernet0/4/3/3.3

Wed Jul  3 17:29:36.795 PDT

interface GigabitEthernet0/4/3/3.3

vrf custB

ipv4 address 5.6.7.1 255.255.255.252

dot1q vlan 2

!

RP/0/RP1/CPU0:A(config)#

Hope it helps,

Cheers,

N.

View solution in original post

4 Replies 4

Nicolas Fevrier
Cisco Employee
Cisco Employee

Hello,

yes you can

VLAN IDs are only locally significant in your L3 interfaces, so no problem.

Cheers,

N.

Hello Nicolas,

This is great.

Do you have an example or documentation link?

Maybe a piece of configuration where you configured this.

Thanks in advance.

Greetings, Peter

Hi Peter,

I'm not sur the particular case of re-using the same vlan ID on different L3 interfaces is particularly documented, but if I start a config on a real router based on your example:

RP/0/RP1/CPU0:A#conf

Wed Jul  3 17:24:22.643 PDT

RP/0/RP1/CPU0:A(config)#vrf custA

RP/0/RP1/CPU0:A(config-vrf)#address-family ipv4 unicast

RP/0/RP1/CPU0:A(config-vrf-af)#exit

RP/0/RP1/CPU0:A(config-vrf)#exit

RP/0/RP1/CPU0:A(config)#vrf custB                  

RP/0/RP1/CPU0:A(config-vrf)#address-family ipv4 unicast

RP/0/RP1/CPU0:A(config-vrf-af)#exit

RP/0/RP1/CPU0:A(config-vrf)#exit

RP/0/RP1/CPU0:A(config)#int GigabitEthernet0/4/3/3.2

RP/0/RP1/CPU0:A(config-subif)#dot1q vlan 2

RP/0/RP1/CPU0:A(config-subif)#vrf custA

RP/0/RP1/CPU0:A(config-subif)#ipv4 address 4.5.6.7/30

RP/0/RP1/CPU0:A(config)# exit

RP/0/RP1/CPU0:A(config)# int GigabitEthernet0/4/3/2.2 

RP/0/RP1/CPU0:A(config-subif)#dot1q vlan 2  

RP/0/RP1/CPU0:A(config-subif)#vrf custB                     

RP/0/RP1/CPU0:A(config-subif)#ipv4 address 5.6.7.1/30       

RP/0/RP1/CPU0:A(config-subif)#exit

RP/0/RP1/CPU0:A(config)#show

Wed Jul  3 17:29:00.889 PDT

Building configuration...

!! IOS XR Configuration 4.3.1.23I

vrf custA

address-family ipv4 unicast

!

!

vrf custB

address-family ipv4 unicast

!

!

interface GigabitEthernet0/4/3/2.2

vrf custB

ipv4 address 5.6.7.1 255.255.255.252

dot1q vlan 2

!

interface GigabitEthernet0/4/3/3.3

vrf custB

ipv4 address 5.6.7.1 255.255.255.252

dot1q vlan 2

!

end

RP/0/RP1/CPU0:A(config)#commit

Wed Jul  3 17:29:03.906 PDT

RP/0/RP1/CPU0:A(config)#show run int GigabitEthernet0/4/3/2.2

Wed Jul  3 17:29:33.799 PDT

interface GigabitEthernet0/4/3/2.2

vrf custB

ipv4 address 5.6.7.1 255.255.255.252

dot1q vlan 2

!

RP/0/RP1/CPU0:A(config)#sh run int GigabitEthernet0/4/3/3.3

Wed Jul  3 17:29:36.795 PDT

interface GigabitEthernet0/4/3/3.3

vrf custB

ipv4 address 5.6.7.1 255.255.255.252

dot1q vlan 2

!

RP/0/RP1/CPU0:A(config)#

Hope it helps,

Cheers,

N.

P. Muilman
Level 1
Level 1

Hello Nicolas,

This is exactly what I needed. Thank you.

The last answer you configured only gig0/4/3/2.2 and gig0/4/3/3.3 the same. And the last show command you probably wanted: show run int GigabitEthernet0/4/3/3.2 to show customer A, as you configured in the above text.

Doesn't matter.

Your answer is clear and you were a great help.

Regards, Peter