Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

HSBI disappeared after upgrade to 4.3.2

Hi all,

I did an upgrade from 4.1 to 4.3.2. After a FPD update I see the following log message:

RP/0/RSP0/CPU0:Sep 11 10:12:26.952 : hsbi_fpd_agent[245]: %PLATFORM-UPGRADE_FPD-4-WARNING : A Warning message while doing fpd_upgrade: Could not get channel name for fpd_lc_hsbi_0x00100302: No such file or directory

This message appears at system startup.

In a lab test I moved the Standby Sub with 4.3.2 into another Chassis (ASR 9010) with 4.2.0 to test the downgrade to simulate a RMA. The downgrade of the Sub worked as expected. But in I found something interesting about this HSBI issue.

The output of "show hw-module fpd location all" shows a HSBI device on the A9K-RSP-4G secondlast line ...

...

----------------------------------------------------------------------------------------------------------

0/RSP1/CPU0  A9K-RSP-4G                 1.0   lc   fpga3   0       1.23     No

                                              lc   fpga1   0       1.05     No

                                              lc   fpga2   0       1.15     No

                                              lc   cbc     0       1.03     No

                                              lc   fpga4   0       3.08     No

                                              lc   hsbi    0       4.00     No

                                              lc   rommon  0       1.06     No

----------------------------------------------------------------------------------------------------------

With 4.3.2 this device disappears..."show hw-module fpd location all"

....

--------------------------------------------------------------------------------

0/RSP1/CPU0  A9K-RSP-4G                 1.0   lc   fpga3   0       1.23     No

                                              lc   fpga1   0       1.05     No

                                              lc   fpga2   0       1.15     No

                                              lc   cbc     0       1.03     No

                                              lc   fpga4   0       3.08     No

                                              lc   rommon  0       1.06     No

--------------------------------------------------------------------------------

Has anyone an idea what happend here and why it disappeared?

Best regards,

Benjamin


Everyone's tags (3)
1 REPLY
Cisco Employee

HSBI disappeared after upgrade to 4.3.2

HSBI is the high speed boot image, it is like a bootloader that the 7200 used to have to initialize some basic things before the main IOS could be loaded.

the hsbi has been useless on RSP2, stripped on the RSP440, but I am getting it back on the next gen RSP5 which will contain a base MBI (minimum boot image) allowing you to boot the RSP into XR and have some access to RP interfaces to do upgrades etc (to make the turboboot a bit easier).

So whatever you see here is fine. HSBI is not a used things as much...

regards

xander

Xander Thuijs CCIE #6775 Principal Engineer ASR9000, CRS, NCS6000 & IOS-XR
256
Views
0
Helpful
1
Replies
CreatePlease login to create content