Cisco Support Community

IOS upgrade to 4.3.2 on ASR9k routers

Earlier this year I implemented a new SP network with 25 ASR 9k routers, a mix of 9001 and 9006. I created a tar file with the required packages, based on 4.3.0, and I used this same tar file to upgarade all the routers, without any problems.

Now, I'm upgrading from 4.3.0 to 4.3.2 using same process.

The 4.3.2.tar file I created worked on the first router, an ASR9001, worked on the second, an ASR9006 then it failed on the third, another ASR9006.

I've tried the 3rd router several times, I get an error message during the admin install add process, fails to unpack the mini and mpls pie files. The rest unpack ok.

I've checked the file size and MD5 signature of the tar file, its the same on all routers and the original PC, so I don't suspect file corruption.

I do have a TAC case open for this, but we are not making much progress, has anyone else seen this or have a sugestion I could try to debug this?



IOS upgrade to 4.3.2 on ASR9k routers

Its fixed, TAC suggested that I untar the package with the command run tar xvf /harddisk:/4.3.2.tar which put the files into disk0a/usr.

I found that I was unable to do the install add from that location, so copied the .pie files I needed to harddisk: and ran the install add from there.

CreatePlease to create content