Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

IOS XR failed to boot

Hi,

I have CRS1 two RPs installed, for now RP0 failed to boot and standby RP1 is running as active RP, when i console to RP0  i got the message:

System Bootstrap, Version 1.54(20091016:214209) [CRS-1 ROMMON],

Copyright (c) 1994-2009 by Cisco Systems, Inc.

Acquiring backplane mastership ........failed

Board type is 0x100002 (1048578)

Any help please

Everyone's tags (4)
1 ACCEPTED SOLUTION

Accepted Solutions
Cisco Employee

IOS XR failed to boot

Hi,

This looks to be a bootflash issue. This typically is seen when upgrading the router.

The fix is fairly simple, disabled the watchdog in order to boot and format RP1's bootflash. Typically we will see another line after the last one starting with G4, but that is not always the case.

Workaround:   For each RP affected by this problem:

- Connect to RP console.

- Enter rommon by hitting Ctrl+c until you get the rommon prompt.

- Enter these commands to disable the watchdog timeout and reboot:  WATCHDOG_MODE=1 sync  reset

- When the RP is running IOS XR, format the bootflash:  format bootflash:

- Reload the RP:  reload

- Hit Ctrl+c until you get the rommon prompt.  unset WATCHDOG_MODE sync reset

- Router should come back up in IOS XR. If not, contact the Cisco TAC.

Thanks,

Sam

4 REPLIES
Cisco Employee

IOS XR failed to boot

Hi,

That is expected since the active RP is already dSC.

What code are you running?

Did the card ever work?

Did this happen after a reload of the router, card randomly reloaded, etc?

Can you provide a full reboot cycle of the RP?

Thanks,

Sam

New Member

IOS XR failed to boot

Hi Samuel,

Thank you for your reply, the card is already running as Active RP0

what i have done today,  i changed between the RP0 "failed one" with RP1 in the slot modules.

for now the RP0 is working fine but i got ROM MON on screen on the RP1.

when i reloaded the whole router still the failed RP send the output as listed below:

Initializing DDR SDRAM...found 4096 MB

Initializing ECC on bank 0

Initializing ECC on bank 1

Initializing ECC on bank 2

Initializing ECC on bank 3

Turning off data cache, using DDR for first time

Initializing NVRAM...

Testing a portion of DDR SDRAM ...done

Reading ID EEPROMs ...

Initializing SQUID ...

Initializing PCI ...

PCI0 device[1]: Vendor ID 0x10ee

PCI0 device[1]: Device ID 0x300e

PCI1 device[1]: Device ID 0x1100

PCI1 device[1]: Vendor ID 0x1013

PCI1 device[2]: Device ID 0x680

PCI1 device[2]: Vendor ID 0x1095

PCI1 device[3]: Device ID 0x5618

PCI1 device[3]: Vendor ID 0x14e4

Configuring MPPs ...

Configuring PCMCIA slots ...

System Bootstrap, Version 1.54(20091016:214209) [CRS-1 ROMMON],

Copyright (c) 1994-2009 by Cisco Systems, Inc.

Acquiring backplane mastership ........failed

Board type is 0x100002 (1048578)

Switch 0 initialized

Backplane FE port Up... Enabling

Enabling watchdog

G4(7457-NonSMP-MV64360 Rev 4) platform with 4096 MB of main memory

Cisco Employee

IOS XR failed to boot

Hi,

This looks to be a bootflash issue. This typically is seen when upgrading the router.

The fix is fairly simple, disabled the watchdog in order to boot and format RP1's bootflash. Typically we will see another line after the last one starting with G4, but that is not always the case.

Workaround:   For each RP affected by this problem:

- Connect to RP console.

- Enter rommon by hitting Ctrl+c until you get the rommon prompt.

- Enter these commands to disable the watchdog timeout and reboot:  WATCHDOG_MODE=1 sync  reset

- When the RP is running IOS XR, format the bootflash:  format bootflash:

- Reload the RP:  reload

- Hit Ctrl+c until you get the rommon prompt.  unset WATCHDOG_MODE sync reset

- Router should come back up in IOS XR. If not, contact the Cisco TAC.

Thanks,

Sam

New Member

IOS XR failed to boot

Thank you Samuel, problem solved,

1442
Views
0
Helpful
4
Replies
CreatePlease login to create content