Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

IOS-XRv 5.2 name pipe issues

Hello,

 

I´m running a IOS-XRv 5.2 on vmware workstation 10 and I getting issues when trying to access console port.

I set up serial port as named pipe ( \\.\pipe\com_1), and i use named pipe TCP proxy v1.0 and mapped to TCP port 2000.
 I could access console, telnet 127.0.0.1 tcp 2000.

I guess I getting a kind of "speed problem" on console port, everytime I press return key ("ENTER"), console port undestand this key twice. This is causing issues to access router because I typed username and press "ENTER" and router understands "enter" twice and I got invalid credentials. I dont have oportunity to type password. See below.

Username: Eder
Password:
RP/0/0/CPU0:Oct 16 15:24:04.692 : exec[65653]: %SECURITY-login-4-AUTHEN_FAILED : Failed authentication attempt by user 'Eder' from 'console' on 'con0_0_CPU0'

User Access Verification

Username:

 

Trying to overcome this behavior I worte my credential into notepad and copy/paste it to console, like a script. If I paste separately username then I paste password, it works.

User Access Verification

Username: Eder
Password:


RP/0/0/CPU0:ios#
RP/0/0/CPU0:ios#

 

Anyone else see this behavior ?

I´ve tested it into two different machines(lapto/Win7 and desktop/win8). I´ve already changed vmware workstation version. I´ve already changed telnet client (putty/hyperterminal) and same problem.

 

Thanks

 

 

4 REPLIES
Cisco Employee

I tried this below option and

I tried this below option and it still did not work.

 

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=196

 

To reduce these effects, increase the time threshold necessary for auto-repeat in the remote console.

  1. Power off the virtual machine.
  2. Add a line, similar to this, at the end of your virtual machine's configuration (.vmx) file:

    keyboard.typematicMinDelay = "2000000"

    The delay is specified in micro-seconds, so the line in the example above increases the repeat time to 2 seconds. This should ensure that you never get auto-repeat unless you intend it.

     
  3. Power on the virtual machine.

Let me know if this works for you.

Cisco Employee

I tried searching a lot and

I tried searching a lot and was unable to find a solution to this problem.

Not a solution but the only workaround I know is to type the username and password in two lines in a notepad (not notepad ++) copy both together  it and then paste it in. Just make sure no spaces are copied.

Since, I didn't find any solution been using this and it works for me.

Once you are working on it there are some commands for which you might have to do the same.

example : clear ip ospf, where it takes two enters after u issue enter after the command. Copy and paste yes or no in a notepad along with the command and paste it in.

 

New Member

This work for my in putty, go

This work for my in putty, go to Terminal > Keyboard and select VT100+, then under features mark the option "Disable remote-controlled character set configuration" later under Connection > Telnet unmark the option "Return Key sends....."

HTH

New Member

 encountered this situation

I encountered this situation also. And I've resolved it.
I think this is a setting problem of termianl emulator like Putty or Secure CRT In my case.
this is my solution.
1. if you use Putty, V check here that [ Category : Connection / Telnet Return key sends Telnet New Line instead of ^M]
2. if you use Secure CRT, Select here that [ Options / Global Options / General-Default Session / Edit Default Settings.. / Termail-Emulation-Mode/ marking V to New Line mod in Intial modes.

632
Views
2
Helpful
4
Replies